XA2 EMMA Recovery - 'No Matching Services'

Is it simply that the recovery file isn’t located in your “platform-tools” folder where your command prompt it’s trying to find it? Do you need to copy it into that folder and rerun the code?

If that’s not the answer, can you please copy the exact error as a reply?

Fastboot flash recovery twrp-installer-3.7.0_9-0-mermaid.img

fastboot: error: cannot load ‘twrp-installer-3.7 0_9-0-mermaid.img’: Permission denied


  1. Are you using linux or windows?
  2. Is the device unlocked? In fastboot mode type fastboot oem device-info
  3. Do you need to open CMD as administrator? In the start menu type “CMD” right click on CMD and select 'run as admin…"
  4. Lineage have this not on their page, does it affect you:

Note: Outdated fastboot releases dropped legacy A/B support, so it might attempt to flash to boot__a / boot__b rather than boot_a / boot_b if you try to flash boot . In this case, you must update fastboot to a release newer than or equal to 31.0.2 . Alternatively, you can manually specify which slot to flash to based on what slot fastboot failed to flash to. For example, if fastboot fails to flash to boot__a , you must flash to boot_a .

  1. Windows

  2. To the best of my knowledge yes but this is what i get.

fastboot devices
CQ3001TJXQ fastboot

fastboot oem device-info
FAILED (remote: ‘unknown command’)
fastboot: error: command failed

3 no

4 no

Alternating successful and unsuccessful commands like that means you have “the USB3 problem”.

I think I got it wrong with fastboot oem device-info, as maybe Sony devices can’t recognise that command.

I can’t think of any other way to help sorry. If you’re using a USB2 port, and you should have a bootloader unlocked device by the fact that you managed to install Sailfish, so I’m not sure at this point. The only other thing I can suggest, outside of all previous suggestions, is updating your ADB/Fastboot tools.

Using the latest fastboot tools.
Thanks for the help anyway.

Finally decided to try to get this done again and fimally did it. Found a link to a post in xda forums that pointed me to “newflasher”. It worked perfectly once i worked out a couple errors on my part.
Now i have to try and find a link to android 9 so i can downgrade in order to re flash sos.

@Ride92 if I lock the bootloader, SFOS won’t boot, correct?
Can I unlock it back later and still boot SFOS? (I just want to check if it works in Emma)