XA2 bricked with unsuccessful update to

Those are described in bug reports here. Looks like phonehook was the culprit for your bricked phone. Storeman has to be re-installed. And I lost many configurations that are back to factory. But all that was mentioned in various bug reports already. With fixes.

Maybe these steps can help some of you out of bricked state:



Now, since AlienDalvik Control is an essential app used by the majority of SailfishOS users, would not it be the case to test the update on devices having it installed, before releasing to early access? Or better yet, include AlienDalvik Control functions as standard in SailfishOS.

We have tested and written the disclaimer to the release notes at [release notes] Pallas-Yllästunturi 3.4.0. It says that the latest version of Aliendalvik Control works ok on 3.4.0 whereas the previous versions cause problems.


yes, but a bit careless from Jolla no neither check nor give warnings.

I wonder if you read the release notes? There were problems with the same app in the case of the previous OS update, too.


In my case it was not the AlienDalvik Control installation the problem … but the fact, there was 2 versions of it ! During the update, the management didn’t succeed to delete the both. I understood that when I was enforced to complete ‘rpm -e --noscripts aliendalvik-control’ with the full name of the rpm.
The new update of the version didn’t get any problem.

1 Like

We have tested and written the disclaimer to the release notes at [release notes] Pallas-Yllästunturi 3.4.0. It says that the latest version of Aliendalvik Control works ok on 3.4.0 whereas the previous versions cause problems.

You are right, but the release notes came out a bit late so many people got the issue. I always read the release notes thoroughly before updates and I guess most early access users do. Luckily for me, I read the warning from @coderus and avoided the issue.

1 Like

Yes, I later read that the issue was with the fixed version released in the morning.

I don’t, like many others I guess. But it also baffles me that nobody at Jolla has seen this coming.

I got this resolved, for who is interested:

  • my libzypp was updated, but not the PackageKit packages
  • below /home/.pk-zypp-dist-upgrade-cache/packages/ apparently all update packages were still present
  • I installed all PackageKit rpms I found, so pkcon etc. seemed to be working again
  • Stress on seemed, because it failed to refresh from jolla repos, as store credentials were not available. Perhaps some other package needed to be upgraded for it to work?
  • I ended up installing all the rpms from the cache (except those from openrepos repos, filtered out that path) via zypper. All at once did not work, conflicts were not resolved. So I did it batch by batch per hand (based on the conflicts described), until every rpm was installed.
  • it took ages, but the upgrade is complete and i am happy

Where can I download the old zip file for the 3.3 release? The Download section only offers the links for 3.4.

For what reason one flags above post?

Jolla only provides the current release to download in their shop.

And it seems the new release will come out soon™ (just noticed: it is out now) as it as it is the one provided now.
No chance to get an older release anymore…

@Que How do you see that? It would be helpful to see the reasons a post is flagged.

And in the context of this thread and experience of an unsuccessful update I do not see this question as offtopic or ‘hijacking’.

1 Like

Thank you, this seems to be working on my Xperia X, too.

From logs my phone has been incompletely updated and seemed to fail because of Aliendalvik-control. What is weird before the update I installed 3.4-compatible version 9.3.1, but 9.3.0 was still installed. I also did ‘cp /usr/lib/zypp/plugins/urlresolver/ssu /usr/libexec/zypp/plugins/urlresolver/’ mentioned by @abranson.
After removing both (from recovery mode) it still doesn’t, probably because the update was incomplete.
How can I perform the update from shell in recovery mode?
Or is what @blizzz posted above my only choice? I can’t follow his instructions, because I don’t have the folder he mentioned.

Did you figure out a way to do it easily?
I had the same difficulties and went the route described by @blizzz and installed/updated everything manually from the download cache (except I used pkcon install-local instead of zypper, because zypper was just way too slow for some reason).
SFOS updates seem to be getting more and more difficult to install for me…

good hints. i managed to remove the aliendalvik-control-rpm and could fix the error regarding missing stuff about “plugin:/ssu?repo=adaptation0” by copying the ssu binary.

and then i managed to do the upgrade with

ssu re
version --dup

that last step took about an hour. now the phone looks ok again!

thanks a lot

I managed to unbrick my phone after whole day of trial and error, so I will post the steps how I did it:

  1. Getting into shell of Recovery Mode (it is quite likely I didn’t need to do that, and could just skip to 2.)
  • I got into recovery using this guide
  • After doing telnet I selected shell and then did chroot /rootfs /bin/bash, which took me a lot of time to figure out, and was the reason why many commands didn’t work.
  • cat /var/log/systemupdate.log to see what actually caused a problem, in my case it failed because 2 versions of aliendalvik-controll were installed, for some reason
  • rpm -e --noscripts aliendalvik-control-9.3.0 and rpm -e --noscripts aliendalvik-control-9.3.1 to get rid of the culprit and rpm -e harbour-storeman just to be sure.
  • exit reboot and try to SSH to a normally booted phone
  1. SSH into working phone (I was very lucky I was able to do that)
  • boot the phone up and look into router controller panel to get phone’s IP adress (hopefully it automatically connected to the network)
  • ssh nemo@[youe_IP_adress]
  • devel-su then pkcon refresh and reboot and my phone booted up! But work isn’t done yet, as my phone wasn’t fully updated and many apps didn’t work
  • install sfos-upgrade and do sfos-upgrade --verify which completed update and everything worked after that. Then I reinstalled storeman and aliendalvik-control and had no problems since.
    This certainly isn’t a guide, many things could be done better and it could not work on your phone as it might be at a better state, but I hope it could help you out.
    Also after experiencing all those problems I really recommend using sfos-upgrade as if I had used it I would see the update failed, would be able to remove problematic packages and do the update properly without having an unbootable phone.

Oh god man, you’re my saviour :slight_smile:

Got exactly the same pb as yours on jolla 1… No aliendavilk even installed, everything was a green light, every partition less than 50% full, now really angry against sailfish…

I am following your steps, I hope I’ll sort this out too!

Perhaps some other package needed to be upgraded for it to work?

I got some errors like you while trying to refresh packages after installing packagekit; they were solved by installing these 3:
rpm -Uvh ssu-1.0.8-1.17.8.jolla.armv7hl.rpm ssu-declarative-1.0.8-1.17.8.jolla.armv7hl.rpm ssu-network-proxy-plugin-1.0.8-1.17.8.jolla.armv7hl.rpm

I am fighting with ugliness here, both packages found in the cache are providing incompatible deps :frowning:
rpm -qlR telepathy-accounts-signon- | grep libaccounts-glib

rpm -qlP ./libaccounts-glib-1.24+git3-1.6.4.jolla.armv7hl.rpm | grep libaccounts-glib.so

but after uninstalling a bunch of all the ones requiring libaccounts-glib.so.0, a:

pkcon update

did the job.

Thanks for you insight, let’s hope that not too much people will land in this post!

1 Like