XA2 bricked with unsuccessful update to 3.4.0.22

REPRODUCIBILITY (% or how often): unknown
BUILD ID:
HARDWARE (Jolla1, Tablet, XA2,…): XA2
UI LANGUAGE: English
REGRESSION: (compared to previous public release: Yes, No, ?):

DESCRIPTION:

ran the update after warning backup unsuccessful the backup gave a splash screen update ddi not install. restart however restart seem not possible, screen remains black. Couple times I was able to get the sony unlocked message.

PRECONDITIONS:

Well, it’s a XA2 with some patches and patchmanager and phonehook installed.

STEPS TO REPRODUCE:

  1. take a XA2 with Sailfish OS 3.3
  2. leave your patches, phonehook installed
  3. run update to 3.4.0.22

EXPECTED RESULT:

of course I hoped for a running system on 3.4.0.22

ACTUAL RESULT:

looks like a dead phine. Vol up + switch will signal three times but not turn on the screen

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

1 Like

well it looks like Vol up + switch screen remains blank.
on by switch only shows the bootloader warning, the sony logo on white screen, then a few on-off (white/dark) screens, then the phone will remain dark.

by any chance did you have aliendalvik-control installed?
Someone on the Telegram channel had the same issue, and @abranson mentioned this could be the issue.
Can you SSH into the XA2?

yes aliendalvik-control was installed. So far I am afraid I can’t ssh. Switch on it goes dead after the sony splash screen, boot into recovery (volume up + power) screen remains black but with green LED when power cable gets attached.
Not very promising… (but now it’s time to learn to SSH)

I successfully bricked my XA2 the same way. I have SSH access. What can I do now?

omg. I’ll wait with the update on Xperia 10 Plus than.

If you have aliendalvik-control installed, it can either leave a bootup service installed that now blanks the screen in 3.4.0, or cause the update to fail half-way through.
If your upgrade was successful, but your device now boots to a blank screen, then you could try removing aliendalvik-control either over ssh with ‘rpm -e --noscripts aliendalvik-control’ (as root) or if you can only get in via recovery mode then remove the file ‘usr/lib/systemd/user/aliendalvik-control-edge.service’ as root then do the full removal when booted.
If the update failed mid-way through and will not resume, then it might be the case that your libzypp package was updated while ssu wasn’t, which breaks repo resolution. In this case, people have had some luck running ‘cp /usr/lib/zypp/plugins/urlresolver/ssu /usr/libexec/zypp/plugins/urlresolver/’ as root, then trying to update again.

7 Likes

I did not have any problems when updating the XA2, Xperia 10 and tablet. It went all smoothly and Android Support including Signature Spoofing and MicroG are there and totally uncompromised

Therefore, it is not the update itself that causes the problems but rather apps like AD control et alia

Now, since AlienDalvik Control is an essential app used by the majority of SailfishOS users, would not it be the case to test the update on devices having it installed, before releasing to early access? Or better yet, include AlienDalvik Control functions as standard in SailfishOS.

1 Like

yes, but a bit careless from Jolla no neither check nor give warnings. With hardware tied license even more. I appreciate Jolla doing updates often, but they always break quite some stuff, too, and it’s well known everybody uses patches and AlienDalvik and else.

3 Likes

I bricked my XA2 Plus too H4493, dual sim 64 Gb.

“Update unsuccessfull”, automatically reboots, then now stuck at sony logo.

Try to use fastboot (as a message on together jolla website suggests on previous similar issues for XA2), driver installation is not working properly (Android device recognized with a “!”, like the tutorial suggests, then when manually installing Xperia X driver, at the very end, after a so called successfull installation, the device still is recognized as an android device (but then with a “?” on the logo, and a message in the device properties telling something like this device seems not to need any driver)… So it seems that fastboot is no more an option for me.
I did not try on a macos or Linux computer, but tried on two windows 10 computer, and device plugged on USB3 and the on USB2 ports.

Tried Emma tools. Device is recognized (there may be hope?), but H4493 seem to be a non supported device (!) So I am stuck too.

Tried Xperia companion. Device is recognized as unlocked, so no dice.

I never owned an android device (I mean, I have no experience on it, especially on rom flash or so. The only time I did that was for sailfish OS, and I just follow the instructions) so I am quite hopeless for now. Any suggestion? Other than buy another phone of course?

Edit: Ah, I forgot to say. No patch installed. A few apps from openrepos, but nothing known to create such mess.

Edit 2: Tried to install XA2 Plus driver on a third PC, with windows 10 pro 1904 (the two first have version 2004). Driver is working properly (maybe something to do with 2004 windows version; the first computer I tried was the one I used to flash my phone years ago and nothing really change on it except windows version), so I am back to sailfish 3.3. Will try now to update to 3.4 in a vanilla state, without installing anything, since I still own a jolla C and can use it for now. Hope it will work properly!

I dont manage to remove Aliendalvik Control. Looks like a double installation.

[root@Sailfish nemo]# rpm -e --noscripts aliendalvik-control ERROR: ld.so: object ‘/usr/lib/libpreloadpatchmanager.so’ from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
error: “aliendalvik-control” specifies multiple packages:
aliendalvik-control-9.3.0-1.armv7hl
aliendalvik-control-9.3.0-2.armv7hl

Update: I’ve tried a few things erratically like a pkcon refresh and version --dup
All returned some errors.
Meanwhile, the phone became operatinal again (display). I then tried, to remove Aliendalvik Control from Storeman. This didn’t work as well. I made a successful restart then. The phone is operational now again and I’m still on 3.3.

Update: I just realised that my keyboard does not work in Android apps anymore.

Update: Meanwhile, after some unsuccessful attempts, I don’t get my phone working again. I only have SSH access. Can I reset it from SSH to start again from scratch? I’m a bis deperate now.

1 Like

so far, no success with fastboot blue LED press buttons attach usb gives green LED.

Have you tried a pkcon refresh?

Had the same issue. This seems to be happening because of failure of update in the Storeman.

Seems that removing one by one works fine, so just do:

rpm -e --noscripts aliendalvik-control-9.3.0-1.armv7hl
rpm -e --noscripts aliendalvik-control-9.3.0-2.armv7hl

2 Likes

good news! IT’S NOT BRICKED
thanks to realizing only vol up button triggers fastboot mode (not vol up + power), I was able to get a blue LED and flashed my device to Sailfish OS 3.3
Of course lost lots of stuff, as usual.
But even from a brand new OS 3.3, update to 3.4 failed at first try.

3 Likes

This doesn’t work as well:

[root@Sailfish nemo]# rpm -e --noscripts aliendalvik-control-9.3.0-1.armv7hl
ERROR: ld.so: object ‘/usr/lib/libpreloadpatchmanager.so’ from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
[root@Sailfish nemo]# rpm -e --noscripts aliendalvik-control-9.3.0-2.armv7hl
ERROR: ld.so: object ‘/usr/lib/libpreloadpatchmanager.so’ from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
[root@Sailfish nemo]#

Thanks @DragonLich !
I was able to ssh.
devel-su
rpm -e --noscripts aliendalvik-control-9.3.0-1.armv7hl
rpm -e --noscripts aliendalvik-control-9.3.0-2.armv7hl
pkcon update #installed something
version --dup #downloaded but:
#UPGRADING SYSTEM
#Finished transaction (status=2, runtime=227ms)
#NO UPDATES FOUND. Try again later
version --dup #started installing previously downloaded stuff
shutdown -r now #reboot

Everything seems to work.

Similar issue, stuck at Sony screen. I removed aliendalvik-control beforehand, but I was having some remnants of flatpak – looks I didn’t remove it weeks before properly. So I saw messages about some libs (but perhaps this was also due to the semi-upgrade?). Got around them by symlink-and-pray

ln -s /usr/lib/libicui18n.so.66 /usr/lib/libicui18n.so.63 
ln -s /usr/lib/libicuuc.so.66 /usr/lib/libicuuc.so.63

Now however I am stuck with a broken backend for PackageKit, likely what @abranson mentioned before. Sadly, copying around the ssu file does not help. That’s what I am having now:

Failed to load the backend: opening module zypp failed : /usr/lib/packagekit-backend/libpk_backend_zypp.so: undefined symbol: _ZNK4zypp3sat10LookupAttr8iterator9dip_equalERK13_DataiteratorS5_, version ZYPP_plain

I finally got my XA2 working again under 3.4 now. However, Android Support is not working. Storeman is also not working. I also still get error messages in Terminal with nearly every command. Seems that is related to Patchmanager.

1 Like