[X10 II] Vivaldi and Brave freeze

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): X10 II
REGRESSION: (compared to previous public release: Yes, No, ?): No?


Vivaldi browser (and snapshot too) hangs on X10II and closes shotly after. Reportedly, Brave does the same thing.


  1. Have X10 II
  2. Have Android support installed
  3. Install Vivaldi from Download Vivaldi | Vivaldi Browser


  1. Start Vivaldi
  2. Browse site of your choice


  1. Browser works and is responsive (enough)


  1. After some half a minute or so the browser freezes and closes


Vivaldi works as expected on XA2 / XA2 Ultra on SFOS, so aarch64 could be the root dfference.

Unfortunately, the same on my X10-II.


I have the same issue. But with English UI and Swedish locale.

Ditto. I got the same specs and I can second on everything except snapshot which I don’t use. As an extra notion, I got microG up and running.

And when I try to maximize the minimized frozen Vivaldi app from the home screen, every open app will disappear from the home screen, and they will become visible again only after swiping the screen from the side.

When I run

lxc-attach -n aliendalvik --  /system/bin/logcat

in the Terminal after the Vivaldi freezing, the Terminal gets flooded in repeat with

ServiceManagement: getService: Trying again for android.hardware.drm@1.0::DrmFactory/clearkey…
ServiceManagement: Waited one second for android.hardware.drm@1.0::DrmFactory/clearkey

until I kill Android Support from the Settings

The same thing happens with Chromium. (Not surprising, with Vivaldi using the Chromium engine.)

1 Like

I tried both 32-bit and 64-bit apk packages from the download page, they function identically in this case.

I tried Brave browser as a replacement but it freezed on me similarly. Then I realized Brave too is based on Chromium.

I think in all Chromium-based browsers this happens in logcat right before those flooded android.hardware.drm messages:

cr_media: Create MediaDrmBridge with level L3 and origin 0C7A0D28C27C9DEC5076EB6A57452
07-03 13:27:04.525 65 112 E cutils-trace: Error opening trace file: No such file or directory (2)

Methinks it is a Chromium-related DRM issue. Creating MediaDrmBridge fails?

Funny thing. Bromite seems to work without the issue though it essentally should be Chromium with better privacy. Might be Bromite has had work done on the DRM-thingy.

If you’re into using Chrome-esque browser, you might want to check out Bromite (from F-Droid, need to add Bromite repository).

And then not so funny thing: DNA TV also does the same DRM factory related failure when I try to watch a pay channel like Cmore Max in it.

This DRM failure does not happen when I try to watch the channels of the public broadcaster Yle in the DNA TV app.

There is something wrong in the DRM handling for the Android apps when run on Xperia 10 II.

1 Like

Seems to be fixed in 4.2!

1 Like