[Release notes] Verla 4.2.0

I tried this with two Xperia 10 II phones, one running (updated OTA from and another running 4.3.0.x (the upcoming OS release). On both phones, call audio was automatically connected to the JBL TUNE750BTNC headset.
This worked okay both for incoming and outgoing calls.

Music playback worked, too. In addition, I watched a video stream from YLE Areena for 1.5 hours with the JBL headset without any hassle.


And again… Sometimes wifi with android apps works, sometimes it doesnt… I dont get it. XA2.


Thanks for the reply! TL;DR Now it works for me, too! But why?

Longer story:

I first tested my paired device once again; calls didn’t work. I then opened /var/lib/bluetooth/[MAC]/info and noticed that HSP was the last item on the list. I turned off Bluetooth, moved it first on the list, connected again, and lo and behold - calls worked!

Then I did several cache cleanings, order changes and pairings, and couldn’t make it not work again. The placement of the HSP profile in the list varies, and it doesn’t seem to affect the result anymore; it just works. Oh well! It works, and that’s the important bit :+1:


i’ve belatedly noticed this new blog post about 4.2:

Does this mean it is actually out?
Jolla’s marketing serves only to confuse me…

1 Like

Yes, it’s out, check the opening post for details :slight_smile:

But you are correct. I didn’t notice that the EA had turned into public release until two days after.

If we consider the blog post to be “the official announcement to the masses” (as the forum thread is created at first EA), then subscribing to the RSS feed helps. Which I may or may not just have found out about myself :sweat_smile:


These two bugs were fixed with, could you add them to the list?

I’m trying to install the update on a Xperia 10.
The update does not start because I don’t have enough free space in my system partition. Required is 500MB and I only have 309,8MB. When I look at the details, I see Sailfish-apps use up 248,3MB. So basically I have to remove all Sailfish apps to be able to update. I clearly don´t want to do that.

Is there another way I can update? Seems like the system partition is just way to small.

  • problem: Contacts in People no longer show pictures. The only way to add picture is to take a photo…

I have the same or similar issue. Some/many avatar pictures are missing (but not all) from the ‘People’ application after the upgrade to on my Xperia XA2. I suspect it is the older avatars where the original picture each avatar was created from is no longer present in the gallery.
Currently trying a restore from backup to see if that helps…

Edit to add: Restore from backup did not fix the problem. I’m going to have to use some developer access. It looks like a recurrence of a known upgrade bug that occurred with Kvarken (

At least I have an old backup that I should be able to restore the avatars from. Sigh. Another entry on my to-do list.


I must admit, I’m not a fan of the new display of open tabs in the browser. If there is a way of reverting to the old style, I’d like to know.

The new one shows more of the page for each of the web-page tabs. Which is nice, but means with my large number of open tabs, it makes navigation difficult, and I find it more difficult to retain ‘context’ of where I am in the list of tabs. Frankly a simple scrollable list of (full) URLs would be more useful to me with an option to show either no thumbnails, small thumbnails or BIG THUMBNAILS (which is the present look).


Where is the opening post?

Does that mean that the SFOS turns into current official release by definition and not by any change or new version since

I have since it was EA released, and now phone says ‘no update available’.
Are there now any changes between EA (abt 2 weeks ago) and now? Should I do an update by command line, because the updater (settings/updates) doesn’t see anything new. I ask because I don’t want to miss anything.

Where is the opening post?

It’s the first post in this thread.

Does that mean that the SFOS turns into current official release by definition and not by any change or new version since

As far as I know, yes.

I have since it was EA released, and now phone says ‘no update available’. Are there now any changes between EA (abt 2 weeks ago) and now? Should I do an update by command line was released to EA on 2021-09-13 and for all three days later. My phones don’t find any updates via Settings nor terminal, so they are up to date.

1 Like

should i be worried in my XA2 Plus has the upgrade progress bar stuck at nearly 100% complete for twenty minutes now?


I’m not impressed*.

It appears the upgrade process dropped the email cache, and reverted server passwords to ‘default’. I have a lot of emails, and having to scroll to the bottom of the screen and select ‘Get more emails’ to get them back on-device is a big chore**. And it looks like the read/unread flags have gone, so all the emails downloaded (again) show as unread.

*Don’t get me wrong. I a BIG fan of SailfishOS and Jolla, so I hope my feedback helps to improve things for everyone in future.

**Would be nice to have a ‘download all emails option’ or ‘download emails’ where ‘n’ can be varied by the user. And while I’m at it, having collapsible folders in the folder view would be useful.

Edit to add: turns out I was wrong about the unread flag. Ii just turned out the most recent emails in my inbox were all unread. Spending too long on upgrading the phone, I guess.

1 Like

Downloading the whole inbox sounds like a nice feature to have. Could you create a bug report for it?

Before you re-enter all the passwords, give the device another reboot first.

1 Like

Don’t worry, 20 minutes is in the normal range. Before an hour of no proceeding, i suggest to simply wait and do nothing.

1 Like

Sorry, too late. I did do a full power-off restart before entering the correct passwords.

However, it could be that the restore from backup to try and solve the missing avatars in the People app issue mucked things up.

With regard to creating a bug for the requested inbox feature, I will: but not immediately as I have to do all the stuff I put on hold to upgrade the phone (smile). I would recommend having a ‘download further emails’ feature, rather than just the whole inbox, as some inboxes are rather large. I just checked on my desktop PC, and the IMAP folder is 2.2 GB in size. It is not unusual for me to need to go back more than 5 years to find stuff relevant to what I am doing today.

Restoring a backup which contains accounts clears all saved passwords, this is by design.

When I quick-scrolled to the end of my inbox, in the bottom pull-up menu there’s an option to get more messages. Is that not what you meant?

1 Like

My install got stuck for about 2 hours (the progress bar looked to be at 100%). I got a little impatient and just restarted the device. it booted successfully and it looks like I have 4.2 now installed.

Is there anything I should check or is there any way to find out if my system is actually completely updated?

Ps. i restarted because i thought my phone was bricked and i need to reflash

1 Like

this is where I am, it is now three hours later and my phones progress bar for the flashing is still stuck at/near 100%.

seems like you faced a similar situation and emerged unscathed, so I might as well restart mine too with fingers crossed… not like I can leave it there forever!

[update] is there a key combo to force a reset on an XA2 Plus, because it doesn’t seem to respond to the power button alone right now…?

Well i have a XA2 Ultra but for me power + volume up + volume down worked.
i hope everything works for you!

1 Like