Whisperfish - The unofficial SailfishOS Signal client

I don’t have any media files in there:

[nemo@Sailfish ~]$ du -sch .cache/be.rubbos/harbour-whisperfish/defaultuser/
du: .cache/be.rubbos/harbour-whisperfish/defaultuser/: No such file or directory
0	total
[nemo@Sailfish ~]$ du -sch .cache/be.rubdos/harbour-whisperfish
4.0K	.cache/be.rubdos/harbour-whisperfish
4.0K	total
[nemo@Sailfish ~]$ du -sch .cache/be.rubdos/harbour-whisperfish/
4.0K	.cache/be.rubdos/harbour-whisperfish/
4.0K	total
[nemo@Sailfish ~]$ du -sch .cache/be.rubdos/harbour-whisperfish/^C
[nemo@Sailfish ~]$ du -sch .cache/harbour-whisperfish/
23.2M	.cache/harbour-whisperfish/
23.2M	total
[nemo@Sailfish ~]$ du -sch .cache/harbour-whisperfish/ -al
23.2M	.cache/harbour-whisperfish/
23.2M	total
[nemo@Sailfish ~]$ du -sch .cache/harbour-whisperfish/
23.2M	.cache/harbour-whisperfish/
23.2M	total
[nemo@Sailfish ~]$ ls -al .cache/harbour-whisperfish/
total 12
drwxrwxr-x    3 nemo     nemo          4096 Feb  3  2021 .
drwxrwx---   53 nemo     nemo          4096 Apr 26 10:35 ..
drwxrwxr-x    4 nemo     nemo          4096 Feb  3  2021 harbour-whisperfish
[nemo@Sailfish ~]$ ls -al .cache/harbour-whisperfish/harbour-whisperfish/
total 16
drwxrwxr-x    4 nemo     nemo          4096 Feb  3  2021 .
drwxrwxr-x    3 nemo     nemo          4096 Feb  3  2021 ..
drwxrwxr-x    3 nemo     nemo          4096 Feb  3  2021 .QtWebKit
drwx------   10 nemo     nemo          4096 Mar 24 14:38 .mozilla
[nemo@Sailfish ~]$ ls -al .cache/be.rubdos/harbour-
harbour-taak/        harbour-whisperfish/
[nemo@Sailfish ~]$ ls -al .cache/be.rubdos/harbour-taak/
total 8
drwx------    2 nemo     nemo          4096 Mar 26 18:46 .
drwx------    4 nemo     nemo          4096 Mar 26 18:46 ..
[nemo@Sailfish ~]$ ls -al .cache/be.rubdos/harbour-whisperfish/
total 8
drwx------    2 nemo     nemo          4096 Feb 12  2021 .
drwx------    4 nemo     nemo          4096 Mar 26 18:46 ..

The only thing I can come up with is the location for received attachments. Those, by default, go into .local/share/harbour-whisperfish/storage/attachments.

Are these files you find media files you created on the phone and then sent to someone? I recall there was some discussion about whether to copy them to a dedicated WF directory, but decision was against if I recall correctly.

Thanks for replying so fast.
Very strange…
No, I didn’t send as many files. Maybe 1 or 2 pics, just for testing.
Thinking now: I was not able to setup whisperfish as simple user (vs Device Owner/defaultuser), as ssh is not possible there, so I had co rsync whisperfish dirs from /home/defauptuser to home/newuser (and chowned them). If there was some links to media dirs or so or maybe some wrong command I did?
Anyhow, I deleted them and it’s ok now.
Also thanks again for WF!

Edit:
Apologies.
Found in term history: I had inversed a cp command.
:man_facepalming:

1 Like

Haha, that kind of archeological work is always fun :slight_smile:

1 Like

Whisperfish recently stopped working for me with:
[defaultuser@Xperia10II-DualSIM ~]$ harbour-whisperfish
[2022-05-06T05:53:01Z ERROR harbour_whisperfish] The name be.rubdos.whisperfish was not provided by any .service files
[defaultuser@Xperia10II-DualSIM ~]$

Even reinstall wouldn’t fix.
Any ideas/ suggestions, anyone?
Thanks!

Hi. So sorry for the delay, I was pretty sick with flu; I produced a few negative covid tests instead of code. Back alive and kicking, mostly, now.

Reinstall typically doesn’t fix anything on Linux systems. Can you run harbour-whisperfish --verbose and report back?

4 Likes

Oh, sorry from my side as well.
It started working again and I don’t know what it was. Might have been a frozen daemon since I can still reproduce the error message by trying to start a second instance while whisperfish is already running. Or I’ve been just stupid and I didn’t realize the first whisperfish instance while trying to start the second:-)
Thanks for your reply and all the best. Seems like we all to go through this Covid thing…

Ah, maybe you updated Whisperfish while it was still running in daemon mode. That’s apparently a thing.

Funny thing is, I had COVID a few weeks ago, and that wasn’t nealy as bad as this flu. I mean, it was bad and I was very glad to have had the vaccine, but now I’m a bit sad I didn’t get the flu shot when I had it offered too :’-)

3 Likes

I’ve pushed beta 9 to OpenRepos, which contains a bunch of fixes for stuff that happened in beta 8. I’ve pushed this out because we’re going to be rewriting some stuff again, which we want to decently test before pushing that to you guys :slight_smile:

8 Likes

So, looks like I forgot to hit save on the OR interface. I did that now :slight_smile:

1 Like

App Crashes when I try to send sms with 6digit code to my phone number

More or less the story of my GF who had a really mild case of covid, followed a couple of weeks later by the flu that put her to bed. It took two weeks to get over the flu.

I hope you’re well again!

2 Likes

There’s a workaround here: Registration Workaround · Wiki · Whisperfish / Whisperfish - Signal on Sailfish OS · GitLab

It took until this Monday, but I feel better now :slight_smile:

Hello, I tried the registration workaround on my new Xperia 10 III, but unfortunately, it didn’t work.

Whisperfish closed with the following output:
[2022-05-25T18:17:00Z INFO harbour_whisperfish::worker::setup] Using override captcha signalcaptcha://signal-recaptcha-v2.6LfBXs0bAAAAAAjkDyyI1Lk5gBAUWfhI_bIyox5W.registration.03AGdBq249-db20o6qONnk-WrjvcNwHmQTiO8MSs5gT8-jPGdExK_IwqEGJSLiizeWGUw7Pc8aWzS8rYAjt-fAqaVYHNVnauNu6mGHdtlLcCnXYa1dRjRMG12wAKsUEP1ynsrrYrkUJ8e2Y3sXZLhizMk3oo_rTHvcY3RfOrr5sS0wDkgxxKv7kE2jWoKpwMOfa2X9A5LL7JQ6GKT9RySzJlo6qDPfwa-2EWGyIMb0KxuxVdqeO8LTJZMTCM9Jg_KFYemIaSoVPYqWUxZ78TEdQtw_-qFkNWEluKvv7bynrYsbwKOoxyDWSsd45O6ko7C2Yy-AzVqc5WDEjqaB3nd8WYpQrqYbJrW2ODgR1Xt3MSitB_YHNNY3r_Mx7d0Hk5w1yf-pKO58J-_P8Pjg7wdx7KkWm-5RenLECzco-enrAEQVOVaDa8Q6W6cmK2ZL-4C7J4MvfaLOS_Kcknb7k4bN8ViqHEFnsUjSkooSu0NCa2rY8_m6pO0WIf3X_e8ahy_Kf9xn-Y49l1t6I4rMX7b03jWcxsrFXPSD-qiQ5OCKO-L0V-XnV6l_WULevbjGbRNj_6GLf3yYQV5i2U2l9uj6uONqIezVTKLlsHFx8t2tKJJgATiQGcpUKOJ3rcyB3Kq2mkerNIFLjd6vzKAafdqL14fVxqA-7G-6FLykTlnjmBJmQrtXFqXmfHqbh5n8ktL7IZRjhO5ybCl_hNOfB1j11XdCTTJqVJ18vexglfHuuFG2MvpVZXX-EmhpNfkLVjWk27jZEs4oz739Ck9n5vloVn9Zi_VRGoESbMdNvnzLgIOD3zuEtYm5J-0EWf9F6WQF7EOmXd80oK1ni-ugHK48CIUnYAjfXYqQymKAyB0zQiZUE4sbz3uIofBI3

[2022-05-25T18:17:00Z DEBUG libsignal_service_actix::push_service] HTTP request GET https://chat.signal.org/v1/accounts/sms/code/+43XXXXXXXXXX?captcha=signal-recaptcha-v2.6LfBXs0bAAAAAAjkDyyI1Lk5gBAUWfhI_bIyox5W.registration.03AGdBq249-db20o6qONnk-WrjvcNwHmQTiO8MSs5gT8-jPGdExK_IwqEGJSLiizeWGUw7Pc8aWzS8rYAjt-fAqaVYHNVnauNu6mGHdtlLcCnXYa1dRjRMG12wAKsUEP1ynsrrYrkUJ8e2Y3sXZLhizMk3oo_rTHvcY3RfOrr5sS0wDkgxxKv7kE2jWoKpwMOfa2X9A5LL7JQ6GKT9RySzJlo6qDPfwa-2EWGyIMb0KxuxVdqeO8LTJZMTCM9Jg_KFYemIaSoVPYqWUxZ78TEdQtw_-qFkNWEluKvv7bynrYsbwKOoxyDWSsd45O6ko7C2Yy-AzVqc5WDEjqaB3nd8WYpQrqYbJrW2ODgR1Xt3MSitB_YHNNY3r_Mx7d0Hk5w1yf-pKO58J-_P8Pjg7wdx7KkWm-5RenLECzco-enrAEQVOVaDa8Q6W6cmK2ZL-4C7J4MvfaLOS_Kcknb7k4bN8ViqHEFnsUjSkooSu0NCa2rY8_m6pO0WIf3X_e8ahy_Kf9xn-Y49l1t6I4rMX7b03jWcxsrFXPSD-qiQ5OCKO-L0V-XnV6l_WULevbjGbRNj_6GLf3yYQV5i2U2l9uj6uONqIezVTKLlsHFx8t2tKJJgATiQGcpUKOJ3rcyB3Kq2mkerNIFLjd6vzKAafdqL14fVxqA-7G-6FLykTlnjmBJmQrtXFqXmfHqbh5n8ktL7IZRjhO5ybCl_hNOfB1j11XdCTTJqVJ18vexglfHuuFG2MvpVZXX-EmhpNfkLVjWk27jZEs4oz739Ck9n5vloVn9Zi_VRGoESbMdNvnzLgIOD3zuEtYm5J-0EWf9F6WQF7EOmXd80oK1ni-ugHK48CIUnYAjfXYqQymKAyB0zQiZUE4sbz3uIofBI3
[2022-05-25T18:17:02Z DEBUG libsignal_service_actix::push_service] AwcPushService::get response: 
    ClientResponse HTTP/1.1 402 Payment Required
      headers:
        "cache-control": "must-revalidate,no-cache,no-store"
        "content-length": "418"
        "date": "Wed, 25 May 2022 18:17:02 GMT"
        "connection": "keep-alive"
        "content-type": "text/html;charset=iso-8859-1"
        "x-signal-timestamp": "1653502622093"
    
[2022-05-25T18:17:02Z TRACE libsignal_service_actix::push_service] Unhandled response with body: Ok(b"<html>\n<head>\n<meta http-equiv=\"Content-Type\" content=\"text/html;charset=ISO-8859-1\"/>\n<title>Error 402 Payment Required</title>\n</head>\n<body><h2>HTTP ERROR 402 Payment Required</h2>\n<table>\n<tr><th>URI:</th><td>/v1/accounts/sms/code/+43XXXXXXXXXXX</td></tr>\n<tr><th>STATUS:</th><td>402</td></tr>\n<tr><th>MESSAGE:</th><td>Payment Required</td></tr>\n<tr><th>SERVLET:</th><td>jersey</td></tr>\n</table>\n\n</body>\n</html>\n")
greHome from GRE_HOME:/usr/bin
libxul.so is not found, in /usr/bin/libxul.so
Created LOG for EmbedLiteTrace
Created LOG for EmbedLite

Has anybody an idea waht could be the problem here? Thanks in advance

Same problem here, also xperia 10 III.

How quickly did you complete the process? You only have say 20 seconds to enter the details before you are timed out and the code expires.

20s???
I already tried as fast as I could. Maybe I will try it again, this time (hopefully) faster

I’ve tried it again and measured the time. It took me less than 20s and it still didn’t work :frowning:

Has anybody a tip on how to complete the registration faster? (If the time even is the problem)

I doubt time is the problem. I also tried again a few times and I can complete the steps well before the captcha in the browser says ‘verification expired’. I’m putting the ‘prefix’ dropdown to my country code, and then putting my phone number without the leading zero. I assume that is correct because if I put the zero I get an error 400 bad request instead, and whisperfish shows and error and needs to restart.

I’ve been using Whisperfish for a few years now. It’s a fantastic product, and I’m glad to see that it’s being kept alive.

3 Likes

I finally managed to register!! :partying_face:

But now I have another problem: I can correctly receive messages, but I can’t send them. When I try it with --verbose , the last lines read this:

[2022-05-26T18:12:24Z DEBUG libsignal_service_actix::push_service] HTTP request PUT https://chat.signal.org/v1/messages/9d2f3c66-7614-4d3d-82df-93d7ae67c96a
[2022-05-26T18:12:25Z DEBUG libsignal_service_actix::push_service] AwcPushService::put response: 
    ClientResponse HTTP/1.1 428 Precondition Required
      headers:
        "x-signal-timestamp": "1653588745215"
        "date": "Thu, 26 May 2022 18:12:25 GMT"
        "content-type": "application/json"
        "content-length": "88"
        "connection": "keep-alive"
        "retry-after": "86400"
    
[2022-05-26T18:12:25Z TRACE libsignal_service_actix::push_service] Unhandled response with body: Ok(b"{\"token\":\"ac61d6db-7316-483f-8fc6-ee1ebe9956a1\",\"options\":[\"recaptcha\",\"pushChallenge\"]}")
[2022-05-26T18:12:25Z ERROR harbour_whisperfish::worker::client] Sending message: Error sending message: Unexpected response: HTTP 428

Is this new, or has anybody already solved this?

1 Like