WayDroid on SFOS?

Actually it seems to be working after I’ve installed Here WeGo! Lime in its own somehow wasnt triggering positioning.

I would also like to add that I really appreciate the sailfishos-open packaging for this, great work!

Here WeGo! Beta seems to get a half decent location with just an internet connection and location turned on, on my Xperia 10 II. I have yet to install any MLS packs or even go into the location settings section (I just turned it on from the top menu).

I notice that waydroid eats more battery than usual on the fxtec pro1. Anyone else having this problem?

Endurance before and after Waydroid looks more or less the same. But then, I don’t let waydroid apps run in the background. Also, felt like running media in Waydroid consumes fair bit of energy.

1 Like

@lal - question for you, (or anyone [@rinigus])…

When Waydroid was first released in Chum, I already had it installed from your repo, so I just installed the packages from Chum, and dleted my previous Waydroid init directory, etc, and it went on functioning fine.

Now, I’ve clean-flashed, and I installed from scratch using only Chum. Everything works fine, bit there’s no icons, (no Waydroid icon, and no app icons), in the SF app drawer.

I noticed that the file structure is quite different, with Android data in ~, and Waydroid directory in /opt. Maybe this explains it…

Anyone else who’s installed via Chum experiencing the same, or just me?

I’ve installed Waydroid (and also waydroid-settings) from chum and it works just fine.

@Levone1: have you checked README at https://github.com/sailfishos-open/waydroid ?

In this version, Android apps are exposed to SFOS launcher. Waydroid launcher you should get if you follow the README

2 Likes

Thanks @rinigus and @piggz or the integration with systemd scripts. Just as @levone1 I have reused the waydroid install from before chum packages.

What I notice is that if the show full ui fails, clicking on one of the previously created desktop files makes show-full-ui work again next.
(I have not debugged why)

if you execute “waydroid prop set waydroid.active_apps none” after closing the UI and give it a few seconds, you should be able to bring full UI up again.

As I understand it, from conversation in waydroid channel, waydroid doesn’t yet understand if its window is closed in Sailfish OS which would have otherwise run the above command automatically and allowed the UI to be restarted.

2 Likes

Restarting ui working fine for me using waydroid-settings package, after clicking ‘stop daemon’ then short wait and ‘start daemon’.

Anybody else tried GMaps? For me, just opening the app breaks location fix instantly. When the app opens, it shows map with accurate location fix, but then gps fix breaks, and it’s just stuck there. Then, when I close or even just minimize the app, fix comes right back instantly. I did it back and forth 10 or 12 times, and it was consistent …

Tried to test that. Looks like I have similar behaviour here. Having some other app requesting location in the background open seems to keep the fix. Thankfully PureMaps is very mature and suffices my most use cases.

1 Like

True - not a big deal, just checking … Seems like same with HereWeGo…

1 Like

I gathered from the thread, that Telegram works via waydroid? I assume nobody has any experiences with Line, right? (or Line lite)
I have not had time to try to install Waydroid yet, since the process appears quite involved and time consuming, so I wanted to make sure it is worth it beforehand…
edit: got confirmation, so no need to reply, thanks!

Btw, waydroid has its donations open Waydroid - Open Collective (see Telegram: Contact @WayDroid)

1 Like

so I gave this a try using this new and improved tutorial:

but it didn’t quite seem to work. First I tried the settings version, which failed to start (container was running, but the app would just load for a few seconds and then close again instantly)
opened the termina and ran “waydroid show-full-ui”, but just got “failed to get service waydroidplatform, trying again…” (and that would then continue forever)

then I wiped the system and tried the runner version, the app would start, but then it always got stuck on the “waiting for Android UI” message…
any ideas?

I am using a SO-05K (a japanese zx2c) flashed with the H8314 version of SFOS (since the hardware is the same as far as I could tell).

Did you download the image with Android as well? Looking from docs, I presume it was waydroid init. Ref: Ubuntu/Debian Based Install Instructions - Waydroid

yeah, I followed the instructions and used “devel-su waydroid init”, which then downloaded about 700?+ mb, basically the stock lineage image (I think it said lineage 17.01) used for this
My phone is not on the official supportlist of los 17.01, so I wonder if that has anything to do with it. Though I assume it shouldn’t since it installed just fine

What happens when you check the status, from terminal:
waydroid status

If both Session and Container are indicated as running. It might be worth checking android logcat by:
devel-su waydroid logcat

If Session or Container is not running, check “waydroid log” from terminal for some possible hints to fix things.

It has been a few days so my memory might be faulty, but I am pretty sure status showed them running - however starting them from the terminal always resulted in an error message.
I also tried logcat, but I didn’t have time to go through the mountains of text. I will try again on the weekend!
sadly my time to experiment is always greatly cut short by my contractual obligation to use this one specific android app… so I have to flash back to android every time something fails -_-