WayDroid on SFOS?

I had the thought of modifying X kernel ro get newer Aliendalvik to work, but someone who knows better than me said it will never work. I guess it’s bigger than just adding modules, etc…
But I don’t know if that necessarily means you can’t run container on it. However, in the early days of @edp17 's containers thread on TMO, I did test requirements on my X, and the kernel is lacking MULTI_INSTANCES support, so as-is, it cannot run containers, but possibly could be rebuilt for that…

See this post and leading up to it - maemo.org - Talk - View Single Post - Full linux distros on Sailfish OS

2 Likes

New Waydroid version posted (1.2). I upgraded version and everything seems good. Not sure what’s changed…

See https://github.com/sailfishos-open/waydroid
Waydroid is packaged in chum:testing, and will be in chum soon.

cc @rinigus @lal

10 Likes

Awesome! Thanks Adam

this will make installation and running easier I guests. damn, gonna go get Tama devices now

1 Like

it’s up…


working well…

3 Likes

I guess this might hurt Jolla license sales…

if only they sell the license for more powerful devices and for more affordable prices. see it all dominated by sony device, the mediocre sony device

1 Like

Did you not get the waydroid-sensors package too??

I did - I first tried to install forgetting that I already had /var/lib/waydroid folder, so the other 2 pkgs installed, but not waydroid …

What all is working in waydroid? Camera/etc?

camera yes. I think the last I read was that location not working, and I noticed that it doesn’t show accurate battery level (it’s always 85%). A few little things like that. For the most part pretty solid…

2 Likes

Location works now with waydroid-sensors installed. Pretty much everything works to be able to run the few Android apps one might wish to on a Sailfish device.

No banking apps and DRM content though.

5 Likes

@lal Sorry if i talk bullshit. But wasn’t Jolla talking about a signature for Android apps in a future release so that f. ex. banking apps would no longer signal a rooted device. Couldn’t that be integrated in Waydroid? :slight_smile:

I dont think so. AD is way ahead and more stable. Furthermore, despite the fact I would prefer SFOS on a FP4 than the X10 III, I would go with the official port/license because community ports/projects get abandoned often fast.

4 Likes

Oh I didn’t know about that. Is that same stuff as what micro-G does? I am not familiar with any of those, to be honest. Also Waydroid does not advertise itself as rooted to the apps from what I understand.

1 Like

@lal Look at the video with Joona Petrell, at minute 43 he is talking about a “signed system init”!?

But probably he refers to the Jolla App Support rather then SFOS in total if i am not wrong…

PS: I found the information i was talking about:
“Improved Android App Support. Sailfish OS 4.3.0 will have a signed system image for Android App Support. This should allow apps that previously complained about not running on a rooted device to work correctly. This should, for example, allow certain banking apps to run that previously refused to.”
This was stated in the latest community news here: Sailfish Community News, 21st October 2021

2 Likes

AFAIK these are different. Android app of bank I’m using complains once per an install or update that device is rootet but works anyway, but refused to work with out microg.

1 Like

Interesting, I don’t get gps with that (I do get e.g. orientation). Do you have a specific gps output in wayland log from the sensors daemon?

I just checked the log, there isn’t anything specific to GPS there from waydroid-sensors. GPS started working for me ever since I installed it (from chum repo), so assumed waydroid-sensord fixed it. Probably something else then!