VoLTE provider support


dumb question: is it normal that the button “4G calling (beta)” to enable VoLTE is pulsing for ever? Is it just taking so long or am I doing something wrong here or is this just an indication that it is not working?

That could be an indicator that something’s wrong. I re-enabled VoLTE on my X10III now that the routing was fixed – and it really looks like it has been, no investigations yet on my part - and the blinking turned solid in two seconds or so.

Okay, than theres probably something not working. Maybe this gets fixed over time - I’m patient

Exactly the same for o2-de as direct customer

1 Like

There’s a bunch of subdirs there for my poor old eyes to peer thru on a little phone screen, but I don’t see anything in the configs that looks like it could AT&T, so I suppose that means I shouldn’t expect the volte registration to work just yet.

@robthebold ATT and MVNO of ATT definitely aren’t working right now unless you have a whitelisted IMEI for the 10ii and 10iii. Maybe soon though. Stay tuned.

1 Like

Tried on T-Mobile USA, nothing but blinking. (Xperia 10ii)

getprop persist.vendor.somc.cust.modem0


1 Like

@rogerblizz TMobile should register to VoLTE on the 10 ii. I was able to get this working by flashing back to Android, enabling VoLTE, slapping in the TMobile SIM and giving it some time. In a short time it should register to VoLTE. Then re-install SFOs and enable VoLTE. Calling and SMS aren’t working for me- or as of a week ago or so, I should say. I haven’t retested. But it definitely should register.

On the 10ii, in France with the operator Free, I got S8683.1 and tried to create the dir with the config file.
But for the content of the modem.conf file I wasn’t sure what to write especially for the vl, vlvw, and non_ims options. For the name of the operator I tried free or freetelecom but none of my attempts allowed to register.

I only see config files for Orange, Bouygues and SFR in /vendor/firmware_mnt/image/modem_pr/mcfg/configs/. So every provider except yours :frowning:

VoLTE on X10ii / O2 Germany works fine for incoming calls (including parallel web surfing) but the phone switches to 2G for outgoing calls. No VoWiFi yet, though.

SMS work on LTE/O2germany even without VoLTE so they still do now.

Does anyone know, if the call quality is improved (on 10 II)? Usually, the other person complains about an echo when using loudspeaker.

Country: DK
Provider: Telenor
Device model: 10 II
Registered: ✓
Voice in: ✓
Voice out: ✓
SMS in: ✓
SMS out: ✓

However: the first couple of calls had some strange issues. I tried dialling out first and the result was that my phone just said “Ringing…” until I gave up and hung up. Next I tried receiving a call and it connected but took a long time (maybe 5 seconds) before audio started coming through. Then, when dialling out again, the the incoming sound was intermittent and impossible to understand. Gradually, after some back and forth, it seemed to get better and when I used a Bluetooth headset it worked flawlessly. Since then there have been seemingly no issues.
The 4G indicator remained through all of the testing and everything connected unusually quickly. Does it make any kind of sense that it would have teething issues? I am not under the impression that there’s any kind of link training in VoLTE.

Does it mean that even on Android the 10ii is not compatible with the operator Free ?

For France SFR
the value for getprop persist.vendor.somc.cust.modem0 is:

regarding the directory you mentioned in vendor/firmware…
i could find references of many providers including.SFR and if you get into the sub sub directory under SFR, there is a file mcfg_sw.mbn which likely has the bits in question


Hi, for me outgoing calls switch to 2G while for ncoming calls the phone remains on 4G.

I think it depends on the Android version, but at least for the base firmware from Android that SFOS is mounting there’s no config for it. Maybe a generic one would work? What we’re missing is the mapping between that S8663.1 and one of those mbn files.

I see there’s a mapping already for S12.1 to that SFR config. You could try copying that to a new S6.3 one if you’re feeling brave? :wink:

Country: PL
Provider: T-Mobile
Device model: 10 II
Registered: X

I also tried terminal commands from xperia 10 3 tread to enable volte. Those also gave me “false”. After reboot this state persists