VoLTE provider support

I got a T-Mobile SIM today for bring-your-own-phone in USA and tried my Xperia 10 II with that. Like @sa found,

getprop persist.vendor.somc.cust.modem0



and the blinky 4G calling light . . .

@robthebold @sa
Please do the following:

mkdir -p /vendor/oem/modem-config/S264.6/
mkdir -p /vendor/oem/modem-config/S264.8/
echo -n 'mcfg_sw/generic/euro/dtelekom/vlvw/de/mcfg_sw.mbn' > /vendor/oem/modem-config/S264.6/modem.conf
echo -n 'mcfg_sw/generic/euro/dtelekom/vlvw/de/mcfg_sw.mbn' > /vendor/oem/modem-config/S264.8/modem.conf

then reboot and enable 4g calling from the Cellular settings page.

T-Mobile and US Mobile will register on the Xperia 10 II. Phone calls now work. SMS and MMS works.

To get MMS working use the following:

  • T-Mobile

    • MMS APN
    • Messages App → Settings → SMS Message Center Address: “+1206313004”,145
  • US Mobile

    • MMS APN
    • Messages App → Settings → SMS Message Center Address: “+1206313004”,145



A German config works in the US?? How many different ones did you try? Is it just generic enough?

It does indeed. I tried two total. I was using the Deutsche Telekom (German owned T-Mobile) config for NL originally and that partially works. The DE one works due to the configuration being identical for the essential IMS services I pulled from a mbn extracted from a Microsoft Lumia 950 which does register to IMS services correctly on T-Mobile here in the US.


Did you try any of the generic configs? I think we’d stand a chance of getting those merged upstream, but I doubt they’d agree with configs from other countries. Fetching configs off other phones and operating systems sounds like a lot of fun :wink:

Country: FR
Provider: RED By SFR
Device: Xperia 10 II (XQ-AU52)
Registered: ✓
Voice in: ✓
Voice out: ✓
SMS in: ✓
SMS out: ✓

In order to have it work you need to copy the modem config file of SFR (S12.1) to RED By SFR (S6.3)

mkdir  /vendor/oem/modem-config/S6.3/
cp /vendor/oem/modem-config/S12.1/modem.conf /vendor/oem/modem-config/S6.3/modem.conf

Reboot the device and voila the VoLTE work!


I would like to update this comment. Volte started working after flashing stock rom, getting volte and flashing sail again.
Country: PL
Provider: T-Mobile
Device model: 10 II
Registered: ✓
Voice in: ✓
Voice out: ✓
SMS in: ✓
SMS out: ✓

Great. I’ve tried it and it registers. One of the benefits of these MMS settings is now they can be downloaded when connected to a VPN/Wifi which will make this bug far less of a problem for me.

Thank you

1 Like

YOOOOO. works for me! on T-Mobile USA on Xperia 10 III (no need to change modem config on the mark3, just using the proxy + mmsc)

thank you @hackman238, and @sa for pointing it out!!!
<3 <3 <3


Glad it worked for you.

I circled back and tried the anysim generic for global and it did not work for T-Mobile USA.

Agreed on the mdn. It’s probably possible for me to create these mbn ELFs… but I would need to go digging for all the parameters to do it. Probably would need to figure out how to do the signature and attestation part. Might even be blocked by the need for a signing cert. I’ll research a bit.

Did you try the one that’s pointed to by the S9999 config? I think the anysim one is non-ims so VoLTE disabled.

I didn’t. I’ll give it a try.

1 Like

I’m not sure anyone’s tried that one yet, but really it must be the first one to try.

Thank you, my Sony Xperia 10 II is not “denied” network in the US anymore, with T-Mobile service. I am assuming the phone and OS are utilizing VoLTE.

It took me a multiple tries to get the ‘flashing’ “4G Calling (beta)” option [within Settings > “Cellular network” page] to be solid, and “Registered” as shown below the option wordings.

First, I did re-image Sony Xperia 10 II, and the T-Mobile SIM card didn’t register with the 4G Calling (beta) option, which I assume this option translates ‘turn on’ VoLTE perhaps,?

Second, I did replace the SIM card with another T-Mobile SIM that is already activated, and not have been used yet, and with a different number; that did help to get “4G Calling (beta)” [is that VoLTE option?] with solid and not flashing light, and phone (modem?) “Registered” to be displayed.

I suspect that the first SIM card got 'blacklisted by T-Mobile; and I say this, because the phone did place and receive phone calls and MMS messages for an hour or so, without enabling or working on anything to enable VoLTE within Saifish OS, and then all went down, with message “denied” under Select Network Automatically option under “Cellular network” page.

However, for the good of me, I am not able to get this menu on the SailFish OS; where is it at, and how to get there?

A side note, on SSH to complete the task.

I did follow the steps to create folders and so forth within Sony Xperia 10 II, via SSH with USB IP address, as the instructions in a post on this forum was greatly helpful.

SSH How-to: type CLI terminal commands into your phone from your Linux computer

However, as I was able to SSH from another PC into the Xperia 10 II SailFish OS, I didn’t know how to sudo, or be root user on the phone. It happened to be to issue this command to come from ‘defaultuser’ to ‘root’:

$ devel-su

And thus when prompted to enter root account password, enter the already set password at “Developer tools” for “Remote connection”.

And then followed your wonderful instructions, and rebooted; changed the MMS input (not sure if before or after reboot); and all is well; the phone works!

Thank you


The screen you aren’t finding isn’t part of Sailfish. It’s an application “NetMon VoLTE Checker”. It can be installed using Storeman.


I’m having issues with mobile data and VoLTE on a Free Mobile (a French carrier) Sim card.

Basically, on Android mobile data is working great (no VoLTE because phone not supported by carrier).
However, on SFOS, mobile data is not working at all (whether VoLTE is activated or not).

Phone calls, SMS and even MMS works, so I’m wondering if it’s related to VoLTE?

Can anyone with the same carrier please confirm if they have a similar issue?

I have no problem with mobile data on the Xperia 10 ii on the Free network in France.

1 Like

OK, got everything working fine until this afternoon and suddenly network status on T-Mobile US has changed to “denied”! So not back to square one, but to square less than zero, since before I had VOLTE voice working at least I wasn’t denied. Not sure what I’m gonna do now.

Ed. It looks like it’s maybe back again, and then disappears. Signal strength is ok, and I’m in the same place. Please don’t mess with my head, T-Mo.

Ed x2. Well, now it’s Network status is now going from “Searching” to “Denied” every time I start up the phone with the T-Mobile SIM. Not good. Anybody got a suggestion?

Thanks. I’ll try to get my hand on a different carrier Sim and see if that’s related to the 10 III, volte, my line, or bad flashing.