VoLTE on the Xperia 10 II - filling in the gaps

I have done some more testing.

After switching cards (primary/secondary) both SIMs (Fello&Telenor) works with VoLTE, as long it’s the card selected to be used for mobile internet connection. I guess it’s due only one modem is able to connect to LTE at the same time?

When primary SIM is used for internet:

When secondary SIM is used for internet:

Both screenshots above are with Fello in primary and Telenor in secondary slot.

The strange thing is that my Fello SIM gets (retains?) the same S-number as the Telenor SIM, but VoLTE works anyway. This behavior remains no matter which slot each SIM is in.


I have Fello Sweden and same problem as Mohjive (but with only 1 SIM card).

I think the sp line in the switcher config is a filter that only matches Telia.
And indeed after removing the line and rebooting, VoLTE registers and works for me.

--- service_provider_sim_configs.xml.ORIG
+++ service_provider_sim_configs.xml
@@ -297,7 +297,6 @@
   <service_provider_sim_config sim_config_id="S54.1">
-    <sp>Telia</sp>
   <service_provider_sim_config sim_config_id="S55.3">

edit: this will collide with the halebop config, which also shares the same mmc and mnc. The correct fix would be to allocate a new S-number and create a new config for Fello.


Good info. Though should there be new S-numbers allocated or should Telia, Halebop and Fello use the same ( and Tre and Hallon, Tele2 and Comviq, Telenor and Vimla etc)?

I don’t think everything in Sweden can be merged, I found four different modem configs in “swe” directories, and their checksums are different (hutch is probably Tre):

43be0f8b354d35a034403d034d1797e7  /vendor/firmware_mnt/image/modem_pr/mcfg/configs/mcfg_sw/generic/euro/hutch/vlvw/swe/mcfg_sw.mbn
a7228cdfb669c71341971b9a8032cf95  /vendor/firmware_mnt/image/modem_pr/mcfg/configs/mcfg_sw/generic/euro/tele2/vlvw/swe/mcfg_sw.mbn
4fff8c8393b75734e5f1bec6c3a3997a  /vendor/firmware_mnt/image/modem_pr/mcfg/configs/mcfg_sw/generic/euro/telenor/vlvw/swe/mcfg_sw.mbn
aba38f3ea22de0d299fba6006a69f24b  /vendor/firmware_mnt/image/modem_pr/mcfg/configs/mcfg_sw/generic/euro/telia/vlvw/swe/mcfg_sw.mbn

But unless this file is used for other things, there can probably be some consolidation.

I think the file has been generated by this script, from the original firmware:


Looks like Halebop already has one in some later version:

1 Like

Telia and halebop is already in the Sailfish file with mcc 240 and mnc 01. But we need something defined for Fello, which also shares mcc 240 and mnc 01.

1 Like

Following the guide from @cypherpunks with the “hutch” hint from @tw1
I manage to get my Hallon SIM (uses Tre network) to get registered after a reboot.

getprop persist.vendor.somc.cust.modem0

Gives ID S9105.1

No current config for this ID exist.
But modem file for hutch exists, so followed @cypherpunks from here.

Don’t know where you able to get your screenshots but at least 4G calling states registered in the Mobile network.

1 Like

That’s not what I was trying to say, but to merge the virtual operators with their “real” operators, i.e use same config for Telia, Halebop and Fello and another config for Tele2 and Comviq, a third for Telenor and Vimla etc.

But at the same time the Telenor config worked for Fello, so I guess it can probably be unified. :slight_smile:

Maybe it’s best to ask the Sony guys about this somehow, as I’m sure those numbers have to come from them somewhere. Iirc they’re based in Sweden, so they might be encouraged to sort out their local operators.

Yes, if Sony upstream does not come trough the easiest solution might be to merge the Telia, halebop and Fello ones, since they all end up in the same place.

Since VoLTE is a standard, I guess it is not that strange that the Telenor binary worked with Telia. Maybe Xperia 10 III have unified them, and that is why they did not have this problem.

My telco operator is “Telecom Slovenija” and it offers both VoLTE and VoWIFI. I followed instruction to swith VoLTE on for my account (sorry only in Slovenian language: volte-vowifi).
My daily driver phone is Sony Xperia 10 II. SFOS
Command getprop persist.vendor.somc.cust.modem0returns “S202.1”.

Ofc, there is no entry for any telco operator in Slovenia in “/vendor/firmware_mnt/image/modem_pr/mcfg/configs/”. All files in here are about 1 year old.

Is there a method to update it with latest version? I hope such update might bring entries for telco operators on Slovenia.

These configs are part of the base firmware of the device, and as far as I know officially you’d have to use Sony’s Emma tool to reflash it with a more recent version of Android than when you installed SailfishOS originally to get newer ones.

There be easier ways to find/extract/construct newer configs, but those could never be merged.

Wouldn’t it be an option to extract further configs from more recent Sony firmwares and just copy them to SfOS?

Of course it’s possible. Whether it’s probable is another matter. Is there anything closed source in the Volte patch?

Edit: Was confused about LTE vs VoLTE. Deleting posts as it was a bit off-topic to begin with.

Yes, as has been stated before.
And i think calling it a patch is quite belittling for such a great effort.

What do you mean with that? This is just about the voice part.

As a software developer; patch generally means small.
Moving on…

LTE is very much supported, just not for calling (voice over…).
Previously voice calls would fall back to either 2G or 3G, and if you bought a plan where you are promised voice, the operator may not let a non VoLTE-capable device on a LTE-only network as to not give false pretenses.

It’s right there in the status bar.


So what is the analogous process / file structure on the 10 III?

Is there some way to go find the config ID on android, or from the MCC+MNC numbers?

The 10 III does the stuff we’ve been talking about here automatically in the modem, so those modem.conf files aren’t used (and their paths are actually incorrect on that device). I’m not even sure if that config id is used at all.

FYI all, VoLTE calling, SMS, MMS and Data working on T-Mobile USA and US Mobile using a Xperia 10 ii. Probably would work for Mint as well. See mbn conf details here: VoLTE provider support - #110 by hackman238

1 Like

Hi! I’m having hard time to get my Xperia 10 II to register 4G calls (the toggle is just blinking, I’ll now leave it there trying for the rest of the day…).

I’m using a Telia SIM in Finland.

getprop persist.vendor.somc.cust.modem0

a config file seems to be in place in:

I double checked with operator that 4G calls are enabled for my phone subscription. SIM card is also new enough (from 2017 or 2018, I can check later).

Has it worked robust for everyone else who’s using Telia in Finland?