Viber update fails

Hi, folks.
Does anyone have issues with the latest Viber update (16.4.7.2) from Aurora store?
The previous version worked normally, and since I updated, I can’t start the app (it starts but then it minimizes the app to a black screen). Every other Android app that is installed on my device works flawlessly.
I’m on the latest SFOS 4.3. I’ve tried removing cashe, data, stopping/starting Alien Dalvik support, reinstalling the app, and everything failed.
When I install the previous version of the app I can open it, but I can’t register to Viber anymore, whatever I try (even contacted their support, and because I use their app in a special scenario, they weren’t much helpful).

Thanks in advance

1 Like

Yep exactly the same behaviour… I should have read your post and not update :expressionless:
I didn’t try uninstall and install an earlier version though.

1 Like

Too bad. I hope someone will provide a solution (or the next Viber update will actually work) soon. It’s not that I particularly like Viber, but many people in the country where I live use it as a main chatting app.

Also, if you are not too bothered by this, please try to use the last working version of the app. That way I’ll know if it’s only me who’s not able to log in to that version.

I downgraded to the previous version which loaded okay and verified that I also can’t register. Then I upgraded again to the latest version and it loads for a brief second or 2 when I can see the registration screen and then Viber crashes. So I am successfully out of Viber now for good :smiley:

2 Likes

Yup. The same thing as on my device.
I’ve contacted the Viber Support and they are working on the issue.

me too, unfortunately - sad to read after the upgrade was made… :frowning:
installing older one worked but cannot activate my account and now it gives me an error message indicating they disabled my number due to suspicious spamming activity.

what the heck!?

contacted the support - I think a bot replied because it has the same name as above but replied just to that part of the story that SailfishOS is not supported by Viber, not reacting that part I’m using it for years there, neither to the account locking issue… :frowning:

wrote to mentioned Twitter account above - let’s see whether they do anything…

1 Like

Yeah, they must have changed something because it was working reliably for years until now. Or, maybe something was changed in the new (4.3) update on our end. I have no idea.
I hope it’s get sorted out eventually (or that majority of the people I chat with will switch to Telegram).

Do you use Viber with or without google play services? You can use Viber without play services, but the cover must always be open, because there are no push notifications. What has certainly changed for us is that the Android image is signed. I personally will not update to 4.3 until the issue is cleared up, because I use the app daily.

2 Likes

I’ve always used it without Google Play services. The cover doesn’t have to stay open, as long as you “Allow background services to start on bootup” from the settings. I do that for all my chatting apps, even on Android phones without Gapps.
Yeah, I have no idea what is the culprit, but the matter of the fact is that we cannot use the app anymore until it gets fixed (or, if you don’t update the app, but you update SFOS to 4.3, the app will continue to work normally).

I more-and-more tend to think it is SFOS issue - activation fails on mobile with reason that indicated account was blocked for spamming. But account is not blocked at all I can use it from Desktop clients…

1 Like

That’s quite possible as well. Maybe because of the new signed Android image.
I guess we can only test it out when the new update arrives (the Viber app will probably update first).
We could probably issue a ticket for this, but other than a handful of people in this thread, I believe nobody is using Viber because it’s not FOSS (or popular in their countries).

Edit: I just saw that you have issued a ticket for this. Let us hope that it’ll get fixed in SFOS 4.4 or when the new Viber updste arrives.
Btw, there’s a typo in the headline

I think the issue is due to something in Sailfish 4.3.

I updated my 10II to 4.3 and Viber is completely unusable, where on my XA2 running 4.2 its running with no problems what so ever.

1 Like

I see. That’s great (in a sense that you’re probably right and the issue will be hopefully fixed in 4.4).
It’s an open issue now since the ticket for this has been opened.
Hopefully, someone will hear the cries of the few of us.

1 Like

Waiting for fix.in 4.4 god knows comes when?!
Viber was used daily by me and I’m literally struggling with keepng some comm channel open without workng Viber client…

fingers crossed some emergency fix will come.
not to mention, Google Translate app has also been stopped working after upgrade.

something went really.bad in Android App Support wuth latest update…

2 Likes

Yeah, it kinda sucks but we can’t really do anything about it.
The solution that worked for me is to borrow someone’s Android phone to register on Viber and then to set up a desktop app and to connect to it. It’s not a great solution, but at least I can use Viber while I’m on my PC.

Lucky me I’ve already registered on desktop (win desktop and Linux laptop) thus I’m not completely locked out bit phone is with me constantly while PC aren’t…

1 Like

There is a new version of viber in the Aurora store. Have you tried if there is any difference with Sailfish 4.3?

2 Likes

I just did. The app finally works…but, alas, I’m still unable to register.
So, this issue has to be fixed on Jolla’s end.

2 Likes