Use of Gmail no longer possible under default browser

REPRODUCIBILITY (% or how often): 100%
HARDWARE (Jolla1, Tablet, XA2,…): XA2
REGRESSION: (compared to previous public release: Yes, No, ?): Yes


It seems that I’m logged out of Google account and can’t login any more as there’s a security warning.


Google account.


  1. Open stock browser.
  2. Try to login.


Loged in to Gmail.


Security warning.

Duplicate of this.

1 Like

Or continuation of this here:

1 Like

Thx. It is a duplicate. I can’t find a way to close this report tough.

Yep, it’s really annoying.
However, the reproducibility is not 100%. After a few tries, it worked for me and I’m now logged in for the foreseeable future.
But I can’t find a reliable way to bypass this f*** warning :confused:

1 Like

THX. I tried once more today and now I’m logged in. At least for now.

To bypass Google’s check, open about:config in the default browser and search for “agent”. Change Sailfish 3 with Android 8 in the user agent string. This lasts until restarting the browser.


Weird, even this is set in the prefs.js file when modifying it via about:config, it gets overriden with the default on restarting the browser. Even killing all affected processes does not help.

wiered, a few weeks ago it worked fine for me, read this thread, tried it, failed. however, i do not use Gmail etc that often, on this page my keyboard hides what i m writing, thats also pretty annoying. but i can confirm your problem.

Thanks, it saved me. For whoever tries this, the string to replace is “Sailfish 3.0” with “Android 8.0”, be precise because befor I had used “Android 8” and it didn’t work :wink:

1 Like

Did the upgrade of the gecko engine on 3.4.x.x help?

And does anybody think that this url

does not work on purpose with SFOS browser? :wink:

Tried in a private windows and was able to log-in at first try, so it seems so!

Haha, it actually works for me :slightly_smiling_face:
EDIT: Argl, the time to write this answer and BIM, phone rebooted, the good old browser RAM leaking until the OS can’t breath anymore I guess indeed :woozy_face:

So maybe a new bug then (worth to be filled as?) As on my SFOS3.2 with older browser onky the browser crashes. But having the whole phone shut down abrupt is not a good thing!

Today not working anymore on 3.2 (yes, yes, I know, I should upgrade…)

Oh :frowning:
Yesterday (or the day before) it was still working on with SFOS 3.2

Do you mean that, after exiting, you could log in successfully into gmail?

Yes, that was yesterday.
And even today I managed to do so.
But not with stored/cookied user (where I received error about java script). I needed to click different account, gave my user and password and was in.

STRANGE is that I cannot enter from other phone or computer where it says password incorrect.
Funny as I enter same pass on both phones exactly same…

THAT (removing from login the old account and enetering it again) with the agent trick, worked again.

Welcome :wink:

Meanwhile google seems to also remember my password and I could enter as well on SFOS 3.4 :smiley: