USB tethering on Xperia 10 iii

Hi, I’ve installed Sailfish X on a new Xperia 10 iii and everything seems to work fine, except USB tethering.
I’ve tried with usb-moded-connection-sharing-android-connman-config and usb-moded-connection-sharing-android-config but none works. The first one works on my Xperia X with the latest version of Sailfish OS.

Does anybody managed to use USB tethering on Xperia 10 iii ?

1 Like

This might be a silly question, but just to be sure: did you restart usb-moded?

I used USB tethering on my Xperia 10 III for a day when my WiFi was down, with no problem.

Yes, I did (systemctl restart usb-moded).

Do you know which usb-moded-connection… package was installed ?

Sorry no, How can I check?

I have used Wifi Hotspot up until now, but wanted to try USB tethering instead and followed the guide (https://jolla.zendesk.com/hc/en-us/articles/203548266#usb), but while my computer identify the phone USB connection as a network it shows as “no internet connection”.

@smartiz how far do you come in your setup?

Oops! Checking back I can see I useds WiFi Hotspot, not USB tethering this time.
Sorry to give you false hope!

1 Like

I have exactly the same behaviour.
I’m not sure to fully understand your question about my setup !
I’ve tried the procedure you tried from zendesk but also
pkcon install usb-moded-connection-sharing-android-config
which seemed to work on Xperia 10 ii according to USB thethering not available on Xperia 10 II?

I’ve just tried on my old Jolla 1 (stuck with Sailfish OS 3.4.0.24) and

devel-su
pkcon refresh
pkcon install usb-moded-connection-sharing-android-connman-config
systemctl restart usb-moded

works fine.
The problem seems related to Xperia 10 iii.

I use
zypper pa -i | grep usb-moded
to see which package is installed.

I would rather say that it’s related to Sailfish 4, as I’m having the same issue as you on my Xperia 10 II with Sailfish 4.4.0.68.

I can use USB tethering on my Xperia X under Sailfish OS 4.4.0.68 but it has been working for a long time, before upgrading to Sailfish OS 4. Perhaps the problem comes with fresh installs ?

1 Like

I just noted that the guide I linked and the forum post linked mentiones different packages: usb-moded-connection-sharing-android-connman-config
vs usb-moded-connection-sharing-android-config

I tried the latter now, but to no avail. What I do see is that my computer now have an IPv6 address, but that doesn’t work. I also tried to set “protocol” to “IP” (instead of “Dual”) for the internet connection on my Sailfish device, but that didn’t work either (still got an IPv6 address for my computer).

If anyone knows how to force IPv4 for the tethering I believe that should work.

I did do a fresh install of 4.4.0.64 on this device, so that’s not impossible.

One currently known issue is the network not working, if you have IPv6 only mode on mobile data and the computer gets IPv4 addres only. So check that the mobile data setting is at least dual, preferably IP (IPV4). Also you have to select the Internet connection sharing option when you plug the USB cable in, obviously.

I have been using both WiFi hotspot and USB tethering on my X10III, so I can confirm they both should work. I did install both packages mentioned above.

I did have it as “Dual” but switched to “IP”(v4) when I saw the IPv6 address on my computer, but I guess the IP protocol is the problem with getting this to work.
With WIFI sharing I always get an IPv4 address.

I think you get the IPv6 address on your computer, because the IPv6 is enabled in the networking stack of your computer. I have an IPv6 address and it’s a link scope address, which is expected and does no harm.

If you’re on Linux, check ip -4 route (should have “default”) and ip -6 route (should not have “default”).

It can also be DNS (red shirt Jeff anyone?) so that should be checked. I have the both packages above installed, so the DNS server my computer gets is the phone, i.e:

$ cat /etc/resolv.conf
nameserver 172.28.172.1

but you could edit it to nameserver 1.1.1.1 instead and try that - really shouldn’t make a difference though.

bild

But it’s also something more, since ‘ping 1.1.1.1’ doesn’t work when trying USB tethering.

Hi, thank you for the ideas. Indeed, the problem seems to be related to IPv4/IPv6 issue.
Even with “dual” mode, I have no USB tethering.
But I can share a wifi connection (rather useless of course).

I read some other topics and saw the “2nd SIM slot” trick : with the sim card in SIM2, USB tethering works !
Then, there is definitely an issue but I have a workaround. Having the problem solved would be great.

Thank you for the help.