Updater is missing internet connection



The updater in settings menu claims about missing internet connection. All other apps and browser are working as expected, so there is definitely a working connection. Also it makes no difference if wifi or mobile connection is alive.


Functional internet connection.


  1. Go to Settings / Updates for SailfishOS
  2. Pull down and select “Search for updates”


Serach for updates. Actually I think there should be a “no update available” message.


Error message “Please connect to internet” pops up, complaining about missing internet connection.


Installed with “sfos-upgrade”, see below.


This problem already exitst in previous version to. I thought it would be fixed with the update. Therefore I went with “sfos-upgrade”, but the bug is still present.

1 Like

Works fine for me.
Do you have a license?

1 Like

Yes I have a licence, Android apps working as expected. But upting should also work without a licence.

No. GUI updates are part of the (paid) license.
Maybe try signing in to your Jolla account again?

1 Like

Account status is shown as active. If there is a problem with account, I would expect to see a message like “Unable to connect to sailfish account”, but not a message about missing internet connection!

Is there a way to reconnect without deleting the account? Will there be other issues if I delete the account? Do I then need to reinstall Android app support / apps when removing the account temporary?

Just a thought…

(Disclaimer: At your own risk!)

At your situation I just might try:

cd $HOME
devel-su     ###  you will need to type your SSH password here
pkill store-client  
rm -rf ./.cache/sailfish-osupdateservice/os-info  

Reference: Updating Sailfish OS | Sailfish OS Documentation

Also (not sure about this, since i’ve never tried it but) removing your user account and adding it again shouldn’t cause any problems.

Worst case scenario: You have to reset your phone to factory settings (or reflash it, if it’s updated OTA).

My two cents.

No need to delete the account itself, just sign out and in again on the device.

How do you sign out from Jolla account on the phone?

I didn’t find any option for that. In Jolla account pulley menu there is an option only to remove the account.

1 Like

Yes, there is a confusion there as well as on first boot login after installation.
There is a mix between the notions ‘login to account’ and ‘creata an account’.

So if you ‘delete the account into the phone’ it will just ‘logout’.

1 Like

According to @ric9k I need to remove the account. Can someone please anser my question from above: When removing/deleting Jolla account in settings menu, will Android support be deinstalled too? So will it be necessary to reinstall all Android apps?

Be the first courageous sailor to try that. :sunglasses:

I don’t think all the Android apps are uninstalled when you remove/logout. Maybe they are just unusable while not logged in? Who knows…

(Actually i think someone knows. Maybe you just have to wait a while for the correct info.)

I don’t know if logging out and in again will solve your issue but yes, you can try it. You will not have to reinstall Android App Support.
Settings, Accounts, long press on Jolla, delete, reboot, log in again, reboot.
that’s what I’d try.
I just did it, AAS is still here.

1 Like


  1. Deleted Account → Updater claims about missing internet. No message about missing account.
  2. After Reboot → Same error when checking for updates
  3. Added account again → Same error when checking for updates
  4. After Reboot → Same error when checking for updates

=> Removing and adding the Jolla account does not resolve the issue!

Does it reproduce on different networks? (WiFi vs cellular for example)
Have you messed with DNS at all?

As I wrote in first post, it makes no difference if on mobile or wifi.
I am using a Pi-hole on my home net. But updater does not work when Pi-hole is disabled. Also updater does not work on mobile connection.

Can anyone tell me which servers are utilized when checking for updates? So I may try to ping them from console to see if it is a DNS issue or a bug in the updater itself?
Two other observations: I don’t see any DNS requests on Pi-hole when checking for updates. And ‘pkcon refresh’ in terminal works.

For me it does not happen, if I open the settings app and go to the update page. But it happens when I go to the page via the quick link from the pull down menu (where you can change the ambience).

1 Like

I have a similar issue. Update hangs with the message “updating will be prepared/Aktualisierung wird vorbereitet”, and sometimes I get “waiting for connection” although I have an existing internet connection.
On Sailfish start screen I get the message “No net, type to repeat”.
Do you meanwhile have a solution?

1 Like

I cannot start developer mode. It hangs with the message “changes will be prepared”. Could it be, that this is caused by the same jolla account issue?
What to do then?

Maybe remove your account and add it again.