Update to failed

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, Xperia 10…): Xperia 10II Dualsim
UI LANGUAGE:english/german
REGRESSION: (compared to previous public release: Yes, No, ?): na


update to failed
Retrying update process stuck at waiting for connection
developer mode stuck at “Änderungen werden vorbereitet” - something like “changes being prepared”

I have a feeling, that the system detected the already downloaded update file, since the kvarken photo is not greyed out anymore in the update screen.
Could someone tell me where (path?) the system update files are stored? I would like to delete the download and restart.

Try just restarting your phone. If the update has been downloaded, it’ll be detected, so you can proceed with either completing the download or installing it

Tryed that but nothing changed Here is the Screenshot, where it gets stuck. it keeps waiting for connection. Though the image is not with a grey tint.

For a short time - just long enough to take a screenshot, theres this symbol on the image - with a hint for not enough memory.

though there seems to be enough free memory on system

But something’s completely cockeyed with the updater’s calculation of the available space: It says that "-1 is needed, but only "0 B currently available. Have you tried to reboot? Otherwise, it seems like a bug in the updater.

1 Like

I tried a lot of times, rebooting and the reset options in the utilities menu.
Sadly, the problem persists.

I had similiar problem with update. For me it was that /opt/ didn’t have enough space for Alien Dalvik update. In /opt/alien I had 2 system.img files. Moved one with .img;32342 file to /home/nemo to make space.
After that update went through. Found hints from derSoes post in here: Update to Koli not working - #14 by gabrielg

and here:

1 Like

At various update versions, the Sailfish updater has failed for me, incl. 4.1 but not 4.01.

This has always worked for me when the built-in upgrader fails … sfos-upgrade | OpenRepos.net — Community Repository System


Thank you for your replies. Theres just one system.img in /opt. For scripts to be executed I’d need devel-su I suppose, but I cannot enable developer mode. Its like the systen partition is in a read only state - I cannot even install new software.
I could su but it asks for a pw I did not set.

Can you remove apps to make some space and then try sfos-upgrade or enable developer mode.

I tried removing all not really neces

sary apps (esp android ones). That strangely only worked via android-settings, not from the sailfish launcher.Didnt change mich with free space though there should be enough for an update since the flashable image is about 670 MB?
I guess I should do a clean install, once I get a hand on a PC.

PS: I wonder if jolla use their own browser to reply to this forum and realize that the reply box hides under the keyboard, which makes typing guesswork since there is no type correction on the 10II.