Unencrypted, FAT sdcard doesn't properly mount via GUI

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): X10 II
REGRESSION: (compared to previous public release: Yes, No, ?): Yes


Mounting of sdcard with FAT filesystem via SETTINGS->System->Storage is not possible. It reads “Unsupported memory card” and attempt to mount ends up with pop up “The file system is incopatible. Formatting is needed”.
Sdcard is already formatted and used to work. The scard is not visible in UI i.e file browsers but is already mounted and visible via command line in /run/media.


FAT formatted sdcard, (encrypted ext4 sdcard is mounted properly)


  1. Have already working phone with and sdcard with FAT filesystem
  2. Update to
  3. Reboot

Next reboot doesn’t change anything.


Sdcards properly handled .


as mentioned


1 Like

Which version of File Browser are you using? If not done already, I recommend updating to version 2.5.1 from OpenRepos and check if it detects the SD card then.

Also, how can it be mounted if mounting fails? :thinking:

Yes in the latest 2.5.1 sdcard is visible but is not visible in any of the rest of file browsers.

For me it is mounted properly, content is visible by apps (eg, music). Only settings app does not show whole sd card just like in you case.
I have 2 partitions: one fat, second ext4. Both unencrypted.

I see; then it sounds more related to the system, not to File Browser.

O course . If it was a File Browser issue I would rise a bug report at File Browser at OpenRepos :).

Sure :slight_smile: I could have worded my reply better: it sounds like a system bug and I’m relieved File Browser isn’t affected and isn’t the culprit.

I couldn’t reproduce your bug. Can you explain with more details how you formatted your SD Card? Like which program did you use? On which system was your SD card formatted. What are the result of:

fdisk -l </dev/memoryCard>
1 Like

I have no idea how formatted this SD card was. It has been working for years, already.

Disk /dev/mmcblk1: 3.7 GiB, 3980394496 bytes, 7774208 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device         Boot Start     End Sectors  Size Id Type
/dev/mmcblk1p1       8192 7774207 7766016  3.7G  b W95 FAT32

I could not reproduce either. Tried LBA and non LBA FAT, both were working.
Maybe your card went faulty. I had a certain amount of microSD who died from one day to the other.

I just tried with a died SD Card and unfortunately I don’t get the same message as @kan_ibal. It shows No memory card inserted.

@kan_ibal do you remember on which system you formatted your SD Card? On Android? Windows? Linux?

@kan_ibal Can you please share result of (as root):

devel-su journalctl -f -u udisks2

Try to mount and unmount using GUI. Then, try mounting using the terminal. Still as root:

mount /dev/mmcblk1p1 /run/media/defaultuser/

If there aren’t errors, you’ll see your SD card in Storage.

Log is empty. As I mentioned before sdcard is not recognized hence there is no mount/umount option in GUI. Unmounting and mounting in terminal doesn’t change a thing.

I’m not sure to understand. Once you executed the command on terminal, there were no errors? Does fdisk -lshow your mounted SD card? Or even mount?

Yes, there are no errors. A log header “-- Logs begin at bla bla bla–” is visible only.

As stated before, scard is visible in terminal and FileBrowser hence 'fdisk -l" shows that sdcard and that sdcard is mounted.
The only issue is with GUI manager Settings->Storage that is useless.

Bug is still valid for
I have tested a second FAT formatted card that works in Symbian, Android and Linux systems without issues. The same behaviour. The same is applicable for X device and build.

How did you format your SD card?

I’ve been using these cards for 10+ years so I do not remember for sure, The most likely one was formatted in Symbian phone and the second in Android.

My advice here is this:

  • copy the data from the card to a safe place
  • format the card with Sailfish
  • copy the data back to the card
  • enjoy the card that works :slight_smile:

We tested the mounting of a VFAT card with a couple of phones and cards, and it worked fine.