Unable to log in to the Soundcloud app on the Xperia 10 II

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): (Verla)
HARDWARE (XA2, X10, X10 II, …): X10 II
REGRESSION: (compared to previous public release: Yes, No, ?): ?


While the Soundcloud app works without problems on my XA2 with 4.2 it won’t let me sign in on X 10 II. I’ve tried with some older versions of the app, same result.


Fresh installed SFOS 4.2 on X 10 II


  1. Install soundcloud app from any store
  2. start it
  3. try to sign into your account (any way, email or via facebook)


App logs you in


I get an error message as if my account wouldn’t exist


1 Like

Exactly same issue here… I’ve install fresh stop release to my Xperia XA2 and I have same error message like you :frowning:

1 Like

I get a different error (gigaset GS290) to the effect that they think I’m a robot. I use host files blocking so I’d guess they’re not able to load something evil. EDIT: I was doing the browser login, NOT app. Funny enough, none of the captcha methods worked.

Yeah :smiley:
I’m robot too :smiley: and that catcha is realy funny… repeating question if am I human :smiley:

Do you see anything in /system/bin/logcat when the error occurs?

Nothing special…
Some messages about performance mode and Decided to move IRQX..

Just tried on my X10 II and got the same error. I installed version 2022.11.21-release from Aurora Store.

Thanks for the report @slemmerzahl, and for the followup info from everyone else.

I’ve created an internal issue for this and tagged it here as “tracked”. If there’s any progress of feedback to report I’ll do my best to post it here.