UI-Themer missing from OpenRepos

There’s everything there to build an RPM, however it depends on harbour-themepacksupport so we would need the source for that as well.
I have successfully built (but not installed/tested) an RPM from the linked source tarball. It does compile on the 3.0.3.8 SDK, but fails on 3.3.0.14. So there is some porting effort needed to bring it up to current versions.

On a personal note, the linked source is GPL so everyone is free to fork/modify/distribute. OTOH I think the original developer’s wishes should be respected or at least considered when resurrecting such apps from e.g. archive.org.

Good day everyone,

As I said to some of you, I pulled off the sources because apparently I failed building a community that could have developed the project together.

If there’s enough interest I’ll consider reuploading them (under a different license) and committing to deliver a functioning experience for later releases of Sailfish OS.

16 Likes

@fravaccaro That would be damn nice. Many users would be happy!

1 Like

That would be fantastic, and I’ll help any way I can… whether that’s testing, bug hunting or whatever. Just let us know!

1 Like

doesnt work in Rokua

@mja already wrote that, sorry. Unfortunately I don’t have a 3.4. and couldn’t test the patch. That happens after every major update. @coderus has always published a fix so far. I hope this time too. If the patch won’t install, then post a comment for @coderus on Openrepos.

https://openrepos.net/content/coderus/patch-launcher-combined-patch

any news on this? with dpi 1.75 (standard) the x10plus is unusable ugly.
I was able to change the dpi line in silica-configs.txt to 1.4. I changed the permissions with ssh of the folder /vendor.d, copied the file and changed it, deleted it on the the device and copied the changed file back.
BUT: even after a restart it has NO effect. the value is set to 1.4 instead of 1.75 after restart without any change.

1 Like

You can change font pixel density fairly easily:

dconf write /desktop/jolla/theme/font/sizeMultiplier <value>

Where <value> is a float. The default is unset, or 1.0. 0.5 is two times smaller, 2.0 is two times bigger. I run at 0.8 on my Xperia XA2 Ultra.

You can also limit the maximum size of characters with:

dconf write /desktop/jolla/theme/font/sizeThreshold <value>

Default is 0 (unlimited).

These two keys get you a LOT more on screen. You can also mess with theme pixel ratio:

dconf write /desktop/sailfish/silica/theme_pixel_ratio <value>

Default is 1.25 (I believe) on my Xperia XA2 Ultra.

I hope this helps.

Edit: the first two keys will update lipstick in real time, but you’ll need to restart it for the theme_pixel_ratio key change. You can do this easily with:

systemctl --user restart lipstick
3 Likes

My silica-configs.txt looks like this and I can use dconf command to change setting. Dconf tells ratio is 1.35 as set in UI Themer.

[desktop/sailfish/silica]
theme_pixel_ratio=1.75
theme_icon_subdir=‘z1.75’

@deprecated Is it possible that UI Themer has removed those lines which you mention to comment out or how this works?

I’m not sure. The ones I mentioned to comment out are in /etc/dconf/db/vendor.d/locks/silica-configs.txt:

#/desktop/sailfish/silica/theme_pixel_ratio
#/desktop/sailfish/silica/theme_icon_subdir

Which allows the keys to be set with a dconf command (as shown above). My Xperia XA2 Ultra is currently on a fresh install (latest installer, then updated to 3.4 via console), so it doesn’t have UI themer installed, so I think my config is essentially stock.

2 Likes

Sorry I missed locks part in path. Actually I don’t have that file at.

Edit: My Jolla1 3.2.1.20 with UI-Themer doesn’t silica-configs.txt either. Test above was with XA2 3.4.0.22.

Well I know, thanks. Problem is that this won’t work anymore on 3.4
X10, and X10plus. Fresh installs and updated to 3.4.
commented out is there in the file. Not any effect, command is still locked.

1 Like

Weird, it’s working on my XA2 Ultra on 3.4. I don’t have an X10 to test, but I might buy one for the sake of having it on hand.

1 Like

sorry but on my Xperia 10with 3.4.24 its working. Theme_pixel_ratio without any problem.

Strange. I’ll do a reflash then, something must have went wrong. I am having some other issues, too.

I have the same issue 3.4.0.24 on XA2. Please let me know if flashing the device helped you.
I already had to reflash because alien dalvik wasn’t working anymore, really hope to fix that …

forget it - do not go through the trouble of reflashing, it does not work:
I reflashed
I updated to 3.4
sailfish-configs.txt in locks could not be commented out, even with setting chmod to 777
I set the vendor.d folder to 777, so I could delete the files and created them new with 777 rights
no chance, still locked :frowning:

something locks that string. Maybe it works in recovery mode, but I am sick of trying now. I’ll use an old android or windows phone in the meanwhile until ui themer is back :frowning:
EDIT: of course it does not work in recovery mode since no comments are accepted - its just a recovery
EDIT2: i wont give in: strange thing: after setting the pixel ratio manually in the config file in vendor.d (not in locks dir) to 1.45 it did not change anything after a reboot. Now I just did a devel-su dfcon read … and a devel-su reboot.
after reboot the dfcon write command worked, but only if used with the number in the silica config file. another devel-su reboot and VOILA, pixel ratio changed.
I do not get it, but it worked that way.
I used WinSCP and putty for all this mess.
But now I still need the right icon sizes, nothinng shows up

!!!
#EDIT3: do not do that, I messed up insanely. no icons or symbols, device is unusable -> reset.

Thanks for the details.
That’s sad, i’m going to flash back on 3.3 until someone find how to fix that.
I doesn’t want to use the device with these pixel ratio settings, that’s just awfull.

1 Like

See here, maybe this is of help to you before downgrading the OS;

To sum it up on 3.4:
Dconf write definately does NOT change the setting in the vendor.d config file.
Also something locks the file in the locks dir, it cannot be commented out, even with rights. If one makes all changes with workarounds like I did, the device needs to be reflashed again.

Maybe someone from Jolla can tell us, where the pixel ratio settings file is located in 3.4??? Please.