Toggle XPeria 10III Cameras

I found this Toggle XPeria 10III Cameras by @nephros in Chum. How come I can’t find anything in forum?
Seems to work pretty well to. :grinning:


Doesn’t work for me, remains in ‘Camera: front’ after clicking

I had to reboot phone to get the accurate button. At first I did get a second Do-not-disturb-button.

Nothing changed after reboot, still stuck on ‘Camera: front’

Guess we need @nephros help on how to debug. systemd really isn’t my “thing”. :wink:

Manually editing the txt in /vendor/etc/camera and killing… process works

1 Like

Works great for me, thanks a lot for the hint.
And even more thanks to @nepros for that cool untility.

1 Like

Ah, yeah, this was just recently published, didn’t have time to announce it properly yet.

I guess this is now the support thread :wink:

For anyone having problems, can you please make sure that:

  1. The camxsettings file is the unmodified original
  2. from cli, try
systemctl status org.nephros.sailfish.x10iiicamera.service
systemctl start org.nephros.sailfish.x10iiicamera.service
systemctl status -l  org.nephros.sailfish.x10iiicamera.service
systemctl stop org.nephros.sailfish.x10iiicamera.service
systemctl status -l org.nephros.sailfish.x10iiicamera.service

… Also note that this is intended to be toggled while no apps are accessing the camera, so close the camera apps, and anything else like video chats etc.

… And a third thing:

The button should ask for authentification the first time you use it (per lipstick session).

I think you have to have Lock Code enabled for this to work.

Needed to change the service file to /usr/bin/bash and /bin/sed as both of those were not busybox but gnu versions, now it works, thanks!

1 Like

‘The button should ask for authentification the first time you use it (per lipstick session).’

And it did. No problem there. Thanks for sharing!

Ah yes, that one again.

I’ll update the commands in the next release. Thanks for the analysis.

1 Like

Wow, works a treat! Thank you!

1 Like

Both the native camera application and Advanced Camera from Chum have the three selection buttons now (Advanced Camera with some elegant leafs), this is awesome! Thank you very much.

Noticed that Android application Open Camera stopped working, telling that the camera might be in use by another application. But that’s not a big deal.


Thanks @nephros for this awesome feature! Works perfectly: I did not need to do anything on a newly flashed sailfish OS image on my Xperia 10 III. Just an FYI: each time I toggle the triple camera, I need to authenticate every time using fingerprint. But for me that is no problem at all.

1 Like

Hm, when the button is off, everything should be at its defaults, so behaviour of AD apps should not be affected.

However, toggling either way kills the (droid) camera service, I can imagine that if that happens while AD is running it may have such an effect.

Can you test whether restarting AD fixes Open Camera?

Tested OK: restarting the AD service fixed the issue with the Open Camera. FYI, I have set it to use Camera API 2 (I do not even know does it make any difference with SFOS).

Opened the native camera application and the buttons were still there. Same for the Advanced Camera.

Thanks, I’ll update the package description noting this in the hopes people will read it :wink:

1 Like

I have a bug report of the button/service not working any more after updating to

As I can’t test on a 4.5 X10iii device, can users of this please aid in debugging?