There is NO way this update was tested. Nothing hardly works

yeah me too. I like it because its unique snd when it works its easy to use.

1 Like

Tried to install the application that was linked…I did not know their was a secondary application store…but it failed to install

So Im out of luck

If you click on the banner, what message do you see?

non of those applications from that store that I was linked to would installed and I had on the option to allow untrusted applications.

There was a problem with installing is all that was reported…wow what a helpful error message. I guess it could not be bothered to display the error type… :frowning:

Im just going to have to wait until they fix this bug riddled Horror show.

Is there a way to go back a few version of the OS?

I will show you. I was hoping for some details but it was not to be.

How did you try to install Ofono Logger? Have you downloaded a rpm file? Have you installed Storeman?

You should install apps with Storeman (or chum if you’re not aware to use CLI).

1 Like

Sorry I dont know what that is?
so I just search the web? for storeman?

my method was that I clicked the link that was posted by the user. I saw aa litslits oofof versionversion andd downloaded it. Then tried clicking the downloaded file.

I did not know it required another application

But probably you have to allow install from third party source


Those i486 files won’t install on xperias, different cpu architecture, use storeman client it should select the proper file for you



I would suggest that - being you a ‘pay’ user - you may file a support request to Jolla Zendesk support.

Submit a request – Jolla Service and Support (

I’ve used this service recently and they are always willing to help.

Best Regards.


ok will do. Thanks everyone . You learn something new everyday! I was shocked to see those other applications . Again thanks for the insight !

wow never heard that either. Many thanks. Yes I boought the os for install. I have thier jolla one phone but the new os I guess does not work and its 2g so I was having radio reception issues. I willwill contact thesethese folks as well.

It IS necessary to allow ‘untrusted software’ , make an account on OpenRepos, install Storeman & enter the credentials of the OpenRepos account into Storeman. Otherwise it will not work.
And - Storeman very often forgets the credentials - remembers them only for a few days. This is known bug, don’t worry about that.


Sorry for the follow up…I don’t see an install. for the application

Do I click one of these or is their a users guide? I asking before I looked …I should have looked before I asked…


I don’t recall to ever having made an account on openrepos and entering any credentials.
If I check the settings in storeman app, there is a log in option, so I appearantly am not logged in, but I still can install software


you have to add repository, then you can install the app


Thanks for information, I did not know that this is possible and made an account immediately in the beginning of all my SFOS activities.

@808 In general, as @davidrasch said before, on installing something from Openrepos, you have to add the repository first, then you can install the software (edit: in a second step). Every repository has to be installed only once, then it stays installed and there is no need to add again if installing further software from the same repository at later time.


I sure hope so. I stayed on 4.1 to avoid further problems - until now, when the update notification started to annoy me too much. So I did the update thinking “well, it’s been quite a while that 4.2 is out, it’s probably okay by now” and then I jumped on to 4.3 immediately, because I only realized how young that version was when I started to research about the troubles the phone now gives me.

As for updates, when I read the description of what they do, my mind goes “don’t care. doesn’t help, couldn’t care less”.

For years I feel that Jolla IS TOTALLY NOT listening to the users. For me as being someone who isn’t involved it seems like they “just randomly do stuff”. The UX tends to get worse as it becomes more and more an Android knock-off.

For me, if the entire focus was on improving the base system and let APK’s and SFOS community take care of apps, that would already be perfect. I wonder how many share this opinion?


I think there is something MAJOR that newcomers don’t seem to know or understand…are ya ready for this bombshell?, ahem!,DRUM ROLL PLEASE!!!..BBRBRBRBRBRBRBRBRBRBRBOMP!!,TSH!!!..

SAILFISH OS is a CORPORATE OPERATING SYSTEM and is not really AIMED at END users who just ‘want things to work’ - maybe that will help you make up your minds about several things, but, just to reiterate, the OS is aimed at CORPORATIONS and not the man in the street.

We are BUG HUNTERS and WE PAY FOR THAT PRIVILEGE, if you don’t like Jolla’s business model, take yourself OFF this forum and quit filling it with nonsense along with all whinging and whining, dumb feature requests and the like, and YES, I am guilty of nasty, horrible comments aimed directly at the really POOR parts of the OS, until I realised it is not about US, the end users, it is about shaping an OS fit for CORPORATIONS and soon (I hope) Jolla will be looking into the AUTOMOTIVE industry!

The paltry fee you/we/I pay for the OS barely covers the admin involved in making the OS available for ‘public use’, so for those of you who have paid, QUIT WHINGING about the cost!, nobody held a gun to your head forcing you to buy, YOU decided, YOU paid and now you don’t like it?, well, there is always the expression - “BUYER BEWARE!”

IF, I have any of this wrong, or I misunderstand things, please, do let me know…I’m sure some of the more eager newcomers will be FULL of things to say!


Just one thing: Why would corporations not want a stable OS?
(No, I don’t think something great will come of a mediocre process - even if that process is applied for many years.)