The Volla 22 (Gigaset GS5) Thread

I’ve send you some beer, so you can look more relaxed on this list :yum:

By the way. I’ve installed waydroid in the meantime. And the performance compared to my Pro1 is much worse. Is this normal and has this to do with the memory leak which @piggz has mentioned? That’s not an big impact for me, because I hardly use Android apps. Just wanted to ask.

And further by the way: At the moment it looks like i stay with the rephone as DD. I have listed things which do not work properly, but I should have mentioned as well things, which work (at least so far) much better than on the Xperia 10 II:

  • Fingerprint sensor works flawless and without hicups.
  • I often had problems booting the Xperia, because of the encrypted home partition. I sometimes needed up to 5 or 6 boot processes for having a running system (I had that on my Pro1 as well). The rephone boots so far very reliable without any hicups.
  • To run Puremaps and OSM Scout I always needed to switch on frame rate view, to avoid these apps constantly crashing. On the rephone they simply just work.

So all in all, yes, there is still some work to be done, but the port quality is not worse than the official builds. Great work!

Heh! Thanks!

I really don’t have any waydroid experience. @teracube or @Pasik2 or @Seven.of.nine I’ve lost track who has what device!

I’ll see if I can get to rephone / gs5 debugging tomorrow. The network and video issues (documenting the lives of children!) are keeping me from using the rephone as a daily which is a bit sad since it’s extra ram is nice.

1 Like

I also have a Pro1 and Waydroid’s performance is much worse on the Volla 22. The whole phone is more sluggish when Waydroid is running.

1 Like

Thanx for this info. So i see that as given at the moment.

I’ll ditto that. Not sure if I can help on that front since I don’t use android stuff. But @piggz seemed to be aware of a memory leak so that sounds like a plausible avenue of investigation.

Can someone tell me if Hotspot is working?
I have unfortunately tried to install blocky (Adblocker) before testing if hotspot is working.
After that I read, that there is a problem with hotspot, when you install blocky. And indeed hotspot didn’t work. So i uninstalled blocky again, just to recognize, that ads were still blocked. So I installed it again, stopped the service, disabled the service and uninstalled blocky again. now ads are here again and I’m able to connect to the phone again. But unfortunately without getting acces to the internet (restricted connection).
So now I’m unsure if I broke something or if that is an issue of this port.

when I try to start Waydroid I get this message

$ waydroid log
(005115) [00:02:42] Failed to get service waydroidplatform, trying again...

Has anyone else had this error message?
Waydroid was installed with chum and the correct settings made in waydroid-gbinder-config-hybris.

Have you done this?:

I don’t remember. I’ll try tonight, back home and report.

1 Like

Yes, I did it, like GitHub - sailfishos-open/waydroid: Waydroid packaging for Sailfish OS
Now, I reflashed my GS5 (as Volla Phone 22) again and tried with fresh Installed only chum and waydroid, but the log is the same.

And you have as well uncommented #bind-interfaces in /etc/dnsmasq.conf?

Yes, I just added that. After a reboot it didn’t change anything.

Then I’m clueless. That are the only two stumbling blocks, that I’m aware of. Have you typed the changes in /etc/gbinder.d/anbox-hybris.conf or made via copy and paste. Maybe there is still something wrong.

Hotspot works on both the GS5 and the rephone for me. EDIT: I only use DNS to block ad servers (hosts).

1 Like

F**k, then I have to reflash probably. Grrrrrr… :unamused: :rage:

I wouldn’t go that far! It was blocky that led to the issue?

Yes, probably. The only things Which could have an impact on that, are blocky and waydroid.

So, two possible issues. dnsmasq vis. waydroid, conman dns config vis. blocky. Just need to find default configs. sek.

For blocky, using as a reference:

  1. make sure /usr/lib/systemd/system/connman.service.d/override.conf is NOT present
  2. cat /usr/lib/tmpfiles.d/connman_resolvconf.conf should contain
d	/run/connman	- - - -
L+	/etc/resolv.conf	- - - -	/run/connman/resolv.conf
  1. cat /run/connman/resolv.conf should contain
  1. netstat -tulpen should show
tcp        0      0      *                   LISTEN      0          138642     2526/connmand       
tcp        0      0 ::1:53                      :::*                        LISTEN      0          138646     2526/connmand 

The last only if dnsmasq is not running/waydroid. I have to admit I don’t know much about waydroid.

One could also look at the connman configs in /etc/connman, but I don’t believe blocky touches those at all. It just uses a systemd override to switch flags.

Hmmm. I’m not sure why, but the postun in blocky removes /etc/resolv.conf that is neither necessary nor desirable, I think. EDIT, my /etc/resolv.conf contains a note it’s generated:

# Generated by Connection Manager
nameserver ::1

SOO, the postun is correct in removing the resolv.conf, though I don’t get it since the contents barely (- ipv6) differ.

  systemctl daemon-reload
  rm /etc/resolv.conf
  systemctl restart connman.service
  systemd-tmpfiles --create

I believe restarting connman.service regenerates the resolv.conf

But checking can’t hurt.