The server password in the email client cannot be changed

REPRODUCIBILITY (% or how often): always
BUILD ID = OS VERSION (Settings > About product): 4.0.1.18
HARDWARE (XA2, Xperia 10…): Jolla C
UI LANGUAGE: pl_PL
REGRESSION: (compared to previous public release: Yes, No, ?):

DESCRIPTION:

the server password in the email client cannot be changed

PRECONDITIONS:

change password to your email account and smtp server and imap server

STEPS TO REPRODUCE:

Settings → Accounts → General email → Server settings from pulley menu → change imap and smtp passwords to new ones → swipe to the right → synchronize from pulley menu

EXPECTED RESULT:

sync with my email account

ACTUAL RESULT:

When I open General email from settings :
mar 12 10:38:07 Sailfish estart[10101]: [W] unknown:-1 - file:///usr/share/accounts/ui/EmailCryptoSection.qml: File not found

When I want to sync with new passwords:

mar 12 10:39:51 Sailfish syncemail-client[11944]: [W] unknown:0 - void EmailAgent::activityChanged(QMailServiceActio
n::Activity) operation failed error code: 1029 error text: “a002 NO [AUTHENTICATIONFAILED] Authentication failed.\r
n\n[Login failed - check user name and password.]” account: 5 connection status: 0 sender: QMailRetrievalAction(0x19
7bf80)

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

6 Likes

Interesting… I can confirm that I couldn’t change my password (for an invalid one, at any rate) on a Jolla C, 4.0.1.48.
Didn’t see what OP posted on the journal.

This is an old bug for many years now, mentioned several times - so far the only solution that works is to delete the account and create a new account from the scratch.

When setting up a phone from the backup file you are encountering the same problem, see this thread

4 Likes

Seeing the same. Also, the SMTP setting got lost and I don’t even have the possibility to set/change them.

I have hit a related problem, that is difficult to reproduce it involves an issue at the server to trigger.

Email type: IMAP/POP
Device: Sony XA2 using latest Sailfish version.

A couple of days ago there was an authentication issue on the email server that meant that attempts to check email failed with authenticaion failure. This was for attempts from two different devices (Sailfish & Adnroid) and to two related server accounts.

When the server issue was resolved, the Android worked fine, but the Sailfish account now had its passwords set to “default” and so continued to fail. I was unable to change the password back to the correct value.

The only workaround was to delete the account and recreate it, with the correct password.

This has happened again. This time it seems the cause may have been something different.

  1. Server had authentication issues.
  2. It was fixed and I could download email again.
  3. 1-2 days later the email authentication started failing and the passwords showed as “default” in the settings.
  4. Only a delete and re-creation of the account worked.

I don’t know if this is a separate bug, but is we could edit the password field in the account, it would be less of a problem.

This is so annoying and accompanying us since many years now. And still in 4.3.0!
So each time restoring a backup you are forced to re-create your mail accounts?!
What kind of …lost words…

Imagine the wonderful camp fire stories a few years after that bug will be fixed. :grinning:

1 Like