Talk Maemo Org is down

I realise this is not quite on (any) topic but I went to visit yesterday and it was off line, today it is still offline, anyone know what’s happening?

Works for me. (20 char limit)

Okay, weird. I’ve had this before, i was prompted to clear cookies and restart browser, I still canot reach TMO, not on my phone either.

Oddly, ' also shows TMO as being ‘down for everyone’ so how are you reaching it @ApB; same for ‘’ …strange indeed.

Upon my Mac which had just been updated to OSX BigSur noticed yesterday that my saved “bookmark” in Safari no longer connected to TMO. As no problem using Chrome browser had to delete existing bookmark and create a new one with no problems since.


try with

and see here for some insights


I have the exact same problem, no matter what I do I can’t access don’t see it up neither.
But downforeveryoneorjustme see it up (and me too):
image is up again, and so am I. :grinning:

Could it be http vs https confusion (and lack of automatic redirect)?


Nothing has changed my end, the shortcut I’ve been clicking for years is still as it was. Entering the URL with http or https makes no difference, I still cannot reach the site, cookies are cleared, I’ve tried entering the site manually and by shortcut, for me it is down and those sites we use to check if a site is up or not, all say ‘talk.maemo’ is down for everyone, but some are saying it is up…weird, TMO is the only site I have these problems with. I tried my Jolla, my notebook, my laptop, my mother’s ipad, none of them show TMO.

Makes no difference for me :frowning:

That appears to be excactly the problem

@edz then it is really only for you :hushed:

http does not work since Sunday/Monday but https does work

as xes said on IRC

It is down for me as well, trying https

Strange. For me it is working (only https). Maybe some DNS?
Would you try with IP

1 Like

no luck. reports being down as well.

1 Like

Yep, TMO uses https now but doesn’t redirect from http to https.

1 Like

Excatly - is still working while does not work

As said before :sunglasses:
Please check yourself with


Yeah, it’s only me it seems. I’ve cleared cookies, cleared history, cleared bookmark, still cannot connect to TMO.

EDIT: I’ve also reset Chrome, tried IE11 (already on PC), still also cannot access TMO via my Jolla1 (both of them), I have flushed DNS, …I have no idea what else to try. Oddly enough, I can access Maemo.Org just not Talk.Maemo.Org