T-Mobile Network Denied on Xperia 10 II

I just installed SFOS on a new international 10 II (dual sim.) I was able to connect to the internet when the device was running Android, but now that SFOS is in it spins while trying to connect for a bit before the network status flips over to Denied. Does anyone know what causes this? It seems some others are using the device on T-Mobile fine, but I have this reproducing on two of them now and T-Mobile wasn’t able to help much (I thought there was some weird carrier lockdown going on with the first, bought a second when I had spare cash.)

Can you install ofono log, turn it on, then toggle airplane mode on and off? Post or dm the log.

Last night I had some time to do some experimenting:
I was able to successfully use the SIM while on the stock sony image.
After flashing to sailfish it started with the “denied” messages.
I then flashed to AOSP, same problem, so whatever the issue is is “beneath” sailfish.
I’ve just now beaten it back into being flashed with the stock sony image, which was a total nightmare, and it no longer connects.

Since the 2nd 10 ii isn’t running Sailfish this is from my first one: at the start it had 4g connectivity, could make calls, etc. Then it got kicked off the network and would only get “Denied” when trying to connect. log

I think I made some progress in the last few days. The Sony rom fails until I update Carrier Services. I’m guessing T-Mobile made some configuration changes within the last few months which SFOS and the underlying Android install can’t understand. If there’s some way to extract whatever SFOS would need from the Sony rom I’d be happy to help.

Did you already try to set your data access protocoll to ipv4?

That allowed it to connect temporarily but then it was kicked off. Also going around town the Xperia 10 ii running stock Android was kicked off of the network, though I think that may be because the stock firmware doesn’t support T-Mobile’s VoLTE?

ofono log with data set to ipv4: http://tekk.in/ofonoipv4.tar.gz

I seem to remember @robthebold was having this problem with the 10ii back in August, any ideas? (@hackman238 was a big help then too, as now)

1 Like

Seeing if I was the only one was part of my intent in asking the question. I seem to have it working for now (maybe the last 3-4 hours or so?)

The magic trick seems to have been putting in an unrelated sim. In my case it was a Simple Mobile (T-Mobile reseller) one. We’ll see if this holds…

Nope, back to Denied shortly after making the post.

1 Like

The instructions there seem to no longer work, sadly:

[root@Xperia10II-DualSIM defaultuser]# zypper install --force ofono-ril-binder-p
Loading repository data...
Reading installed packages...
Forcing installation of 'ofono-ril-binder-plugin-1.2.6-1.4.3.jolla.aarch64' from repository 'adaptation-common'.
Resolving package dependencies...

Problem: This request will break your system!
  the installed ofono-binder-plugin-1.1.5-1.4.2.jolla.aarch64 conflicts with 'ofono-ril-binder-plugin' provided by the to be installed ofono-ril-binder-plugin-1.2.6-1.4.3.jolla.aarch64

 Solution 1: Following actions will be done:
  ignore the warning of a broken system (requires:droid-hal-version-xqau52)
  deinstallation of ofono-binder-plugin-1.1.5-1.4.2.jolla.aarch64
  deinstallation of patterns-sailfish-device-adaptation-pdx201-
  deinstallation of patterns-sailfish-device-configuration-xqau52-
  deinstallation of droid-hal-version-xqau52-0.0.2-1.3.152.jolla.aarch64
 Solution 2: do not install ofono-ril-binder-plugin-1.2.6-1.4.3.jolla.aarch64

1 Like

Indeed, my Sony 10 Xperia II has been suffering from the same issue, that is Network status is denied. A fix of reinstalling ofno drivers did resolve issue temporarily. Red Pocket an MVNO of T-Mobile, SIM card was replaced, and the same issue on phone with Sailfish OS.

I apparently received a call from T-Mobile on Friday stating that they had an actual engineer look at it and determined that the Xperia 10 ii “is incompatible with their network.” At the moment I have a Google Fi sim coming to use as evidence that it is compatible, if it does in fact work.

Another weird update: on Friday I trekked out to the T-Mobile store and bought a smartphone, though they had to mail order it in.

Ever since placing that phone order it seems like my phone has just worked? I’ve been bringing it out around town the last day or two and I haven’t been denied yet.

@X0X0 you didn’t happen to get a flip phone from T-Mobile when you signed up for your plan like I did, did you?

@tekktonic For the Sony Xperia 10 II I am using Red Pocket SIM card and service, which is a reseller of T-Mobile in the US. And the phone is “denied” indeed from the service.

I had not tried T-Mobile SIM card nor plan on the Xperia 10 II phone. Perhaps I should give this a try, go to the T-Mobile store, and ask them to add another line for my “Pre-paid” plan.

On the T-Mobile Pre-paid plan, I do have Sony Xperia 10 III, and it is working like a charm, excluding videos SMS where I cannot receive a video on the phone. I did follow instructions that were posted at one point here at Sailfish Forums to have the phone running, I believe.

I do have no flip phones, but I do have a non-smart ‘dumb’ phone that is active via Red Pocket, with ATT or AT&T service and SIM Card. Purchased from Amazon, and it is Nokia.

Would utilizing T-Mobile SIM card and service yield different results from utilizing T-Mobile service reseller? That is a good question, and I do not know if there will be a difference or not.

1 Like

Interesting. That makes me wonder if it’s the same thing. ie if you purchased a cheap smartphone from Red Pocket and had them ring it up, if your 10 ii would start working with their sim (Or just buying a used t-mobile phone on ebay.)

The phone is still holding up now, even driving between towns through areas where I had no service. When I had a super weak signal my phone would drop to “Denied” but then connect again when I had a better signal.

1 Like

I do remember at this forum, the suggestion of using an already activated SIM card on the Xperia 10 II phone, thus to have the Xperia 10 II working. I might try that too. I do have a T-Mobile phone that is without a SIM card, where I can get for it a SIM card from T-Mobile and activate the card, then transfer it to the Sony Xperia 10 II.

Of course, if I do try any of the methods that you suggested, I will leave an update; at least to figure out a pattern on how to “avoid” the denied service.

Now such begets this question: Are these phones blocked by T-Mobile because of their IMEI ? I do not doubt such. I am trying to remember if I did try to activate the Sony Xperia 10 II at T-Mobile store, and then later, hours later it was denied. I believe that happened with Red Pocket too, the phone would connect then get “denied”. Activating the SIM card initially with a different or “official” phone, might yield different results, as you do suggest.

There is an interesting discussion about IMEI ‘changing’, again, only if legal in your jurisdiction, at the Pine64 forum. I think it should be an option for these Android phones, thus to have them ‘un-denied’ and be able to utilize any service, and internationally.

This discussion is exposing interesting concepts. Not promoting anything here, and I hope I am breaking no rules, yet I find the discussion regarding the legality of IMEI swapping or the necessity to perform so, even by companies who purchase devices from China manufacturing en mass all imprinted with the same IMEI, has some virtues. Again, we are talking about PinePhone, where it is possible with ease, not an Android device.


I get a sense they don’t like it here, in the US, to have more options with your Android phone, that is an international device that was ‘not made for US market’ functioning in the US. I think T-Mobile and Red Pocket are blocking the Sony Xperia 10 II intentionally according to your experience.

I was using that method, but my phone would still get kicked off until I bought a smart phone. Previously I was using T-Mobile flip phone models as at the time I didn’t have a phone for BYOD and they were the cheapest option (I also wanted to take a look at KaiOS.)

Edited to add: to be clear, I’ve never inserted my sim into the phone I bought. Something seems to have happened on the network end when I bought my phone which lifted some kind of lock on my account. The T-Mobile store didn’t have any of the phone I ordered so it had to be mailed to me.

That doesn’t explain why it’s working now, though. I’m definitely no IMEI blocked.

For 10ii users in general:

  1. Have you experienced the “Network Denied” error where your phone will be kicked off of the network and can’t reconnect, but it works fine until then? This can usually be temporarily “fixed” by inserting the SIM into a supported phone and letting that phone reconnect to 4G
  2. Was the previous/only phone on your plan a “dumb” phone? (One of the GFlip variants from TCL or Alcatel for example.)

In my case it’s

  1. yes
  2. yes, and it seems to have resolved when I bought a smart phone from t-mobile.

A bit late to the party, and I don’t own a 10 ii, but wanted to add my two cents. You’re both saying that your 10 ii’s worked on T-Mobile with Android, right? When I first started skimming this thread, I was afraid it was the band 12 issue. You know about that? T-Mobile uses band 12 in non-traditional coverage areas, so they don’t want phones on their network that support band 12 and not VoLTE because if you need to make a 911 call from a band 12-only area your phone will literally have no other band to fall back to. And by law carriers have to support 911 (actually E911). I posted some threads on this back during the summer: Beta VoLTE on the Xperia 10 III, disabled by default - #85 by tao101 .

But if Sailfish connects noticeably worse than Android, I draw a blank.

From what you’re describing above about buying a throwaway, approved T-Mobile phone, it sounds like you’re tricking their back end into giving you a permanent get-out-of-jail card. You never officially told them about the 10 ii, right? So as far as T-Mobile is concerned, the throwaway phone IS your daily driver, and it seems any phone using the associated SIM gets a pass. Or did you actually buy an extra line? I think that would be even funnier, as it suggests that every phone on your account now gets a pass. I think this makes some sense from my own experiences, since for a while I was getting emails and snail mail letters about T-Mobile dropping their 3G network and please contact them for a free 5G phone. I haven’t used a 3G-only phone for quite a few years. It was a cute Nokia E73…that was T-Mobile branded. T-Mobile has the ability to see that what is connecting via my SIM card is 4G LTE, but their back ends obviously don’t talk to each other.

Did any of that help?

No, I bought a separate 10ii and left android on it. It had exactly the same behavior.

This one was ruled out by someone in the VoLTE thread. Basically the carrier can’t detect the absence of a connection.

correct but specifically a smart phone. When I bought my plan (I’m an AT&T refugee,) I bought one of their flip phones as the cheapest option since I planned on hotspotting to my broken phone until I could get a 10ii. Since going back to t-mobile and buying a “real” smartphone my 10ii has worked. I never put it into the smart phone (It actually just arrived via mail yesterday,) but buying it did something.

Okay, I get that. But out of curiosity, do you live in an area where band 12 is prevalent?

I guess if you’re happy with the status quo, declare victory and move on. If you’re still curious about what was happening, I’d be either going back to T-Mobile and trying to clarify what the engineer said. In what way is the 10 ii incompatible and how does their network sense that? Or post the question at https://forum.xda-developers.com , https://howardforums.com/forums.php , etc. as somebody over there probably knows the answer. Maybe leave out Sailfish to not muddy the waters?