Spotify Android app does not recognise a premium accout

My Spotify app refuses to acknowledge that I have a Spotify premium account and will therefore not allow me to download songs/albums/podcasts and show med advertisements. It also don’t show any difference between online and offline mode, perhaps that is related to the “you don’t have a premium account”-issue.

Does anyone else have, or have had, the same issue?

I have Spotify installed as you get it set up from the Android Store.
I have checked with Spotify and they recognise my account as a premium account and on other devices where I have Spotify installed I don’t have this issue.

Perhaps it is unrelated but I managed, by mistake, to uninstall my android app support the other day while still having Spotify and one other android app installed. I re-installed the android support but neither of the two apps wanted to work after that. Hence I removed them both, reinstalled the android app support before installing the apps again. Now I have the issue described abowe with Spotify while the other app works as it should.

To try to fix the issue, I have:

  1. uninstalled all android apps,
  2. uninstalled the android app support
  3. manually removed the android-storage folder via the File Browser app
  4. restarted the phone
  5. reinstalled android app support,
  6. reinstalled my android apps, and
  7. logged into my android apps.

It still doesn’t recognise that I have a premium account and it doesn’t always want to start the app. I can have to try up to 10 times to open the app before it actually opens up.

What else can I try to get the Spotify app to realise that I have a premium account?

Thank you,


Try cleaning the Spotify cache, removing its data, and log in again. (Are you sure you logged in with the account that has premium access?) Also try downloading Spotify from the Amazon appstore, to be sure that it is Google-free.

Thank you for your answer.
I have been trying to locate the Spotify cache and can’t find it. Can you provide the path to the folder?
I only have one Spotify account so I am sure it is the right one.
Doesn’t Amazon appstore also require android and an account?

Settings -> Apps -> pick the Spotify icon, then clear cache and clear data.
Yes, the Amazon appstore requires Android and an Amazon account, but apps hosted by Amazon do not require Google services.

Thank you!
As I have unistaled Spotify, I then take it I can’t have any remaining cache from it. :slight_smile:
Perfect! I didn’t know that. I never install apps requiring Google services and didn’t know where to find apps that don’t. Now I do. :slight_smile: :slight_smile:

1 Like

That proved to be tricky. I have logged in on a Amazon via the Sailfish internet browser and try to download the app. I get two error files named netError.xhtml and netError.xhtml.part and no app.
Is there another way or do you know what these error files mean?

Install the Amazon Appstore apk downloading it from an external site, try googling for amazon appstore apk.

Got it. But there is no Spotify in Amazon App store. Perhaps there was at some point, but not today.

Any other possible solutions?

You are right, search does not find it, but it is shown (but not updated) in my apps.
Anyway, it is listed on Amazon apps. Here it is:
I don’t know why it does not show on the Amazon Appstore app.

And it is that link that leads to a “Download our app store” situation and that download of the app doesn’t work. :frowning:

I managed to download the app from apkpure. Unfortunately it too behaves just as described in my initial question.

Premium works for me on both Jolla C with Alien Dalvik and with Sony XA2 with the Android 8.1 system.

I have Google Services in the Jolla C and Micro G in the XA2. Spotify installations are from Google Play and Aurora Store. Aurora also installs from Google.

Hi hetas,
Thank you for your answer. However, I am not a fan of Google Services and would not install it, even if it could potentially solve my issue.

Well I don’t know why Google services would be needed just for the premium account to work. But theres some weird dependencies sometimes.

You could try Micro G just to find out if it makes a difference and uninstall it then.

Nor do I. So I don’t really think it is the lack of Google Services that is the issue here…
I’ll keep looking.

Try to delete the directory
manually (if you are using SFOS on a XA2 or 10). IIRC the deletion via the native Settings is broken.
I am using Spotify with a premium account without issues on my XA2, I installed it via the Aurora store and I am neither using Mikro G nor GAPPS.

Here is how to perform a clean reinstall of the Spotify app.
For Android - 6.0 or above

  1. From the Android home screen, tap Settings > Apps .
  2. Find Spotify in your list of apps, tap it and clear the storage, including the cache and data.
  3. Once done, select Uninstall .
  4. If you are using an external SD card to store your downloaded/offline music from Spotify, it’s best to delete the file . You can spot it using your device’s File Manager > SD card > Android > Data.
  5. Once all this is done, switch your device off and wait a couple of minutes.
  6. Switch your device back on.
  7. Open the Google Play Store then search for and install the Spotify Music app.
    Or you can draw help from tools like Spotify Downloader Mac to help you download music without a Premium account.

Hi Alex,
Thank you for your answer and I am sorry for the late reply, I have been on holidays. :slight_smile:

I use the 10 but unfortunately I don’t have a folder there. The /home/nemo/android_storage/Android/data/ only contains .nomedia.

The procedure is applicable anyway, just replace Google Play Store with whatever you are using to download Spotify.

Ok… I have now followed the instructions, still don’t work.
The app starts, after a few attempt to open it, but still doesn’t recognize my account as a premium account.
I have tried logging in on Spotify on an Android phone and there I have no issues with the account type. So I believe something is wrong on “my end” and not Spotify’s.