Sounds and feedback doesn't work after sfos-upgrade verify

Yesterday I ran in a console ‘sfos-upgrade --verify’ to ensure that all packages for an update from to are there and uptodate. After a reboot I also ran the past_sfos-upgrade command. Every command was successfully. No update issues were reported. Now no sounds and feedback (vibration, incoming / out going call, LED notification and more) are working anymore. Also the jolla media app does not want to start anymore.
Do any of you know what I can do to make these functions work again?

Install Install History app from chum, maybe something got uninstalled by the script you ran?

@throwaway69: Thank you for your advice with the Install History app. I checked my de-/instalkation with it. Nothing was unintentionally removed with the script. I ran sfos-upgrade and post_sfos-upgrade again. All was up to date. Nothing was new installed. But what is with these four packages

marked in light blue? They were updated but not installed. Can they are the reasons for the problem?

1 Like

If I now update my phone from to via settings → check for new updates ->update software, is there then any possibility that the phone will work normally again?

Gstreamer and ffmpeg might be responsible for audio issues and the media app, did you install something recently (or enable maybe some weird repos in storeman with experimental builds of related libraries)?

1 Like

Yesterday I uninstalled Music Explorer (harbour-musicex) from arnachy_in_the_uk and on Wednesday I installed deadbeef-silica from kravich.

Deadbeef not supported in 4.6 according to Broken apps in maybe related? Try uninstalling it and see if the 4 packages still give you same output
Edit: did you run maybe sfos-upgrade with parameter and put yourself in release mode??? From description --verify shouldn’t really cause issues

I uninstalled deadbeef-silica and ran sfos-upgrade --verify and post-sfos-upgrade again. I got again the message “The following 4 package updates will NOT be installed: ffmpeg ffmpeg-tools gstreamer1.0-plugins-bad libjpeg-turbo”. Also the jolla-mediaplayer 1.3.5 was re-installed although 1.3.13 was already there. The problem still remain.
Do any of you know what I can do to make these functions work again?

1.3.5 is from 4.5 so the correct one, you should not be seeing 1.3.13 that’s from 4.6, did you change ssu re to 4.6? It seems like you have now a mix of 4.5 and 4.6, so make sure you have a backup

1 Like

As far as I remember I had similar issue and it was related to gstreamer’s packages that were not from the same version. Try disable lpr repository and then run upgrade verify or manually find wrong gstreamer package and reinstall respectively.

1 Like

These are the gstreamer packages which were installed by sfos-upgrade --verify on 23.05.24:

Are these the right versions? Or are these packages not for a Xperia 10 II?

If I try to call the command ‘pkcon repo-disable lpr’ then this command will not finalized. I only see the message: wait in waiting queue and nothing happens. What is the reason for that?

I only installed jolla-mediaplayer with ssu re 4.6. Nothing more.

Hi kani_bal: I searched for all my installed packages with ‘zypper pa -i’. See

. Is it now visable that I have not all gstreamer packages from the same version?

So you probably have now mix of 4.5 and 4.6 packages which will very likely cause the update to fail (and probably also trying to downgrade with ‘sfos-upgrade’), the latter option has probably higher chances of working, just make sure you make a backup and be ready to reflash

Yes, it is. You should have all only installed (i) from jolla (prefered) or openrepos-lpr. The best way to solve this issue is to disable repository openrepos-plr and then fix packages.

1 Like

Hi kan_ibal. Thank you for your advice with the disabling of the lpr repo. Now it looks like this:

, but sounds and feedback unfortunately does not work. Must I remove additional gstreamer packages? Like gstreamer 120.7, gstreamer plugins bad, gstreamer plugins ugly 120.4 because they are still installed from lpr? And then again run sfos-upgrade --verify?

1 Like

Yes. sfos-upgrade --verify or manually, one by one.

I’d try ~~zypper~~ pkcon install <package> for the ones from lpr, maybe decorated with --allow-downgrade --allow-reinstall.

zypper install <package> with --allow-downgrade --allow-reinstall is under Sailfishos not available. Is there a alternative? Pkcon remove gstreamer1.0-1.20.7+git1-2 does also not work.