Sony Xperia 10 II Review (a lot of problems)

@Pasik2: thanks A LOT for the link. Not sure why i could not find it. Now it was possible to check what app is using all the RAM. It was the android layer. It uses about 1,5 GB.

Is it possible that the “shift + M” function is not working in top, because i deinstalled busybox?

Again, thanks to everyone for the infos. It helped a lot to find out what the problems are. I will try to only start the android layer when i play games now. It is just weird that i could listen to music in the browser AND play i.e. world of tanks at the same time on the Jolla C. This is not possible anymore. Well, maybe a patch will make the RAM usage go back to normal one day.

edit: i also found out that the browser is using about 1,5 GB of RAM or even more with only two tabs opened.

edit2: btw: what also helped a lot now was to change the out of memory killer app to 85-90% with:
devel-su
echo 85 > /proc/sys/vm/overcommit_ratio
i found this on [Discussion] Oom Killer fine tuning (overcommit_ratio value) - together.jolla.com

One bug is still very annoying. I hope you guys can help with that too. Why is only the 5 Ghz wifi band working? It is even worse than any wifi i ever had on any device. Any idea or anyone who got both bands working?

2 Likes

My experience about bugs you wrote on this thread is:

  1. It works fine for me
  2. Sometimes I have this issue and I solved it as @cartron said
  3. App-shop: you are right, but you can find more apps on openrepos or chum repository
  4. It works fine for me. My old phone is a Xperia XA2 and I can confirm that gps works much better on Xperia 10 II. I use ‘only device’ gps option.
  5. and 6) I agree with you, Ram usage must be improved
  6. I haven’t notice that
  7. and 9) I only use one android app and I don’t have any problem. Sorry, maybe other users can help you.

There is a bug that is not include in your list: if you enable call recordings and you record a call outgoing, mic will stop working. I opened a thread about this bug here: [4.3.0.12][4.2.0.21] Xperia 10 II: Mic doesn’t record sound after recording an outgoing call

I’m impressed that nobody commented nothing about this bug, I need to have call recording enabled on my phone ( I use it since jolla phone) and it’s very annoying to record a familiar video and notice there is no sound on it.

2 Likes

An important step for improving the speed of getting a GPS fix is to install one of the MLS Positioning packages from the Jolla store (search for “Positioning” or “MLS”). @wayn3, it’s possible this will help if you’re having trouble getting a satellite fix. See the 4.2.0 release notes for more info.

1 Like

But MLS packages from Jolla Store are not updated, right? From my experience, this doesn’t improve gps positioning on my phone. I’ve tested that on my xa2 phone without finding an improvement, and as I said before, positioning gps works fine on my xperia 10 ii: I get position on <2 minutes

3 Likes

I got GPS working quite good now with some hints from the forum. I always keep the “GPSInfo” app open and some custom configuration in the gps.conf file. I use the nokia provider instead of the sony one now.

But still thanks, i installed the MLS packages and will see if it even improves everything.

I guess keeping GPS running (via leaving tbe GPSinfo app open) will always get you a quick fix because you’ll be tracking the satellites all the time, but at the expense of a bigger battery drain.

2 Likes

If i close GPSInfo i have no GPS signal at all. It is like there is no GPS in this phone then.

GPS has never done anything useful on my XA2 Plus, regardless of the mode or the mozilla additions.

It’s true that the packages don’t use the most recent data, which differs from if the online MLS database was being used. But it is basically a list of cell tower IDs and locations. If a physical cell tower is removed/added and the database isn’t updated, it won’t trigger a hit in the database. So installing the packages shouldn’t make getting a GPS fix any slower, but may (should) improve things.

If I understand correctly from reports made elsewhere, there is something else going on with the XA2, so as you point out, experiences with the Xperia 10 II are likely to be different compared to the XA2.

2 Likes

In general, GPS will only activate if there’s an app requesting location info. If you have GPSInfo closed, is there some other app that you’re expecting will get location info, but which isn’t?

1 Like

Can confirm that GPS only works if GPSinfo is open, despite GPS is enabled in settings.

  1. enable GPS in settings
  2. wait 10 minutes
  3. start GPSinfo
  4. no sat’s received or sync’ed, but immediately begins to receive
  5. 30 sec later, GPS works.

Conclusion: GPS starts NOT at enabling it in settings, GPS starts only after starting a GPS app under condition GPS is enabled in settings.

1 Like

@flypig: In the past when i opened apps like the escooter app “Lime” or maps without starting “GPSInfo” before, GPS did not activate and i had no GPS in those apps. Now i tried it again, but after changing a lot of settings (nokia instead of sony as provider in gps.info + installed MLS packages) it suddenly works. It activates when opening the apps and stops when closing. So good behavior now. I don’t know what changed it exactly.

Thanks for replying and I’m glad things are now working as expected. Just to check, were the apps that were failing to activate GPS all Android apps? As far as you can recall, did you have the same problem (GPS not starting) with any native (non-Android) apps?

I only ask in case it helps better understand what the problem may have been.

1 Like

I am not sure about the non-android apps, i only tested it with android map apps, like “HERE We Go”, “Google Maps”, “Lime”.

Of course this is the way it works. Everything that is not needed is turned off to preserve battery charge. The sore point is that once turned off for a while the XA2 GPS receiver will take a lot of time to get a fix.

1 Like

Thats exactly the reason why i want to be able to start GPS manually BEFORE I really need it and/or keep in a working state by manually switch it on, so that it can provide GPS data immeadetely if required by some app.

It’s absolutely nonsense from Jo* to let the user manually switch on GPS and do nothing, and when the user wants to access GPS data, there are none… In this case the settings should be named something like ‘allow GPS’ . But on should be really on and not something like standby or permission to eventually start with minutes delay… :unamused:

2 Likes

Keep GPSInfo open and the GPS receiver will stay on.

2 Likes

good workaround, i will do so. Gracias!

1 Like

That will probably drain the battery pretty fast.

Yes, but if i want to prepare for use of GPS in e.g. 10 minutes with Pure Maps, i can foresighted switch GPS on and start GPSinfo and do other things in the mean time. Later, if i really want to use it, it is ready synced and working. To save power, i close GPSinfo + Pure Maps and switch GPS off. That’s the workaround . It would be much more senseful if I could simply switch on GPS and it will work . If I want to save power , i switch it off. if I want to have it running I switch it on. I don’t need Jollas cleverness to save some battery power if I set GPS to on. If set to on, I want it simply to run and nothing else.

1 Like