Some beginner questions

I have just installed SFOS on a XA2, following instructions mentioned here. I also logged in on SFOS using my jolla account, and enabled Android support & Aptoide in the setup wizard.

I am able to run android apps, I have downloaded telegram and whatsapp from their respective homepages. The apks got installed automatically (which btw confused the heck out of me since there was no indication whatsoever that the apps would be installed automatically after download :confused: )

However, there is no aptoide icon in the list of apps, so I cannot use this store to browse for apps. I already restarted the phone and uninstalled/reinstalled aptoide from via jolla store, but it didnt change anything. What am I missing?

Then, is there a way to change android apps resolution? It feels like in telegram and whatsapp really big fonts are used, wasting a lot of space.

Next question: the apps on the jolla store seem to be really limited. Is there more repositories I could add, or is this about as good as it gets in terms of native app variety?

Thanks for your help guys.

1 Like

OpenRepos is full of native apps. Go for the Storeman app to download and install other apps.

3 Likes

Welcome @s710 :smiley: To reiterate what @eson mentioned, if you can’t find the native app you want in the Jolla store, OpenRepos is the next place to look.

Concerning aptoide, it should appear in the app list, so I’m not sure why that isn’t happening. One thing you could try is to install the version from the Jolla store. It should then update itself to the latest version anyway if it’s not already.

Edit: sorry, I re-read your post and see you already tried installing from the Jolla store. I’m not sure in that case.

1 Like

For Android-Apps: Download the F-Droid APK (https://www.f-droid.org/) on your mobile, then install it. If the Android App support is installed on your device, this should work.
There you can get the Aurora-Store (https://f-droid.org/en/packages/com.aurora.store/), from which you can Download all the free Android Apps directly from the google servers. Don’t login there with your google credentials, use the “Anonymous” option (don’t know the exact name).
I would prefer Aurora over Aptoide a lot!
(If you don’t want to install F-Droid, you can download Aurora here: https://f-droid.org/repo/com.aurora.adroid_6.apk)

2 Likes

If you don’t have any Google Service Framework (GSF) replacement installed (like Open GApps or MicroG) only those apps from Aurora that are labeled GSF-independent can be used.

1 Like

I think he could try all of the others to, but probably not anything will work then or they will plot errors a lot.

@s710: when you install native apps, do they appear in the app list just fine? And it’s not quite clear to me whether it’s just Aptoide, or all of the Android apps you’ve installed (Whatsapp, Telegram) that don’t appear. Could you elaborate please? Just Aptoide I think?

Ok great, I managed to make the “aptoide” icon appear (again, uninstalled and reinstalled), and I have also installed the aurora-store as advised by @fridlmue

Just to clarify: How would I install this? I have searched jolla store for “Storeman”, but it didnt yield any results. Visiting those links also does not indicate any installation instructions?

Go here: https://openrepos.net/content/osetr/storeman
And download the latest RPM for armv7 (as this is what your mobile supports).
I suspect you are on the newest Sailfish OS release (3.4)?! Then currently that is https://openrepos.net/sites/default/files/packages/6416/harbour-storeman-0.2.3-1.sfos3_.4.armv7hl.rpm for you.

And on OpenRepos take care with “Patches” at your first days with your Sailfish. Be aware that there can be Problems when Updating your Phone when you patch some stuff… So it is a good Idea to always read the Description completely, there is mentioned normally if it could get “risky”.

You probably found the wrong version then. Sideloading APKs sometimes have this issue, where you get one for the wrong DPI setting. Taking it from e.g. Aurora should give better results.

Didnt help much, still like zoomed in. Its okay-ish though.

So all in all, SFOS looks really nice to me, although seemingly not as feature-rich as other mobile OSes. What bothers me is that I cant get some of the apps. For example, I have tried like 4 or 5 telegram apps, with the most recent one (Fernschreiber) working, but beeing incredible slow, thus not fun to use. Of course, I can always fall back to android apps. While they work A LOT better than anbox on Ubuntu Touch, they pretty much break the look and feel, and also look kind of weird because of the different font sizing/DPI issue.

Also, I failed to get some apps at all for SFOS. For example, looking for german train schedules, there seems to be just one app, which does not even start. So again, I need to fall back to Android versions.

To actually have a replacement for my current phone, I would need in addition:

  • banking app
  • banking pushTan app
  • MS authenticator (for work)

Can those be installed from aurora store? I have some concerns here, since those are security related.

In addition, it seems like the SFOS browser is not that great. Some websites are just not working properly, and it seems like there is no alternate browser?

By the way, this post might sound like a lot of complaints, but its not meant like this. I am a long term iPhone user, but I want to move away from Apple mobiles, and I would love to use some open-source/linux-based mobile solution. In fact, I got myself a Volla Phone, to try out Ubuntu Touch. While UT was kind of okay, the lack of properly working Android apps via anbox was a no-go.

Thats a pitty, really, because I would love to have a good linux-based phone as regular phone. Its a shame not more apps are available, and also better hardware. While I dont want to play games on the phone, I can see that the XA2 I got is really much slower overall than my current iPhone, which I must admit is a 11 pro, so pretty top-notch.

As I understand it, the newer Xperias are not expected to get support for SFOS, right? So with SFOS, we will be bound to use older, sub-par hardware, which is really a shame :frowning:

2 Likes

I don’t use very many Android apps. It’s basically eID, mobile payments, and a bit of Spotify. (And mail tracking, but i should switch over to Paketti). Now that you mention it, Spotify looks like it is in retiree-mode, strange. So i checked the Android settings - and i could turn down the size one step, an now it looks much more reasonable.

Android settings are either accessed through the settings item added by aliendalvik-control, or by accessing app settings for an Android app, launching it’s Android settings, pressing the back button, and reactivating that window. (easy, huh?)

I have installed some security-senistive apps through Aurora with no issues so far, but i can’t vouch for it. Proprietary apps not being available is not something we can really blame Sailfish for though, is it? The publishers need to get their act together.

Supposedly the native app Foil Auth works with Microsoft, but i have no ideas if it is for your purpose.

I think the browser is actually pretty good now, not counting the crashes. And it is bound to get even better in the next release. Alternative native browsers, apart from maybe Angelfish aren’t any better nowadays (IMO). Firefox for Android works very well, if you happen to be frequenting pages that the built-in browser dislikes more than usual.

The Xperia 10 II is the likely new candidate, still midrange, but definitely a step up from the current ones. There is also perceived slowness in that animations are built to be quite slow, and i’d say slower than necessary nowadays. Obviously it is no iPhone, but i have had a Galaxy S9 (since new) for work, and i don’t care for it one bit. It still manges to lag where it hurts the most.

1 Like

By no means am I blaming SFOS. I think its a great OS, with great potential. I am rather blaming out capitalism-driven society which does not exactly power open-source software and the likes :slight_smile:

Actually, the Xperia 10 II looks pretty nice.

1 Like

I’m new too to Sailfish and am confused about how to install .apk apps. I see them in the Transfers section then tap the link and nothing happens. I did change the security settings to allow third part apps (that’s a bit scary!) and nothing. I tried installing the Here WeGo app (.apk) and didn’t thing anything happened and went back to the link and it said it was installed, but no icon…where do I go to open it?

I assume you have the Android runtime installed?
When you say “went back to the link”, i’m getting the impression you mean some webpage, which then cannot know whether it got installed or not, just that it got downloaded.

There was a mention on here just recently about Android apps not showing up, but can’t find it right now.
Could definitely be worth going to #sailfishos on Freenode IRC to get faster answers and a discussion going.

Exactly as attah said.

Noticed same strange behaviour on my test X without Android runtime.
Downloaded apk looks like getting instled but does/can not as not supported without official paid license, Android runtime installed.

In case of Android support installed did you try a reboot after activation/installation of it?

Or take a look here and follow up to this.

I’m trying to “de-Google” and have avoided installing anything from them so have not installed Android Runtime. I read that if I find an app, let’s say for navigation, if I find the .apk link it can be installed on my phone?

I have been using Apk Pure android store to install android apps. The experience has been good so far. By the way, I have very less android apps installed.

Whatsapp
Cricbuzz - App for cricket live scores
MySejahtera - Malaysia local contact tracing app for Covid-19

Are you confusing this woth Google Play Services? In order to run Android apps, you need the Android runtime from Jolla. Obviously by virtue of being based on Android, this comes from Google, but does not contain the bits people usually worry about.

Where did you find this? When I go to settings -> apps -> WhatsApp/Spotify/… -> Android Settings, I dont find any option to set any kind of sizes.