[solved] Xperia X, upgrade to failed

If I try to upgrade via System settings I’ll get the message that the „system cannot check the size oft he upgrade“. The message gets even worse if I try the following in the terminal:

  1. devel-su
  2. ssu release
  3. version –dup
    „This request will break your device. Upgrade not complete.“

There is also OLF’s sfos-upgrade which throws similar messages. Any help appreciated!

Thanks for your advice. Everything is fine. The only message I got while sfos-upgrade is „-Stopping osupdate-check.timer“ and „NO UPDATES FOUND. Try again later.“

NB: Yes, I did post_sfos-upgrade after samegrade and no updates found by the system.

1 Like

Same here. And increasing the root partition size did not solve the problem, as it seems to have done in https://forum.sailfishos.org/t/updating-problem-with-store/6629/3

Just a wild guess, since I always did
pkcon refresh
version -dup
…does this changes anything in your case?

1 Like

I did - nothing changed. So I had to go for a full reset and went thru all the updates via terminal commands. Finally I am on with many quirks.

@oedelmeier Did you mark this as a solution? I don’t think reflashing or factory reset is a proper solution to problems in determining the size of the update.

My ~/.cache/sailfish-osupdateservice/os-info contains lines

codeName=Vanha Rauma
summary=Vanha Ra....van Niftrik
cover= ....

-1 is clearly not a valid size. But what causes this?

Of the apps mentioned in the release notes that might cause problems, I don’t have any. Patchmanager3 is installed, but the patches should not affect updating.

I did in random order few loops of
-ssu release && version --dup
-ssu release && version --dup
-sfos-upgrade (from openrepos)
-pkcon refresh
with no success.
Then I run post_sfos-upgrade, which loosened something and installed 734 packages.

Repeating again version --dup did nothing, zypper dup complained that patterns-sailfish-device-adaptation-f512x-1.3.27-1.5.1.jolla.armv7hl requires ofono-ril-plugin but nothing provides it. I desided to cancel updating this package.
Rebooted to without problems (and run post_sfos-upgrade).

I don’t have sim in this phone, so haven’t tried calling, but everything else seems to work, patchmanager3 included.

1 Like