[SOLVED] Upgrade to removes Android support

BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): XA2


Upgraded the phone from to and after reboot Android support is gone. It is not showing up in the store either as installed or to re-install. Is there another way to activate the support layer?


  1. Upgrade from to with sfos_upgrade
  2. Reboot
  3. Android support not turned on.


Android support active


Android support is gone, not to be seen in settings, not able to start with systemctl on terminal and all Android application don’t show up anymore. Data is there when you become root on the terminal.

1 Like

It is even worse than I thought. Everything related to Android is deleted. All files from my home are gone. Bye back-up of Signal to restore. :cry: :angry:

To get help, you need to provide more information.

Which device are you using, how exactly did you do the update, are you still signed in with your jolla account? What do you mean with “everything android related is deleted”? How did you confirm this? Did you make a backup before updating the device?

to fill in the information, please use the template that was provided with the first post. It helps people, when the first post provides all necessary information

1 Like

You’re right. My emotion got in the way for writing it down properly.

I’m running sailfish on an XA2, did the upgrade through terminal with sfos_upgrade. Using the file browser I can see that .android does not exist any more in my home. In the Jolla Store Android support does not show as item (to be) installed. The back-up of Signal is no longer to be found and in /home/nemo/android_storage.

I made a back-up from the phone, but I’m not convinced the Signal back-up is part of the Sailfish back-up process.

Are you sure the folder is not there anymore (check via terminal) or it is just not showing up, because the filebrowser does not have the permission to see it. The enforcement of sailjail in 4.4 causes this for the filebrowser from ichtyosaurus.

Are you signed in with your jolla account?

Yes I’m signed into my Jolla account.

Aha! I can see my back-up folder under android_storage through terminal. (pfew). I did not think about checking through terminal.

How do I re-activate Android support?

Okay, nice. Unfortunatley I wont be of any help for that question. But I think you make it easier for everyone if you update the first post to conatin all necessary information. You can use the template that is provided, when you open a bug report

hmm, I thought is a stop release, eg. you have to first update to before updating to 4.4 … ? release notes for said it’s to prevent problems with the 4.4 upgrade…

Yes I was upgraded to the .15 both the .12 and .15 were stop releases.

This is from old version of File Browser! If you install the latest version from Storeman/OpenRepos it will work and show all files and directories again.

edit: version 2.5.0 from march 30, 2022

First things first, I assume your Jolla account is logged in on the phone?

This happened to me last year on my last device (10 plus) on a previous update, I think 4.1.
I had a similar issue where I couldn’t install Android App Support, but luckily there was another point release a few days later and it upgraded one of the required packages for AAS, and then I was able to reinstall it.

I would suggest using ssh from a computer to look at the /var/log/zypp/history file (eg using nano or vi).

Scroll down to the end and then look at the part where the update takes place (it will be apparent as the timestamps are very similar and there will a massive number of updates happening) and see if there are any errors from an install with alien or apkd in the title.

Yes I’m logged in into my Jolla account.

I have checked the log, but not found much interesting or clear errors that may be helpful. In the Jolla store the android support is also not showing up there.

As you have used sfos-upgrade, you may also check its log at /var/log/systemupdate_….log.txt.

The upgrade process did remove:

Remove (5 packages)

  • aliendalvik-configs;10.0.57-1.4.1.jolla;armv7hl;installed
  • aliendalvik;1.1.0-1.2.1.jolla;armv7hl;installed
  • apkd8-android-settings;;armv7hl;installed
  • apkd8;;armv7hl;installed

But it did re-install them.

Which service should be running for Android support?

When I check systemctl it appears that the sailjaild is not running and the droid.service as well. Is droid.service the service for Android and does that depend on sailjaild?

Does nobody have an idea of what I can do/ try?

Seen from a practical point of view, my idea is, save your data, reflash and reinstall everything. So, in 1 or 1 and a half hour you will have your device back working fine with the new system. With some attempts to repair the old systen, you will never know what comes next.

edit: prefer installing apps from Chum or Storeman, they are more up to date. Jolla Store apps may be outdated and may not work with a fresh updated system.

Well that was a waste of my time re-flashing the device. Nothing changed with regards to Android support. Still not available and Jolla Support is not helping me much either. Perhaps this is the time for me to say our goodbyes.

Oh no no!!! Don’t give up! Please try the following: Delete the Jolla account in your phone, and then reboot the device, and then install the Jolla account new with your credentials. Then check again if Android support is available for download and installation in the Jolla store.

What would that do if I just flashed the device fresh?