[solved] Everything almost broken after upgrade to rauma :(

yesterday i wanted to upgrade to the newest version (Rauma) but there was a message to remove alien dalvik and onther app first.
so i did but i got a message the script had an error that it couldnt stop some proces.
the packages where gone though.
so first did a restart and it al seemded fine so then i proceded to start the update.

after reboot it started updating and the progress bar came to 100% but then it said:
upgrade unsuccesful.

after restart i checked the version and it says: Rauma

however most things are broken:
cant connect to the cellular network, cant start wifi, cant start android subsystem.
even the flashlight doesnt work.

so basically my phone is useless now.

how is this possible and is this fixable somehow?

How: I don’t know.
Fixable: Without internet connection it is hard to restore. I would recommend making screenshots of app launcher, and apps with complicated settings, then doing some backups to SD and copying as much as possible to your PC using USB, and reflash.


You can still try to use this before attempting to reflash. This does require though that you have enough Linux knowledge to bring up network and DNS before running it. Generally, this script delivers a safer update experience.

Many of us have been through this! Basically, the upgrade process is not completed at all because of a glitch in the removal of aliendalvik-control. I had used “sudo pckon remove aliendalvik-control”, but it did not remove it properly. Someone advised me to instead using “sudo zypper remove aliendalvik-control” and then press ‘i’ for ignoring the warning. After that I did “sudo version --dup”. This did not upgrade the system, rather it downgraded my system to But I guess that is a good thing to get back a clean slate. Finally, I just used the graphical updater once more and all my problems seems to be gone, except that my sdcard is not recognized under Settings->Storage.
You might try this, but do so at your own risk! :wink:

therer is no sudo on sailfish, are we talking about the same thing?

ok, works with devel-su but it tries to download stuff which is impossible with no network

That’s a predicament, all right. I noticed that after the downgrade, I had no network either. I rebooted and got it back. You might want to try a reboot.

no, not even the flashlight works.

no internet, no wifi.

is there a way to do a downgrade by copying the upgrade image to the phone with an usb cable or something??

No, there isn’t. There isn’t even a “upgrade image”, it’s all packages. There is a rescue mode you can boot into over USB, but since USB connection seems to work for you, this probably won’t help you. If you don’t want to backup data & reflash, trying to get network again, installing & running sfos-upgrade is one of the few things you can try in advance. If you don’t have little knowledge about linux command line I would go straight to backup & reflash, otherwise maybe helpful to know that Sailfish uses Connman for networking.

It looks like you have the same problem described here. Have a look on this post and this one if you’re using a X10 II. They are all from the same topic.

fixed it!

thx for the links.

so basically if you run into this while upgradig to rauma and lost networking after reboot do:

zypper remove aliendalvik-control # this was a problem according to update 
ln -s /usr/lib/libip4tc.so.2.0.0 /usr/lib/libip4tc.so.0 # restores networking
systemctl start connman # start networking
ssu re
version --dup  

You can install sudo in terminal if you want.

Can you mark your topic as closed and hint to this post, please?

1 Like

yes, please do, so that people with the same issue find it easily, as well as how to fix it! :slight_smile: