SFOS 4.5 feedback thread

I have noticed that after upgrading, my X10III is not connecting and not even able to find the 2.4Ghz SSID operated by my router. The network is there, as I am connected with my laptop to it right now.

The phone can, however, still use the SSID operating on the 5Ghz band.

Yes, I’ve tried it, but I prefer the standard Gallery app, because of the following reasons:

  • it’s much snappier in it’s reaction
  • the categories have a photo image, not just text and a number
  • the cover has a nice selection of photos showing when ‘minimized’ on the homescreen
  • it has the timeline build in (touch and drag) and is a lot faster when scrolling in time while still seeing the photos
  • categorie for Nextcloud photos (using the system account setup) is natively included

It’s just missing the album/folder creation support which hopefully Jolla will build in the Gallery app.

A seperate app for photo editing I would understand, just not for a standard gallery app.

Regarding backups, the backup settings are already in the system settings app. An end user should not have to worry about a different app for their photo backup to the cloud. It currently backs up photos to the memory card, just not to the cloud.

1 Like

XPeria 10 II here , bt works as expected (German locale)

There are plenty of photo editing apps in Storeman/OpenRepos. And I agree, editing functions in the standard Gallery app isn’t necessary. For me, it’s only a quick-‘n’-easy viewer, and for this, it works fine.

1 Like

On my XA2 the bluetooth does not turn on after a reboot. As workaround, it seems to work (at least with Amazfish) after a restart of bluetooth subsystem using the setttings/utilities.


Have a look at this bug report:

Good to know that restarting from Utilities works. I had forgotten that this had been included and went by command line.

Also see Why aren't more core table stakes apps open sourced to speed up progress?


Unless tracker crashed, which is the case on my X, almost all the time… Then you just don’t have any images listed. You can’t watch, share, nothing…

Hotspot still doesn’t work on 10 III, SIM is Telekom DE.
(Can just tell that for SIM Slot 1 as I need the SD Card…)

Have you checked the password set for your Hotspot? Mine seems to have been changed from what I had set before to a random set of characters.

Thanks. (20 characters)

What should that have to do with a not working connection? The problem on 10 III for a notable number of users is still that that phone doesn’t share it’s internet connection. The password in Hotspot settings is just the password for other devices to log into that Hotspot.
And in my case another device was able to connect to the Hotspot as in the previous SFOS version, but the system still doesn’t share the connection. So the decive that that should use the Hotspot still says “connected, no Internet connection”.

Thanks for clarifying that although connected to the hotspot, you cannot access the internet via the connection. Not something I have experienced with a hotspot on X10iii with 4.5.


1 Like

So it’s not the hotspot itself but the routing from hotspot client to cellular data connection? This must be clarified to find the bug.

Can you ssh into the phone from hotspot client computer, despite you have no internet connection?

1 Like

Oh, what have started here… I just wanted to say in one sentence that the biggest problem from the previous version still exists. Next time I’ll do better.

SSH into the phone is something I never tried, especially as I just tried the connection with other phones/tablets without a terminal app installed. Could try this from PC, sure.

Did a factory reset, going to be waiting on a stable 4.5 release, at least with my 10 iii

Internet was acting weird on 4.5

If you make a factory reset, you get back to the version with what you have flashed the phone long ago. All later updates will be lost. But as long as SFOS 4.5 isn’t yet rolled out officially but only EA, you can download the flash image from the Jolla shop homepage and reflash with it.

If you do so and later make a ‘factory reset’ you come back to then and not to older version with what the phone was flashed initially.

Jolla C. Great update (GUI) no problem. I uninstalled CHUM because off the info and disabled all Storeman repros and deleted patches. So far i have discovered. → Gpoder and 9gag has no download shortcut anymore. CHUM installer from Storeman installs, but no icon.I tried to use pkcon to install but no luck.
Thanks to JOLLA for this great update. :relaxed:
PS. My Jolla (1) has bad battery but my wife use it more than her androide phone☺ . She plays Wordl and Aenigma.
I bought an Xperia 10 iv last autumn and hope Jolla or the community could make a port. It’s sleeping in the shovel.:relaxed:

Thanks, found week numbers :slight_smile:

I made a test screen shot:

Here are overlapping whole day events and for curiosity overlapping hour events also.

If there are many whole day events, the whole day event part of screen becomes scrollable (swipe up and down). It shows vertically 2 and a half whole day events as maximum.
That half visible one hints user to scroll/swipe to see it.

If there are no whole day events visible on current week view, then that part of screen rolls away (animated) revealing more space for hour events.
And similarly rolls down when user swipes to a week that has whole day event(s).