[SDK 3.2.10] App deployment failed (using RPM or rsync)

Hi,

I have a fresh install of the Application SDK running on Debian Sid, with the Docker build system.

I tried to build the Examples applications provided in the SDK, and the deployment failed, either if I tried to deploy as RPM or copying binaries with rsync.

Here is the Compile Output :

11:13:15: Running steps for project componentgallery...
11:13:15: Test Device Connection: Testing connection to "Xperia 10 - Dual SIM (ARM)"...
11:13:15: Deploying RPM package...
11:13:15: Starting: "/home/nicolas/.config/SailfishSDK/libsfdk/build-target-tools/sailfish-os-build-engine/SailfishOS-3.3.0.16-armv7hl/deploy" --sdk
+ /home/nicolas/SailfishOS/libexec/qtcreator/../../bin/sfdk -c target=SailfishOS-3.3.0.16-armv7hl -c 'device=Xperia 10 - Dual SIM (ARM)' deploy --sdk
[W] QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-nicolas'
[W] QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-nicolas'
No journal files were found.
Building target platforms: armv7hl-meego-linux
Building for target armv7hl-meego-linux
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.fQywDQ
+ umask 022
+ cd /home/nicolas/SailfishOS/projets/build-componentgallery-SailfishOS_3_3_0_16_armv7hl_in_sailfish_os_build_engine-Debug
+ '[' /home/deploy/installroot '!=' / ']'
+ rm -rf /home/deploy/installroot
++ dirname /home/deploy/installroot
+ mkdir -p /home/deploy
+ mkdir /home/deploy/installroot
+ LANG=C
+ export LANG
+ unset DISPLAY
+ rm -rf /home/deploy/installroot
+ export QT_SELECT=5
+ QT_SELECT=5
+ make install INSTALL_ROOT=/home/deploy/installroot
cp -f -R /home/nicolas/SailfishOS/projets/componentgallery/qml /home/deploy/installroot/usr/share/componentgallery/
install -m 755 -p componentgallery /home/deploy/installroot/usr/bin/componentgallery
install -m 644 -p /home/nicolas/SailfishOS/projets/componentgallery/componentgallery.desktop /home/deploy/installroot/usr/share/applications/
+ desktop-file-install --delete-original --dir /home/deploy/installroot/usr/share/applications /home/deploy/installroot/usr/share/applications/componentgallery.desktop
+ /usr/lib/rpm/find-debuginfo.sh -j4 --strict-build-id --build-id-seed 0.4-1 --unique-debug-suffix -0.4-1.arm --unique-debug-src-base componentgallery-0.4-1.arm -S debugsourcefiles.list /home/nicolas/SailfishOS/projets/build-componentgallery-SailfishOS_3_3_0_16_armv7hl_in_sailfish_os_build_engine-Debug/
extracting debug info from /home/deploy/installroot/usr/bin/componentgallery
1 blocks
+ /usr/lib/rpm/check-buildroot
+ /usr/lib/rpm/meego/brp-compress
+ /usr/lib/rpm/meego/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/meego/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python
+ /usr/lib/rpm/meego/brp-python-hardlink
+ /usr/lib/rpm/meego/find-docs.sh /home/deploy/installroot
+ /usr/lib/rpm/meego/brp-java-repack-jars
Processing files: componentgallery-0.4-1.armv7hl
Provides: application() application(componentgallery.desktop) componentgallery = 0.4-1 componentgallery(armv7hl-32) = 0.4-1
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: libQt5Qml.so.5 libQt5Qml.so.5(Qt_5) libc.so.6 libc.so.6(GLIBC_2.4) libgcc_s.so.1 libgcc_s.so.1(GCC_3.5) libsailfishapp.so.1
Processing files: componentgallery-debuginfo-0.4-1.armv7hl
Provides: componentgallery-debuginfo = 0.4-1 componentgallery-debuginfo(armv7hl-32) = 0.4-1 debuginfo(build-id) = e5c1d2adb4bc980802d0bab0a92286a79a6bd148
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Recommends: componentgallery-debugsource(armv7hl-32) = 0.4-1
Processing files: componentgallery-debugsource-0.4-1.armv7hl
Provides: componentgallery-debugsource = 0.4-1 componentgallery-debugsource(armv7hl-32) = 0.4-1
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Checking for unpackaged file(s): /usr/lib/rpm/check-files /home/deploy/installroot
Wrote: /home/nicolas/SailfishOS/projets/build-componentgallery-SailfishOS_3_3_0_16_armv7hl_in_sailfish_os_build_engine-Debug/RPMS/componentgallery-0.4-1.armv7hl.rpm
Wrote: /home/nicolas/SailfishOS/projets/build-componentgallery-SailfishOS_3_3_0_16_armv7hl_in_sailfish_os_build_engine-Debug/RPMS/componentgallery-debuginfo-0.4-1.armv7hl.rpm
Wrote: /home/nicolas/SailfishOS/projets/build-componentgallery-SailfishOS_3_3_0_16_armv7hl_in_sailfish_os_build_engine-Debug/RPMS/componentgallery-debugsource-0.4-1.armv7hl.rpm
11:13:21: The process "/home/nicolas/.config/SailfishSDK/libsfdk/build-target-tools/sailfish-os-build-engine/SailfishOS-3.3.0.16-armv7hl/deploy" exited with code 1.
Error while building/deploying project componentgallery (kit: SailfishOS-3.3.0.16-armv7hl (in sailfish-os-build-engine))
The kit SailfishOS-3.3.0.16-armv7hl (in sailfish-os-build-engine) has configuration issues which might be the root cause for this problem.
When executing step "RPM"
11:13:21: Elapsed time: 00:06.

I was trying to deploy on a Xperia10 running 3.3.0.16, and the connection test in the “Manage Kits > Devices” was successful. I was using my usual SSH RSA key, which was installed on the phone and had no problem connecting to the phone otherwise. I had to use the “Specific key” option to use it, because it was failing to use it automatically using my active ssh-agent.

Thanks to Vige on IRC, I managed to make the deployment work by creating a new SSH key (
“Create New…”) and installing it in the phone.

I suppose the SDK doesn’t like using an SSH key protected by a password, or can’t use the active ssh-agent running in my session (which has the unlocked private key loaded), as the key generated by the SDK is not password protected.

3 Likes

Current SDK (3.2.10) indeed has issues with ssh keys and passwords. It’s actually even slightly worse than what @N-Mi described above - if any of the default keys requires password, then none of them works. The workaround of using a specific key works anyway.

2 Likes

This bug is very annoying. I got it fixed with Specific keys as follows in SDK. It seems that this operation has to be made sometimes again to be able to proceed coding. I have Ubuntu 18.04.5 LTS in use.

  1. Tools–>Options–>Add
  2. Select Sailfish OS Device, Start Wizard
  3. Hostname 172.28.172.1, Next
  4. Create New Key Pair
  5. Generate And Save Key Pair (if created before, remove ~/.ssh/qtc_id and ~/.ssh/qtc_id.pub from file system)
  6. Deploy Public Key, Close
  7. Next, Next, Next, Finish, Close, OK