SailfisOS on a Sony Xperia™ 10

Just purchased an Xperia™ 10, the issue is it came with android 10, with no way currently tp revert back to 9.*

What makes android 10 not recommended for sailfishOS?

Thanks

Missing adaptation for Android 10 in the libhybris package that uses Android drivers to link to GNU/Linux ones.

2 Likes

Can’t you use Xperia Flash Tool to revert to Android 9?

been attempting to downgrade, BUT.

But when I went to purchase the license for the Xperia 10, says I am unable to do that since I live in the US.

Oh well :frowning:

Yup Sailfish X seems to be available only in Europe.

just use vpn, Luke.
:slight_smile:

1 Like

@RodMyers
You don’t mention whether your Xperia 10 is Single or Dual Sim, which might affect choice of software used to downgrade from Android 10 to Android 9 as posted here:https://forum.sailfishos.org/t/program-emma-doesnt-work/548/5

Single SIM.

Success. it took a while, but I have sailfishOS installed and being setup now

10 Likes

I was in the same situation with my Xperia 10

I could not use FlashTool to downgrade Android 10 to 9, it gave me an error. The official service tool called Emma worked just fine, it found the firmware, this tutorial helps a lot:

https://jolla.zendesk.com/hc/en-us/articles/115004283713-Reverting-Xperia-device-to-Android-OS-and-reinstalling-Sailfish-OS

1 Like

Hi! I have new Xperia 10 i4113 with Sailfish_OS-Jolla-3.4.0.24.
But it works only 1 day with fully charged battery.
I have tried using the program Lighthouse from OpenRepos.
Is it normal to have 645-650 processes?

The Xperia 10 has a very small battery life and sadly not everything is 100% optimized driver wise on this hardware. So yeah 1 day battery life is pretty much what you get.

1 Like

I have got Sony I3113 and now use SFOS (trial version). About 620 processes are running after boot. I think it’s abnormal at all. For example, typical number of processes for Jolla C with AD is 330 (plus-minus), Jolla One - about 300.
For decrease battery consumption you can try to change governor (interactive > ondemand), limit max cpus frequencies. But it won’t have much effect, cause 8 cpus are always on and min cpus frequencies are too high (cores 1-4 787 and cores 5-8 614MHz).
I totally agree with @leszek, drivers are not optimized.
@vasimov relax and have fun :slight_smile:

P.S.: file “init.ganges.pwr.rc” is situated “/vendor/etc/init/”

1 Like

My dual sim X 10 allows me to set 1 sim to 4g, then the other works in 2G only.
Is that how it’s supposed to be?
I remember this was a hw limitation of Xperia X (even on android), but is it on X 10?

No, it is not. Both SIM slots are supposed to and can operate in the 4G network.

1 Like

Does sim order matter? My 1st sim is in 4G, 2nd set to "prefer 3G’, yet SimScout (which btw, stopped showing LAC and CellId some SFOS update ago) shows “gsm” for 2nd sim.
What’s the proper way to check?

Maybe there is no 3G coverage anymore?
Disable first SIM and see.
Set second SIM to 4G and see
Set it to 3G/2G and then see again.
Put both SIM to 3G and so on…

1 Like

well, that’s interesting.
No matter what I do (disable sim1, change it to 2g or 3g or 4g), sim2 stays on 2G.
Mind, that default mobile internet is set to sim1 here.

But!
If I change default internet to sim2, suddenly sim1 goes to 2G and sim2 now gets 3g or 4g (what I chose).

So basically, for me at least, there’s seems like no way to have both sims on 3g/4g.
At least one of them (which is not selected for Default Mobile Internet) will stay on 2G no matter what.

Could somebody please check this behaviour?

I have X10 Dual SIM and both SIMs connected to 4G at the same time (and had most time in the past). Phone hardware surely provides this, but maybe bug of the new SFOS version?

I’m still on 3.4.

btw, how do you check that both sims are on 4G?

Do you have your mobile connection set to prefer 3G or prefer 4G. At least in Finnish Elisa network this makes a huge difference: with 3G battery lasts twice as long.