Sailfish X on Sony Xperia 10 II DualSIM - Status Story and more

I was buying a Sony Xperia 10II after my Jolla Phone 1 is not longer supported.
So I was installing SailfishOS X (free version) on the phone and played around for 2 days without limits. Of course there have beena lot of problems in the 1st try.
After 2 days I installed a fresh and clean SailfischOS X again and started to configure my new phone with my preferred settings. (I didn’t restored a backup because during my tests before I got a lot of problems.)
Current status (22.05.2021):
SIM - working / 1 installed
SD - working / 128GB
Charging - working / energy usage OK (2 days - ~80%)
Ambiente - working
Fingerprint - working
NFC - no app is using it
Accounts - Jolla, Nextcloud, Google, CalDAV and CardDAV, 4x Email - working
Accounts - XMPP - not working (loosing password)
Mail - working
Calendar - working
Message board - working
Media player - working
Gallery - has a problem that in the picture mode you see partly picture parts left or right
Stores - working with Jolla, OpenRepository (Storeman)
QR - Camera app is reading the information but support only links otherwise copy

Applications

  • not all are available for the new architecture and

  • not all are working well (but most of them)

  • PureMaps - working but no audio engine is available for sound

  • CodeReader - working

  • QR Clip - is missing

  • SailOTP - working

  • ownKeepass - working

  • Pass Viewer - is missing

  • Tidings - is missing

  • MeeCast - in not working

  • Anchor - is missing

  • Recorder - is missing

  • slp - working

  • ISO Drive - is missing

  • Night Silence - is missing

  • Call recorder - is missing

  • Sea Print - working

  • Android - is missing

Handling
Device

  • speed - very fast
  • device accessabillity - very slippy
  • is to long (1,5cm less would be better) so the handling with 1 Hand is unpossible!!!
  • double-tab is not working (or I have done something wrong)
  • low-power modus - working but have a to short time to show date and time (0,5 sec.)

Usabillity - terrible
Right now it is possible to use a lot of actions with one hand but the usage-killer is the menu with the applications. Right now all apps are locateted at the top of the screen.
Solution - I suggest to have a configurtion switch (Settings/Ambiente/Display) to choose between the apps icons start reference are located at the top of the screen or related to the bottom of the screen.
This is an advantege for 1-hand usage and also for handicaped accesebility (and I don’t have to install a lot of scrap apps to fill up the top area of the screen.)

Also I’m missing in the most new apps the possibility to use a shift-menu (top and/or buttom) because the developers are simply using buttons (e.g. start/stop) instead of a menu. (Is there a possibillity to have a config switch in the settings - Buttons/Menu/both.) That is negative for handicaped accesebility … as far as i know it is in the law (in Germany) defined that Software has to be considered for handicaped accesebility. (I know the reality is different but why not include that point … that’s a selling argument.)

So far till today - All-in-All I’m satisfier for a Software test version. For the release I’ awaiting more.
I’ll buy the OS for sure because it serves my requiremnets more that other operating systems.

2 Likes

Thanks for this short review.

One question as for Android support: is there a reflash of the whole system neccessary when the “not EA” version is available, or will this work by just updating?

As I understand it is a simple upgrade where you have to enter the lisence key!
I was never doing it before so it will also be a surprice for me.
May a more expierenced user will tell us more about in the next days… :slight_smile:

You should basically just buy the licence and log on to the Jolla account you bought the licence on. It might require device reboot as well, but other than that it should be simple. Android support etc. should appear on Jolla store as any other application.

That sounds very simple)
Thank you for the quick answer.

The easy fix is just installing more crap :slight_smile:

I love this solution. I hadn’t quite figured out the usability issue comment before I read this, and then it clicked: the device is so physically long compared to a human thumb that some icons can’t be reached without sliding the device around in the hand. OTOH, the swipe down actions would still be out of reach. :frowning:

I also may have done something wrong, but even running Android I can’t find a way to enable this feature if it exists.

Very well, my Xperia 10 ii arrived an i am ready to install and wanted to try the EA version, but I do not see the download. I’ve logged in with my account and see the downloads for the XA2, 10 (mark1), …
am I missing something, or did Jolla remove it?

@gaelic
You have enabled EA in your Jolla account as otherwise it won’t show as available? Downloaded a couple of days ago but haven’t been back to check whether pulled from server temporarily.

did it yesterday, the location is shop.jolla.com and select Sailfish X Free for supported devices, on the page that opens you’ll find the xperia 10 II download at the bottom…

I agree on the app layout. For an OS that at least attempts to make one-handed use more feasible, this is a very strange omission and has kind of been a problem since Jolla 1. Even if apps appeared with a smooth scroll motion (stopping the scroll where you lift off), that would allow you to position them to your liking. Not ideal but better than the current setup. Or perhaps half-screen scrolls at a time?

Has anyone tested the GPS?

I think this can be easily solved by adding some scrollable blank space to the top and the bottom of the application roster, and then making it scrolling instead of paging. Then you can place any application near your thumb in short time. I don’t understand at all why the application roster was paging from day one.

1 Like

Yes, me! :wink:

Conditions/Settings: GPS only
Surrounding area: rural, inhouse

After switching location (Standort) on and starting GPSinfo, immediately 13 sat’s in sight but 0 in use.
After abt 1 minute: 26 sat’s in sight and 3 in use, and correct position is displayed, but only with 100m accuracy.
After 3-4 minutes: 36 sat’s in sight and 7 in use, correct and stable position display and accuracy is 8 meters.

edit: I’m so sorry, earlier I did not read that this thread is for the X10 II phone!
My report is from an Xperia 10 Single SIM. But I can confirm that GPS works better now since 4.1.0.23.

just did, basic installation (no mls package from store), first lock in under 40s., after that, next fix within 5s. first satellite signal appears in 2s…
(it’s faster then the xperia 10 which takes 10s. for second satellite fix)

So download worked in the end. I had (have) activated licenses for X and X10, and had to enable the free version separately …

Do you think that Android App Support will be released this week?

Sailfish_OS-Jolla-4.1.0.24-xqau51-0.0.1.44 Released today with Android App Support 10.0 with Predictive text input to follow in upcoming update: https://shop.jolla.com

3 Likes

I’ve installed it with Android App Support (paid license), but I can’t find the Aptoide icon anywhere. Do I have to access that store through the terminal or something?