Sailfish OS pinephone

I tried to install SFOS on a PinePhone 1.2 (community edition) using this script:

However, this script fails to download (It’s a 404.)

Am I using an outdated version of that script? Or am I going about this all wrong?

Bonus question: I’d like to install straight to the eMMC. Is that aforementioned script suitable for that purpose?

As far as i remember, you can expose the internal emmc via usb and write direct on it instead of a sd-card. Also i had some problems until update via ssu re and version --dup.

There have been problems with the flash-it in recent months…I don’t know if it’s been updated but here’s what you have to change to get it to work: Telegram
You can flash straight to the emmc using jumpdrive or towboot.

While taking a quick glance at that script, at one point it asks whether to write to an SD card. Would I answer “yes” for the eMMC as well, then? After all, jumpdrive offers it like yet another USB drive.

Thank you very much for your speedy reply.

Unfortunately, I do not use Telegram. Thus, would it be possible to post that solution here? After all, others might benefit as well.

Yes, but your data will be lost then like you know! Pinephone is nice to play around with, under normal circumstances you can always recover…

here’s the link:
it’s on the line UBOOT_DOWNLOAD2
ps currently no sound on PP, works on PPP

1 Like

Thanks, defactofactotum! After adjusting the UBOOT_DOWNLOAD2 URL, the installation finished as expected.

However, the phone does not boot. It briefly flashes the “flashlight” on the back (supposedly as intended) and, then, lights up the front LED in that typical slightly pinkish hue. But that’s it. It’ll remain in that state forever.

It tried modifying the “install to SD” and “clean root password” options during installation, alas, with the “install to SD” option the phone would not start at all. The other one did not seem to matter.

Have our friends on Telegram verified that the Pinephone installation will boot with the u-boot-sunxi-with-spl-pinebook.bin file? Has anyone else installed directly to eMMC recently (using Jumpdrive)?

I told the dev and he’s going to reflash and check

1 Like

I was kindly referred here by acrux from the Pine64 PinePhonePro Sailfish forum.

I’ve downloaded the current (as of today) scrip from;

Selected No. 5 PinePhonePro Image to my SD. Told the script to install to the SD and Yes to the clear root option.
Script appears to have run and loaded the auto image to my SD card Ok however when I select the boot to SD Card option on my PhinePhonePro I just get the light flash then nothing else ?

No Sailfish boot screen images.Nothing :frowning: I’m not quite understanding the “UBOOT_DOWNLOAD2 URL” reference above and which .bin I should be downloading ? Shouldn’t the script be downloading the correct one for me automatically ?

Bit of a scripting “Gumby” so I might be missing the obvious ? Am I not doing this correctly ?

Just wanting to get a PInePhonePro Bootable Current Sailfish SD Card Image up and running to test with a view to ultimately installing it to the eMMC down the track for Guinea Pigging / Testing :wink:

Again any assistance is gratefully appreciated in advance

documentation is a bit behind…but the current flash-it requires tow-boot, do you have it installed? And there’s a possibility it only works with emmc, failed on my sdcard on PP.
if you’re on telegram the dev is here: Telegram: Join Group Chat

Thanks, Defactofactotum

Alas like Linguist I’m not a Telegram user as well :frowning:

I’ve pretty sure I’ve got tow-boot as my PPP shipped only a couple of weeks ago and I’m able to “Volume Down” boot fine to other SD Card Images like UBPorts and Mobian no problems. SD boot images running very well and surprisingly fast / responsive on the distros above !

I might have missed it but I didn’t notice an option to install the image directly to eMMC in the script ?

I’m reading your above post as I should try and attempt a build using directly to eMMC instead of SD card ? Plugging the PPP into my build linux pc and tow-booting “volume up” readable media mode ? I’m just not clear how I tell to build to the PPP via USB directly connected to my build PC ? I feel I’m missing something here ?

I’ve seen the question asked online without a response before. I’m wondering the technical reason why we can’t just download a zipped.img file similar to the way it’s done in UBports and Mobian for dd’ing straight to an SD card or eMMC partitions as required ? Is it a tow-boot / boot partitions issue with Sailfish OS or a building issue ? Why on Pine ?

Just for the record I’ve 2 x full blown Sailfish OS Licences already in use and I’ve been happily using them for several years on my Old Sony Xperia X and XA2.

I’m happy to Guinea Pig / Gumby install test Sailfish OS to PPP as well as draft and update any necessary install Doco for publishing if that helps anyone ?

Just let me know here.

Thanks :slight_smile:

Ok so I’ve gone back to the install doco @

Noting step 3 ;
“A list of block devices is displayed and the user is asked to enter the installation device
This will typically be /dev/sdX for the EMMC or /dev/mmcblkX for an SD card”
^Missed that :roll_eyes:^
Thus noting the ability to install to the dev/sdX option for directly to eMMC.
After running the script and selecting option 5 for the PhinePhonePro
Alas I’m now getting the dreaded :wink:
“UBoot image download failed. Aborting.”
Which I was suffering prior to my posts here when trying to initially to build an SD Card :frowning:
^is this a script or image download problem once again ?^

Alternatively I also notice the script has a -c “Custom” option ?
“Install from custom dir. Just put you rootfs.tar.bz2 and u-boot-sunxi-with-spl.bin into dir and system will istalled from it”

Is it possible to get a link to the correct PinePhonePro rootfs.tar.bz2 and u-boot-sunxi-with-spl.bin files posted here if there is a download fault ?

An assistance is greatly appreciated in advance once again :slight_smile:

yes, to flash to emmc use tow-boot with vol up to expose file system, should be blue led.
The option to write an image is by typing raw instead of /dev/sdX but I’m not sure if it’s working at the moment, it was broken for a long time. Make sure the flash-it is the latest from GitHub - sailfish-on-dontbeevil/flash-it: Flasher script to flash Sailfish OS on a SD card for PinePhone/PineTab/devkit
It changed about 2 days ago. It’s been tested with sdcards on PP and PPP. You need to update immediately to get sound working: zypper ref and zypper dup
A faster way to flash is via another distro on sdcard, just put the flash-it script somewhere and run the command. I use danctnix alarm, you need to install wget and jq first but that’s quick to do. Mobian would probably work fine.

“The option to write an image is by typing raw instead of /dev/sdX”

Are we talking about when the script asks
Device node (dev/sdx):
I should just type in ?
He asks after telling the just re downloaded latest script to flash to /dev/sdb in my case :wink:

yes, should make a 4GB .img in the flash-it folder

Great stuff.

  1. I’ve updated to the latest script via the link above
  2. Connect the PinePhonePro via USB to my Linux Build PC
  3. “Volume Up” booted the phone to readable media mode
  4. Run
  5. Selected Option “5” for PhinePhonePro flash
  6. Selected Device node (dev/sdx): /dev/sdb ← in my case
  7. Are you Installing to an SD Card? : n
  8. Clear Root Password?: yes
  9. Flashing /dev/sdb OK!
  10. Rebooted PinePhonePro and ran initial Sailfish Setups and booted into Sailfish on the eMMC

Woot !

Thanks again Defactofactotum for all the help :partying_face:

Doh forgot about resetting the devel-su root password in SailfishOS “Developer Menu” !

note the camera has stopped working, the wifi disconnects during sleep and needs to be retoggled off and back on…and the display dies erratically, only remedy is long press on power and reboot…so not quite for daily use

Well I had some trouble running the zypper ref and zypper dup commands. All seemed to go well but it continually crashed out when I went through the Sailfish OS initial Setup and onto the desktop forced by zypper updates. Top Pull down menu would work it appears but nothing else. Loading Circle would spin endlessly with no desktop loading. Also WiFi would not detect (sleep issue ?)

So as per the extensive Sailfish OS Doco ;

Under “Update Software” just ran a devel-su and then a
version --dup

That seemed much better.
WiFi bombed out still (Due to the sleep issue I expect)
Booted Ok though back to the desktop this time
^after some time / be patient throughout re-Inital Boot / Skipped Tutorial by closing Tutorial WIndow^
Turned WiFi on and off and it reconnected fine.
Seems I now have sound and call’s (somewhat !).
As per above posts no camera
Regular screen crashes still but comes back Ok without reboot currently :crossed_fingers:

Gone back to a boot SD Card build while I continue to happily play with Sailfish OS on PinePhonePro

Oh and thanks of course to Piggz for all his and anyone I’ve missed’s Porting / Dev hard work !

Totally Awesome to be able to tinker with Sailfish on PinePhonePro

Great stuff all