Sailfish OS 4.0.1.45 Signal Messenger voice message is consumed and sounds robotic

REPRODUCIBILITY (% or how often):
BUILD ID = OS VERSION (Settings > 4.0.1.45
HARDWARE XA2, XA2 Plus
UI LANGUAGE:
REGRESSION: (compared to previous public release: Yes, No, ?):

DESCRIPTION:

Signal Messenger voice message is consumed and sounds robotic

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. Open Signal Messenger and send a voice Message to a friend.
  2. Listen to the voice message.
  3. I was able to reproduce it with the XA2 dual Sim and XA2 Plus.

EXPECTED RESULT:

no solution yet

ACTUAL RESULT:

ADDITIONAL INFORMATION:

4 Likes

same issue! xa2, dual sim. 4.0.1.45 , Signal 5.3.7.1!

Can confirm this for Signal and Viber too (probably other Andoid apps as well)

The same troubles here on Xperia 10 Dual SIM. Signal and Threema voice messages are like an alien robotic :slight_smile:

I can confirm this for Xperia XA2 Ultra Single Sim after updating to 4.0.1.48 as well: Using threema only, but the behaviour is exactly as described. I can add, that speed of message seems to be reduced exactly to 50%, meaning, a 5 second message will be 10 seconds in duration, once sent or processed in any way necessary by the android app.
As a result, the sound shows serious distortion effects which are - on the contrary to guitar music of any kind - heavily annoying for person involved. This makes audio recording via android unusable.

Same here on XA2, anyone with a solution yet? I am using v16 vendor image, is it the same on v17B?

same here with facebooks messenger since update to 4.0.1.48 yesterday

Update: Just replaced v16 with v17B Sony vendor image and tested android voice recording in messengers. This bug unfortunately remains.

Luckily I havent update to Koli yet, and this isuue is not gonna help me to give it a try to the download. Cause I use kind of like a lot the audio message in Signal app. Hope I could do that is whisperfish really soon. Please , if someone there could fix this problem will be a great help. thanks

i can confirm for all android apps i am using (threema, signal, android autio recorder)

1 Like

I can confirm this! XA2 4.0.1.48 with threema 4.5

must be a general Adroid App issue…

1 Like

I can confirm it too in my Xa2 with 4.0.1.48.

1 Like

Seems that none cares about this issue??!!

I also get robotic sound on video calls on both Whatsapp and Facebook Messenger - just gave up trying to talk to my daughter. Obviously both Android apps - on SF 4.0.1.8 on XA2.

The same for me, on XA2 plus dual-sim, SFOS 4.0.1.48.
Haven’t used voice messages in Signal before, so I can’t confirm if it’s a regression.

The voice sounds like it’s slowed down a bit and chirpy, it seems to be a sample/bit rate mismatch between SFOS audio codec and Android codec.