Run mobile Gnome/KDE apps?

I’m looking around a bit at what apps are available for SFOS and it seems there are a few cases where apps for other mobile linux distros seem more complete. For example Whisperfish has severely limiting known issues that Axolotl doesn’t appear to have. And for example “Bitwarden Manager (alpha)” is basically unsuitable for use, while Warden seems quite alright.

Is it possible to run mobile linux apps from other distros on SFOS? I would expect yes since AFAIK they are basically just Gnome/KDE apps that use Wayland which… if SFOS is just a linux distro, I can’t see why it wouldn’t work?

Looking around, I can find some libraries that have been compiled for SFOS, but so far the only GUI app that I’ve been able to find that people seem to have built on SFOS is Waydroid. I also can’t really find instructions how to compile random software for SFOS.

There seems to be some RPM infrastructure for building SFOS software, but if it’s just a matter of copying metadata from upstream RPM packages, I’m not sure why I don’t find more apps from other platforms. Is there a catch?


Maybe Sailfish is based on Linux, but it is using a custom Wayland compositor, that lacks a lot of modern protocols. It also lacks necessary libraries.
Someone more knowledgeable will have to respond, but basically what it means is that GUI for a linux app has to be rewritten.
There is also Flatpak for SFOS which makes it possible to use some Plasma Mobile apps.

The person who seems most persistant where non-silica/qt apps is concerned is:

This is just one of his many adventures: Cantata App Testing

1 Like

I see. What I gather from @rinigus Flatpak repo is that it (used to?) work for some Qt apps, but fail for GTK ones due to compositor incompatibilities. From the issues it seems like somewhere in 2021 the build broke and aarch64 support is lacking.

It seems upstream updated to 5.6, would that solve anything?

1 Like

It wouldn’t solve aarch64 support that I didn’t managed to get working. So, on Flatpak end, it looks rather dead. Unless someone wants to start debugging and fixing it.


Would it do anything for running GTK apps? Or that’s really a SFOS issue…

I’m kinda on the fence of installing SFOS on my sony xperia 10 III, and part of that is the ability to run apps from the larger mobile linux ecosystem to cover all my needs.

But if I do, I have some build system battle scars and C++ knowledge to dive into this.

It seems like your conclusion was that SFOS libhydris needs an update, at the time of writing, so, could be SFOS 4.4 resolved this?


As far as I understand running GTK apps won’t work without modofocations with the current compositor, Flatpak or Native.
What you can do though is use harbour-containers from chum which allows you to run a normal distro in an app (e.g. Debian), without almost no performance hit. Not working is GPU acceleration, amd sound is worked on aarch64 for now.
Then you have full desktop app support.

1 Like

If I understand correctly the flatpack-runner runs its own wayland compositor

This is a fork of which has since updated to a newer version of qtwayland, and from what I understand the old version of qtwayland is what is limiting the supported wayland protocols that gtk needs.


Oh, you are right! Sorry about that, I forgot!
I do recommend LXC containers though with harbour-containers, it is probably the easiest way to achieve what you want right now.

1 Like

I tend to try after every SFOS release, but so far, it hasn’t worked. But I haven’t looked deeper recently on what is preventing it to work. As I have spent decent amount of time trying to fix it earlier, I am somewhat reluctant going into that rabbit hole again and prefer to work on some other projects.

As for “larger mobile linux ecosystem” - which ecosystem do you refer to? I would suggest to look into what’s supported under different Linux mobile OSes and decide according to your priorities.

1 Like

I don’t remember from the top of my head if Wayland compositor in Qt 5.6 supports newer protocols. Please try to look it up and document over here, so we would be able to know which version of Qt introduced corresponding compositor changes.

Kde has android builds of some of its software which work quite well

So far I’ve found that the XDG class is new since 5.12, so if that is something that is available om newers SFOS that could maybe work? QWaylandXdgShell Class | Qt Wayland Compositor 5.15.10

Looking at harbour-containers they also use qxcompositor in combination with xwayland to run linux stuff. They do have an ubuntu image, but I’ve not been able to figure out if it can somehow install Ubuntu Touch apps. Similarly there is an Alpine image but not clear if you can somehow install things from PostmarketOS.

Seems like Ubuntu Touch apps are some weird “click” thing so no idea how that works.

1 Like

The option to use ‘normal’ Linux apps/programs would reform the lack-of-apps problem and make a lot of things easier.

@rinigus I understand, and am dreaming of since long time, ‘larger (mobile) Linux ecosystem’ as running ‘normal’ desktop Linux applications on the SFOS phone, as long as they do not demand too much graphic capacity.

Sorry for this amateurish question: is it technically possible to modernize and complete the Wayland GUI to a full featured version by updating a set of libs in the existing Sailfish system by hand to give it full compatibility to standard Linux apps and keep compatibility to the current SFOS at the same time?

@pepijndevos: we are on Qt 5.6 - 5.12 is far away. We are stuck on this version for licensing reasons. As we are told, Jolla’s layers have been looking for solutions but didn’t find anything yet. So, no hopes so far.

click is UT format that they distribute software in. Something also to do with permissions and such. I have a minimal exposure to it due to my maps apps running on UT as well - compilation seems to be done by some JSON, YAML and scripting. Think as of RPM or Flatpak…

@Seven.of.nine: in theory, you don’t need to use Qt for making a compositor, but some other compositor and show it in GLES stack within an app. I was considering to do so, but then it was way easier to do with Qt and, at that time, Gtk apps were not that attractive. I don’t know what’s a state of Gtk mobile apps these days and whether it is worth an effort.

As for lack of the apps - you would have to make sure there is something elsewhere that you are missing. When Flatpak was working, I was mainly using web browser Angelfish. Now, SFOS web browser is improving, so not sure it is needed.