Request: official statement from Jolla about unusable Xperia 10 III devices

I could even try sim2, once I have the time to switch them, but as I explained above whatever the result will not help anybody to get data working on sim1. There is a software issue, which is 100% repeatable and tied to the simultaneous presence of AOSP, the Xperia 10 III and some operators. The only solution is to find what triggers the issue and rewrite the code in order to correct it. If a developer asks to try the second slot because he spots a difference in the code and needs to gather data, it can help him. If I as a user test the slot I cannot use to see if it works, the outcome of the test cannot help me in any way because the slot I can use fails 100% of the times, with the exception the very first time after flashing, or after using a SIM of an operator not showing the issue, independently of the outcome of the test on slot 2.


You still are ‘I know better than any test’ so keep at it, if you want to troubleshoot maybe change your attitude

Are you a broken record? I have been troubleshooting for six months in every way that makes sense, including several reflashes with different Android versions, switching SIMs between providers, checking IP configuration assigned by the provider, changing to IPv4, IPv6 and both, disabling SIMs, re-enabling SIMs, removing SIM pin lock.
Now, before you go on with the same nonsense, suppose I test slot 2 and come out with a result, it works or it does not work. Now, please tell me:

  • If it works, how can this help me have data working on slot 1?
  • If it does not work, how can this help me have data working on slot 1?

Yes, I need the memory card. I won’t buy a device where I cannot use a memory card. If I had known this, I would have purchased a 10 II. Instead, I purchased a 10 III because the OS is known to work with a memory card.


With apologies, there are important topics in this thread, and it’s understandable that they have generated frustration, but I would please urge everyone to stick with the principles of the forum and try to Be Agreeable, Even When You Disagree. I’ve put the topic into slow mode to cool things down a bit.

Please feel free to message me privately if you have concerns about the use of slow mode.


I am testing a 10 III at the moment. I haven’t tried data before, because the SIM (AIS) that is in it doesn’t have a data plan.

Anyway, I am in Australia and inserted a second SIM (Lebara - Vodafone network) with a data plan.

The only problems I have experienced are that sometimes when I turn the data off (old habit from days of hideously expensive data) it sometimes requires a reboot to get the device to reactivate the data connection.

Otherwise, I can report that the data seems to work for me. YMMV

It is not completely random, it has worked for someone in France

I mean if it consistently works for people in SIM slot 2, then that provides an avenue of inquiry into specific code. Eg what is the difference between SIM 1 and SIM 2, are they handled differently in software.

Right now there is one person saying it worked, which could be a fluke. If 30 people say it works, that lends credence.

Seems pretty silly not to take 10 minutes to test something so simple that could lead to the discovery of the issue in software, OR rule out something that has already been suggested to be a path to finding the issue…


If you read the many topics about this issue, you will find that there are also people saying it does not work for them. Which means it works at random and results are useless.
Anyway, given the trolling way it was asked, I will not do it in any case out of principle, unless a developer explicitly asks me to carry out a specific test.

So still not willing to do an easy test that would add a data point and could provide additional info. Got it

1 Like

I say it would add no data point. If anybody can tell me, arguments in hand, which data point it would add, I will do it. Jolla have my ofono blogs, they are really useful to understand, unlike blind SIM switching.
I would have done it if who asked for it would have used better arguments than trolling.

You do you. But again, silly not to even try, let alone acting petulant.

Don’t bother responding I won’t be back and you can keep waiting.

Nobody asked for your intervention in the first place, and it’s not me who is acting petulant. Let alone if I’ll be waiting for your response.
Moreover, it’s not me who should find solutions to bugs. At most I should be the one reporting them. After six months without a glitch of a solution, I and all we others with the same issue have full rights to be annoyed.


The problem with data is usually solved by switching data from SIM1 to SIM2 and then back, at least for me it works.

Simple turning them off and on doesn’t help.

1 Like

This is an interesting matter. Do you have two SIMs in your phone?
My experience is that replacing the SIM in slot 1 with one from another operator and then back with the original one does not work; another user reported that a reflash solves the issue until the first reboot.

Yep, two SIMs. Doesn’t always work on the first try but so far it always worked when done multiple times.

Obviously. Not like I ever claimed it’s a solution. But it might (or it might not) be the thing that helps find the bug because it’s very specific behavior. Next time I prefer less condescending replies if at all possible from your side.

1 Like

I don’t own a 10-iii, but has anyone with a networking background tried reaching out to this small number of problem carriers? They have logs, too. Obviously it would be best for Jolla to do this on the corporate level, and hopefully they have fostered some ties with Finnish carriers…but depending on who/where these problem carriers are, that may not be feasible. As the saying goes, “the worst thing they can say is no”.


Tested the Xperia 10 III in Greece with a COSMOTE SIM card, works just fine.

Also mine works fine with Iliad in Italy. But it won’t with Vodafone. Same issue: when it does not work, no IPv4 address is available. Same SIM in XA2, IPv4 address is available. Other provider in 10III, IPv4 address is available. I am considering a carrier switch.

1 Like