[Release notes] Verla 4.2.0

Here is my bug report - WLAN bug:

Edit: Using a WLAN access point for internet connection (Phone is the client), the following occured:

I have a WLAN access point and a WLAN range extender (D-Link DAP-1325 N300).
They have different SSIDs but the same password.
Both work fine with automatic configuration, but I want manual config, to always have the same IP address for the phone in my WLAN - edit: to access it via ssh and sftp.

Tried to store both (the WLAN and the range extender) in the WLAN settings with manual setup for host address + gateway address + subnet mask.

Access to WLAN works if only one (the access point or the range extender) is stored with manual settings. If both are stored, only one is remembered (the last used), the phone forgets the settings of the other access point.

Maybe because both settings are identical except the SSID?

1 Like

If your SailfishOS version is a licensed install (Android support, Xt9, etc) then the update should come via the UI provided you have ticked the box for ‘Early Access’ releases in your jolla account.

If your SailfishOS version is the FREE (unlicensed) install, then you can update via the terminal.

In terminal, you run the following commands, make sure you have ‘devel-su’ / password first, then;

ssu release 4.2.0.19

version --dup

I did this recently, all files downloaded but install quit at 56%. I finished the update again from terminal using ‘pkcon update’ ~ this replaced missing files from failed install. As per usual with updating SFOS, your mileage may vary.

Also, there are a few precautions regarding the update of SFOS to 4.2 and you should read through the above release with regard to removing certain apps before updating.

1 Like

Sony XA2: Bluetooth mode switching issue
Switching between music streaming and phones calls via bluetooth doesn’t work properly. In order to switch between theses modes I need to turn off, turn on and reconnect bluetooth.

This mode switching is needed to use your phone in a car to receive phone calls while listening to music.

Please fix this :slight_smile:

2 Likes

Using an Xperia 10 II I notice that apps are closing themselves sometimes since I updated to 4.2.0. The window stays open but the app loads anew when the app is brought back to the foreground. This happened to me several times with different apps (gpodder, shmoose, etc.) If this is happening with shmoose I have to log back in to the jabber server. This is making the last (?) working native jabber app less usable. The integrated telepathy is still not working for me (I suspect TLS 1.3 is still the problem) and telepathy-gabble-plus has no aarch64 package and therefore can’t be used as a workaround to fix the broken telepathy-gabble. Is anyone else experiencing apps closing after some time?

Otherwise the Update is a noticable step forward using an Xperia 10 II. The network connection seems more stable and neither the native nor the android apps are loosing their connections as often as they did before. I also appreciate that the MPRIS-Proxy is finally active by default.

3 Likes

I thought I was just being clumsy, but I can also confirm this.

2 Likes

I’ve experienced this bug also on 4.1.0 on a 10 II, so it is not a regression. Not with a car but with Bluetooth headphones: if I am listening to music → receiving a call → switching back to music, then the music does not resume on the earphones but on the phone’s speaker.

Anyhow, plz fix nevertheless. :slight_smile:

It’s because the device runs out of memory. It is becoming obvious that for normal daily driver work, we could really use 8 GB RAM on the phone.

Indeed, it’s a different universe now. Something major must’ve been fixed in memory management, because the OS is now able to kill background apps on demand (like 32-bit XA2 used to), whereas in 4.1 X10 II would constantly run into OOM reaper and freeze all GUI while dealing with it (standard Linux behavior).

In 4.1, I used to manually keep closing Browser and others just to free up memory for active apps, effectively playing a human memory manager.

I hope Jolla takes note of what they put people through on these long release cycles just to stay on this OS…

Exactly! The update itself is great, but it’s the incredibly long release cycle that almost kills it for me. I mean… the last update before this was in early June, right? And we’re in September! If at least bugs were fixed along the way as smaller releases, that would be great, but you’re stuck with a phone that requires work on a daily basis (as you say, making sure it doesn’t run out of memory, turning Android off and on again to make sure that connectivity and crashing issues are fixed, rebooting frequently so as to avoid it crashing often…) for long amounts of time. It’d be great if they could release fixes more often! (in the end, there are a bunch of numbers at 4.2.xx, so maybe Jolla should consider using them!)

4 Likes

Yes. but the memory management seems a bit aggressive in killing background tasks. I had this kill for example shmoose while it was the only running app, aside from the started android support (with the f-droid nextcloud client running [~60 MB RAM]). Normally top shows between 1,2 and 1,5 GB RAM used for buffer/cache. It’s not happening all the time but I had 3-5 apps closed since 4.2.0 was released and when it happened I never had many apps open or did something where I suspect much memory being used, like an browser with some tabs open for example. It always killed apps while there were only 1-2 small apps (<200MB Memory usage) open. So it seems that a normal idling device with android active can be enough that under certain conditions it fills the memory to the point that it needs to kill background tasks.

2 Likes

Same Android-internet issue here:

Phone call leads to drop the mobile internet connection for firefox (android app). I need to turn off and on wifi and mobile data to regain internet access.

Might be an issue with vpn connection (I use too).

1 Like

Several times, even with restarts in between, I have experienced no sound when making calls. No headset used, just silence in both ends. This has happened with different contacts (different networks), with an Xperia 10.

1 Like

I added a calendar:
webcal://ical.dbu.dk/P…
It went OK but when updating the calendar the appointments will be there 2-times. If i did an updated again I will have it 3-times - and so on.

When deleting the calendar the appointments will still be there.

To delete the calendar/appointments I did the following in the terminal:
devel-su (become root)
pkcon install sqlite (install sqlite)
sqlite3 .local/share/system/privileged/Calendar/mkcal/db (Open the database)
select * from Calendars; (List the Calendar Tables)
DELETE FROM Components WHERE Notebook="{calendarID}"; (delete)
DELETE FROM Calendars Where CalendarId="{calendarID}"; (delete)

After a few days of working with this release, I have to admit it feel pretty buggy. There’s some weird gliltch where the keyboard becomes stuck in numeric mode. Then it’ll simply show that keyboard instead of the normal one everywhere.

So far the only way to get the keyboard working normally again is to restart the phone. At some point during restarting it, android support stopped working. Now it refuses to start. At least my keyboard works again (for now).

Before it completely stopped working, there were many issues with android and connectivity when on wifi. It worked OK on 4g, but when you connected to wifi it would stop working until you restarted android support. This was on both an XA2 and a 10.

I haven’t found a way to get it working again. Uninstalled android support, but am unable to install it again, all I get is “problem with store”

2 Likes

This is a regression indeed, that was introduced when rewriting the plugin gestion in Buteo. As far as I can tell, the regression is affecting every account where the cleanup function is not called on account deletion. Here is a PR proposing a fix for it :

1 Like

I’ve noticed the text prediction on the French keyboard is mostly broken, at least on the Xperia 10 II. Other keyboards (English, Dutch) work fine, but the prediction on the French keyboard mostly shows useless predictions (like short acronyms when you’ve typed a long word) even when you’re spelling the words correctly. A reboot didn’t help.

2 Likes

Hello,
Works fine in French on my XA2 plus.

1 Like

Is it possible sort of “reinstall” 4.2.0 without flashing the phone? Maybe that will fix some problems, in case something went wrong during update.

1 Like

I can only confirm that on X10ii the French prediction is working very badly, while the English seems ok (except for the bug about the frozen prediction text which affects all languages).

1 Like

Check out sfos-upgrade on openrepos, I think there was something related there: sfos-upgrade | OpenRepos.net — Community Repository System

If the configs in home folder are borked, it can’t help, though.

1 Like

Thank you for confirming, I’ll make a bug report about it. Edit: see below