[Release notes] Verla 4.2.0

Check out sfos-upgrade on openrepos, I think there was something related there: sfos-upgrade | OpenRepos.net — Community Repository System

If the configs in home folder are borked, it can’t help, though.

1 Like

Thank you for confirming, I’ll make a bug report about it. Edit: see below

Thanks for confirmation, that’s what I thought too.

I’ve got the feeling - but can’t prove - that it happens since 4.2.0 more often than before (on my XA2).
I mostly have max. 4 apps running at the same time so it very rarely happened that an app was closed automatically. Now it seems to happen more often. But yeah, I don’t have real proof.

I don’t see a serial number on the About page on my Xperia 10 ii

1 Like

Neither in my Xperia 10. There’s manufacturer, device, imei, os- & drivers-versions, mac- & bluetooth-addresses, and encryption. But in Xperia X serial number is shown.

Android frames displayed in wrong order looks like to be fixed in 4.2.0. Anyone else confirming?

Vivaldi freezing is also fixed! Wohoo!

After a few days of use in 10 II (Dual SIM) I would say that 4.1 was operating more smoothly. Battery life is significantly reduced, loosing 40% overnight and phone barely lasts 24hrs (before it would easily survive 2 days). The text prediction as other mentioned takes for ever and freezes the phone once you select a word from the proposed ones. When on WiFi most of the Android apps think that there’s no internet connection. When walking outside the house, the phone keeps looking for the WiFi instead of switching to mobile data.

After flashing I had to do several reboots to get things working and at least once the phone was stuck with green LED on and no way to light up the screen. Exchange didn’t sync until after serveral reboots.

1 Like

Hey guys,
I just confim the following aspects for Sony XA2:

→ Not for Sony XA2: Smoother experience with 4.2 and no battery drain as decribed above.

→ Yes, this problems occurs with my XA2 too.

→ Yes, so annoying! Also in my XA2!

→ No, installation went perfect. Only problem: download status bar got stuck after ~10%. The progress carried on in the background.

1 Like

Tried all steps, no updates found. But seemes problem was fixed, at least from last night till this moment everything is fine. Maybe it was somehow related with post_sfos-upgrade command.

I updated my X10II to 4.2, but the gui method failed repeatedly, the download didn’t even start. I ended up installing sfos-upgrade and using it. The download went ok, but RPM script segfaulted on two packages: sailfish-ca and popt, so I had to try it three times. In the end everyting went fine and device works smoothly :slight_smile:

Some notices:

  • Android apps feel more responsive
  • Android apps frames get rendered in correct order
  • Vivaldi (by extension Chrome, Brave et. al.) don’t crash anymore after 30-ish seconds
  • Predictive text works fine 98% of the time
  • Lock screen media controls: prev/next/pause works, play (aka unpause) doesn’t, at least not with Deezer. Please see my commen of this answer: Status of allowed libraries in Harbour - together.jolla.com
  • bluetooth keyboard still doesn’t work properly on android apps. layout is always english, shift key does nothing. SFOS side works fine.
  • Bluetooth audio control buttons work for next/prev/pause, but not for play. See comment above. I’ll open a new bug report for this. Edit: Logitech keyboard media buttons don’t work, but JBL headphone buttons still work as before. No issue after all!
  • Bluetooth button on top menu desyncs on reboot (Bluetooth is on, button says it’s off. I think this is a known issue… Existed in 4.1 too.)
  • Triple camera works great!
  • Strikethrough over SMS bubbles on XA2 Ultra is still there
  • Edit: JBL bt headset works, except for calls. This was the case for SFOS 4.1, too. I’ll test it with XA2 Ultra on 4.2, too.

Overall it’s a great update, and no immediate regression popped up (except Whisperfish, and WLAN is untested, Bluetooth devices largely untested). Thanks again for great work!

1 Like

It’s still not possible to tick the checkbox in German trains (DB, WIFIonICE) captive portal.

EDIT: this was with Seems to be fixed in as reported by @jollajo


Hello I would welcome any advice before updating my XA2. Sailfish recommends removing the following packages before updating: harbour-storeman and commhistory-daemon

Removing harbour storeman would be no problem. However I cant remove commhistory daemon. When using pkcon remove commhistory-daemon the terminal replies: fatal error this command leads to system crash.

What should I do? Some previous updates already broke my system - I really do not have time to setup my whole system again.

I have found a new bug (XA2 plus). After having received an MMS, no WLAN connection in 4g for Android apps. Connection OK after using “restart network connections” utility.

Well, the source of information I was using did not clearly state any exceptions. The serial number seems to appear on Xperia X and some business customer products only, not on XA2, 10 or 10II. After learning this, I decided to remove the mention of the serial number from the notes.


Thanks for reporting. We should take another look at it to see what is causing the issue in this case.

1 Like

On an Xperia 10 II I experienced several cases of Battery drain with 4.2. that didn’t happen with 4.1. Today it was ofonod that ran at 100% CPU for hours. After an reboot everything is back to normal for now.


I am also experiencing frequent battery drain, ofonod eats up a core. Restarting data using Sailfish Utilities fixes it, until it occurs again.

1 Like

I just noticed the upcoming update! Thank you so much! This in particular caught my eye:

  • Routing phone call voice to Bluetooth headsets improved, also by being less pedantic about the ordering of speech codecs

I knew it would be something like this, because I had some Bluetooth devices that worked and others that didn’t but they would all expose the same capabilities! Can’t wait to test my JBL with it!


In the meantime users with cars BT systems that requires PIN to pair cannot make BT calls in car :confused: