[Release notes] Vanha Rauma

Update went on XA2 with no issues @all.

:warning: RECOVERY MODE NOT ACCESSIBLE via “telnet” :warning:

SFOS release flashed on SONY XQAU52 : ( Vanha Rauma )

Also this release does not provide any access to “recovery mode”.
Last known release providing access : ( Kvarken )

IMHO, a critical issue which should be solved. Thanks !

Further reading: [Xperia 10 II] Unable to reach Recovery Mode - #11 by launchpad

No problem, i can give precise report. Jolla recommendation is to provide clean install rather OTA update. So, i use backup toll and then flash the phone. After restore from backup my all apps are deleted. Android storage folders are empty. Documents and downloads on system partition empty. Calendar accounts not working, mail also. I’m asking: what’s going on? It’s so difficult, to add few folders to backup?


OTA-Updates are perfectly fine and flashing your phone surely deletes all data. It is meant that way.
Where did you find a recommendation to do a clean install in order to do a minor OS update?

In the backup control, right above the backup button, there is a note telling you precisely what will be saved in that backup. Hint: It is meant that way.

1 Like

I am guessing he meant this line:

OR How do I reset the phone to factory settings or here: Total device reset

In the articles is is explained very well (I think) what the different options mean.

Just because you can reflash with every new update does not mean you should.
and / or:
Just because you can upgrade from Windows 1.01 to Win 8, does not mean you should :slight_smile:

1 Like

It never came to my mind that one could understand this as a recommendation against the SF update function. Maybe it would be wise @jovirkku to give an extra hint here although the documentation looks good to me.
People tend not to use the normal update function for good reasons and also based on rumors and misunderstandings.
Emphasizing the normal update process a bit more might help.

Edit: @Seven.of.nine and @atlochowski just brought a similar issue up:


And we had a discussion on update methods in the German section


1 Like

Worked well on my XA2. Thx!

Yes i found it in relase notes as “stop relase”. Oh, sorry, it’s my fault, because i don’t read whole documentation. Are You serious? If I buy commercially available system, not beta-dev-geek relase, but normally available product for end user, can I expect normally functioning backup app or warning “hey, copy all data from Android layer because we can’t write a script”? We protect Your data - oh yes, so where i can found it in backup?

I asked @olf. Since 2022/10/02 - 17:22 there’s a updated version of sfos-upgrade. See https://openrepos.net/content/olf/sfos-upgrade
BTW: @nephros asked the same question earlier :slight_smile: On GitHub.

I feel very sorry for you that you lost data. What I wonder: how different would it be if, in the hypothetical case, you had dropped your phone in the ocean?

By this I mean: how do you view a backup of sensitive and important digital data stored on your oh so fragile cell phone?

1 Like

What is a ‘Stop release’ exactly? I always thought this is a necessary precondition for making later updates, isn’t it?

Maybe better answer:


I’ve got an Xperia 10 II on and have been updating it using the standard updates. This time, after downloading the update, I got warned that I needed to delete probably 100 or more packages that might interfere with the update. I have a couple of Openrepos apps installed, but this list looks completely out of proportions compared to earlier updates. What’s going on here?

Is there something I need to do to help the installer along at this point? Reset something?


I’m doing backup monthly in this case. So now I know the backup app is junk and must copy my data manually every single time. It’s really hard for Jolla, to attach few folders to backup? I must pay next 50€ for that “feature”?

Don’t worry about the message and simply proceed updating. You don’t have to deinstall something manually.

1 Like

What’s this? These two links required reCapcha from me right now. Is this normal new behavior of tjc now?

edit: had a look again because i couldn’t really believe… No it’s not a reCapcha, it’s a hCaptcha, the idiot test wants me to find the pictures with horses.

It looks like the browser is doing something to trigger ‘protection services’ on many websites (I’m assuming you encountered this on your phone). From what I’ve read a captcha shouldn’t be shown if the system can recognize you are not a bot from your earlier actions on a site. At least you were still able to pass the captcha, for now, unlike the case where this happens for akamai or cloudflare: https://forum.sailfishos.org/t/browser-is-blocked-by-akamai-and-cloudflare/

1 Like

Darkly I remember something there was with this issue some months/years ago when accessing tjc while using a VPN tunnel. I use a VPN tunnel.

But: hCaptcha appears when trying to access with Sailfish browser on Volla phone /, and hCaptcha appears NOT when trying to access with Firefox on Linux computer, both connected by the same VPN tunnel.

So maybe a thing with SF-browser recognized wrong by server? Worth a bug report? This I ask not for me now, but for better development of SF-browser and/or Volla port.

Thanks again for your polite request for help from the community. I am sure we all appreciate this.

For my weekly backups I use the SF backup. It does what it says. It backs up SF data.

My important Android apps come with internal backup functions. They do backups for single Android apps.

A general local Android backup would imho be a feature that should be implemented by Google.

Do not ever feel obliged to read documentations. They are made for the less clever. Like me.