[Release notes] Suomenlinna 4.3.0

@sviscapi have you tried to login to shell and run pkcon refresh?

1 Like

Hi @jollajo

I just issued that command. I get a small horizontal bar going from left to right and the message: “Refreshing cache, waiting in the queue”.

Is this the expected result ?

Cheers, Samuel

Yes refresh takes quite a while, depending how many repositories of OpenRepos you added before in Storeman.

1 Like

Thanks for the quick reply. I rebooted the phone and launched that command again. Now it says it’s updating the software list. I also tried to run “version --dup” prior to getting your message about “pkcon refresh”, and it started downloading packages, aliendalvik if I remember correctly. “pkcon refresh” has finished, what should I do next ?

Cheers, Samuel

Enter Jolla Store or Storeman and check again for updates

1 Like

Hmm, that doesn’t look too good: Jolla store reports that no application is installed…

Should I run “version --dup” ?

Cheers, Samuel

EDIT: I restarted the phone and now Jolla store understands that there are applications already installed and proposed 6 updates.

Directly after first boot Jolla Store didn’t show any installed apps either, however since I ran pkcon refresh it shows my apps. Not sure whether that fixed it or Jolla Store just needs some time to update the list.
I’d be surprised if version --dup helps as you’ve just upgraded, but it shouldn’t hurt either.

1 Like

The update went well by UI this time on my Xperia X.
BUT, it restarts every time after 5-6 sec from bootstrap!!
I cannot investigate because of this small amount of time…

1 Like

Thank you for the update. As usual downloading and installation went smooth.
However, Jolla store doesn’t work. Installing an app is not possible. I wanted to reinstall Fernschreiber, but the wheel keeps turning. Switching the system off and on does not help.
The same trouble with Storeman.

1 Like

As for the breaking the touch coordinates in the new SDL2 version this update, I suppose I’m a bit responsible for that as I got annoyed with continuously fixing the touch input coordinates while trying to port some applications to SailfishOS and therefore made a pull request to the upstream SDL2. (About the applications, I hope to release them later when they’re in a more usable state).

As for now, if you’re developing with SDL for SailfishOS, you should probably handle your input somewhat like this at the moment:

SDL_version version;
int touch_x, touch_y;


if (SDL_VERSIONNUM(version.major, version.minor, version.patch) >= SDL_VERSIONNUM(2, 0, 16)) {
    touch_x = event.tfinger.x * window_width;
    touch_y = event.tfinger.y * window_height;
} else {
    touch_x = event.tfinger.x;
    touch_y = event.tfinger.y;

Eventually, you should be able to drop this workaround when the minimum OS version you want to support is 4.3 :slight_smile:


@kea, this is probably related to @sviscapi 's issue. If you haven’t tried, please run pkcon refresh in root console and try again.

Thank you. Can you tell me what exactly I have to type in terminal behind nemo@Sailfish?

In the 3rd party APIs section, there is some weird spacing:

All SDL application s need to be fixed because of a fix to touch input coordinate handling.

1 Like

It is marked in my post. If you’re already root:
pkcon refresh
if not:
devel-su pkcon refresh
you need to enter your password there.

1 Like

PSA: It’s been known for a while that Whisperfish doesn’t work on 4.3. I’ll do my best to get a new release on OR before 4.3 hits main line.

The problem is that a rebuild against OpenSSL 1.1 means that I have to drop support for SailfishOS 3.4, which I intend to keep working for a while. We need to make two separate releases, and figuring out the RPM spec steps for that will take a bit of time.


The app of my health insurance (german DAK) is not complaining about root anymore, that’s great! Sadly it is missing the device lock now in android side and is still not operating because of this… Does anybody know a workaround for this issue?


It doesn’t accept the generated password. I give up now and wait.Mabe try again later.

Kea, I wonder if you are familiar with this: https://jolla.zendesk.com/hc/en-us/articles/202011863

1 Like

@jollajo : just to let you know that “version --dup” downloaded and installed a bunch (200+) of packages, and after a reboot everything seems to be working correctly :slight_smile:

Thank you very much for your help, really appreciated :slight_smile:

Cheers, Samuel

EDIT: actually it looks like I’m back to SFOS 4.2…

EDIT2: proposed update to is only ~400 MB now, was ~800 MB this morning…


Does the GCam port still work on X10II after the update?