[Release notes] Suomenlinna 4.3.0

Hi, I got the same problem during update. When system started downloading update to SailfishOS 4.3 I received a message that I have to remove WebPirate and ofono-alien-binder-plugin. I removed WebPirate but not ofono-alien-binder-plugin.
Now, after update finished downloading I have a really long list of packages, that looks like all packages installed in the system.
I downloaded 4.3 update directly after updating from 4.1 to 4.2. The only change in ssu config I made was setting the password.

I successfully install paid Jolla OS 4.3 Version for the Sony Xperia X with the g7-patch (https://github.com/g7/sailfishx-patcher-f5321 on a Sony Xperia X Compact Device.

I know this is officially not supported by Jolla, this Unit will be my “Spare and Play” Smartphon, because i´m heavily interested in alternative Operation Systems. My Daily Driver is a Sony XZ1 Compact (nearly same dimensions like the x Compact) with Lineage 18.1 (Android 11 base) without GApps (don´t need it). Sadly there is no patch for the XZ1 Compact, so i go for the X Compact as spare and emergency Smartphone.

2 Likes

I have the following issue (not sure if it was present before this release):

In the Gallery app, I cannot delete a picture: trying to do so will show the usual progress bar, but the image does not disappear after that. It is not deleted either.

I also just got an issue where sending an image via a MMS didn’t work (even with multiple retries).

I use a Sony Xperia XA2.

1 Like

See [Bug] MMS doesn't send pictures when Patchmanager is installed - #23 by dcaliste for MMS

2 Likes

Meanwhile the Sony X Compact becomes my Daily Driver, i really like it with Sailfish OS 4.3!

4 Likes

I only noticed 4.3.0.15 today, and the update went just fine on my XA10II

Great to see security updates are pushed between major releases, please make this a habit!

16 Likes

I pressed the button on my Xperia X. I didn’t watch it closely but it seemed to go just fine and while I am not using it for calls at the moment, other stuff seems to be unchanged

I don’t get an update for 4.3.0.15 with an XA2. No matter what I try. Am I missing something?

Early Access must be enabled in your Jolla account (on the homepage there in account settings). Go to account.jolla.com, enter creds, scroll down, there is ‘Early access to Sailfish OS releases’. Enable there.

Should not be necessary :
2022-02-16: OS version 4.3.0.15 was released to all users as an over-the-air update. Installable images are available in the Jolla Shop 95.

2 Likes

From:
https://forum.sailfishos.org/uploads/short-url/hhP9RMYUiAbmpM14eQntZt6CDne.md

================================================================
SAILFISH OS
Changelog from 4.3.0.12 to 4.3.0.15
2022-02-07

Packages modified
polkit
Updated : 0.105+git5-1.5.3.jolla – 0.105+git8-1.6.1.jolla
- [polkit] Fix for CVE-2021-4034 (PwnKit).
- [polkit] Drop unneeded Debian patches.
- [packaging] Separate Debian patches from the rest
- [packaging] Use pkgconfig symbols for -devel requires
- [polkit] Update Debian patches, drop patches already included.
ruby
Updated : 2.7.1+git1 – 2.7.1+git2
- [ruby] Fix build with newer bison.
sdk-setup
Updated : 1.4.11-1.5.1.jolla – 1.4.42-1.6.1.jolla
- [mb2] Refresh git index before creating a stash.

Is this update really interresting for regular users or is it more for devs (lots of changes in sdk-setup) ?
EDIT: oops, maybe you are all devs in this thread? :blush:

As the version number implies, it is just a (very) minor bugfix/security release.
Probably doesn’t qualify as particularly interesting to anyone.
It is however good, and not not to mention mandatory for the next update.

3 Likes

Did you get the update finally?
(XA2, no EA, updated on 20200216)

Nope, nothing. I tried the GUI update process and through terminal, but apparently there is no update.

Fake news I guess? :stuck_out_tongue_winking_eye:

Did you try the sfos updater tool from OR?

It IS interesting. There are users in this forum, that are not professional devs and also not users that only want to have a nice phone working and not thinking why, but want to learn and understand. (me, :wink: )

For sure, me too! (always had nice phone NOT working and ALWAYS thinking why :sweat_smile:)
I’ve not been clear enough. Just ment: Is this update meaningful for those who are not using the SDK (like me who’d love but not yet clever enough).

1 Like

This fix should be important for any security-concerned user:

  • [polkit] Fix for CVE-2021-4034 (PwnKit).
3 Likes

Oh, ok, thanks.

I just flashed the 4.3.0.15
Not all packages are yet updated to allow install on this version of course.
Don’t know if it’s right but as it didn’t work, I installed Storeman by downloading it doing:
$ /usr/bin/sailfish-browser https://repo.sailfishos.org/obs/home:/mentaljam/
and then install.

But in storeman, packages can not be seen (chum, patchmanager…).

How do we inform the system/zypper to consider it as the previeous version already?
Is it set ssu 4.3.0.12?
EDIT: Yes, seems to work. Have to remember to set it back to 4.3.0.15.

The Chum GUI is in Storeman/Categories/Programmes, there is SailfishOS:Chum GUI application.

After updating to SFOS 4.3.0.15, Chum didn’t show any apps, so I had to manual config ‘4.3.0.12’ in Chum’s settings. After this it worked again like a charm. Downloaded apps work fine.

2 Likes