[Release notes] Suomenlinna 4.3.0

As for the breaking the touch coordinates in the new SDL2 version this update, I suppose I’m a bit responsible for that as I got annoyed with continuously fixing the touch input coordinates while trying to port some applications to SailfishOS and therefore made a pull request to the upstream SDL2. (About the applications, I hope to release them later when they’re in a more usable state).

As for now, if you’re developing with SDL for SailfishOS, you should probably handle your input somewhat like this at the moment:

SDL_version version;
int touch_x, touch_y;


if (SDL_VERSIONNUM(version.major, version.minor, version.patch) >= SDL_VERSIONNUM(2, 0, 16)) {
    touch_x = event.tfinger.x * window_width;
    touch_y = event.tfinger.y * window_height;
} else {
    touch_x = event.tfinger.x;
    touch_y = event.tfinger.y;

Eventually, you should be able to drop this workaround when the minimum OS version you want to support is 4.3 :slight_smile:


@kea, this is probably related to @sviscapi 's issue. If you haven’t tried, please run pkcon refresh in root console and try again.

Thank you. Can you tell me what exactly I have to type in terminal behind nemo@Sailfish?

In the 3rd party APIs section, there is some weird spacing:

All SDL application s need to be fixed because of a fix to touch input coordinate handling.

1 Like

It is marked in my post. If you’re already root:
pkcon refresh
if not:
devel-su pkcon refresh
you need to enter your password there.

1 Like

PSA: It’s been known for a while that Whisperfish doesn’t work on 4.3. I’ll do my best to get a new release on OR before 4.3 hits main line.

The problem is that a rebuild against OpenSSL 1.1 means that I have to drop support for SailfishOS 3.4, which I intend to keep working for a while. We need to make two separate releases, and figuring out the RPM spec steps for that will take a bit of time.


The app of my health insurance (german DAK) is not complaining about root anymore, that’s great! Sadly it is missing the device lock now in android side and is still not operating because of this… Does anybody know a workaround for this issue?


It doesn’t accept the generated password. I give up now and wait.Mabe try again later.

Kea, I wonder if you are familiar with this: https://jolla.zendesk.com/hc/en-us/articles/202011863

1 Like

@jollajo : just to let you know that “version --dup” downloaded and installed a bunch (200+) of packages, and after a reboot everything seems to be working correctly :slight_smile:

Thank you very much for your help, really appreciated :slight_smile:

Cheers, Samuel

EDIT: actually it looks like I’m back to SFOS 4.2…

EDIT2: proposed update to is only ~400 MB now, was ~800 MB this morning…


Does the GCam port still work on X10II after the update?

Strange: I now have more system storage then before the update.

Yes Jovirkku, I am in dev. mode, pushed the right dots, got a generated password. But thanks for the link. I will check again.

Update hanged at around 90% of downloading (judging by the highlighted part of picture), with message about needing to uninstall puremaps, sailfishconnect, qca-qt5 and few other packages, as pkcon was hanging after waiting for 2h restarted the phone, now pkcon refresh is waiting forever in queue, storeman complains about zypper cache, after killing packagekitd the error changes to:
[|plugin:ssu?repo=openrepos-CepiPerez] Repository has no alias defined.
Anyone experienced similar behaviour? It’s all even before the update which is weird as hell

The explanation very clear! I did it right, yet I get ‘Auth failed’ all the time.

hi, any hints how i can make the mediaplayer find my music? was using the sailfish utilities from jollastore, doesn’t work anymore since upgrade…
also all pics on my encrypted sdcard are missing… how do i reindex media?

thx in advance for any help…

@jollajo : the update to version is supposedly downloaded and ready to be installed. Are there any checks I could run to make sure the downloaded archive is complete (md5sum or similar) ? And where is the update located on the filesystem ? Is it a single zip-like file or a collection of RPM packages ? I’m just trying to avoid running into the same issues I faced this morning when I first tried to update :wink:

Cheers, Samuel

Try typing the SSU password yourself instead of using the generated one. Do not forget to save it.

Not that I’m aware of. On my side my second try worked as expected.
I wish you all the best and hope you won’t need to verify your backup strategy any soon. :blush:

1 Like

This update sounds massive in terms of solving annoying (and partially long standing) usability bugs.

  • Sharing to android apps
  • faster camera start
  • connectivity fixes for network transition
  • rooting issues of banking apps
  • VPN ipv6 leaks

Christmas came early this year! Thanks a lot! :christmas_tree:

edit: Had slight installation problems: Installation got stuck on full progress bar. Did a hard reboot (volume up + power) and gladly everything worked with version number being 4.3. Only Fernschreiber app is gone from the app grid (which potentially caused the error, it was warned as being a conflicting package before installation),