[Release notes] Struven ketju

To provide more context:

10iii - went fine - but Android App support still needs to be manually started on device restart!
XA2 Plus - went fine (inc Android App support)
X - went fine (inc Android App support)

Just to clarify this one. Did you upgrade from 4.4.0.x (or older) or from

If you updated from 4.4.0x (or older), did you follow this one AppSupport upgrade notes

1 Like

I came from 5.0.21. i had the same problem in that one too, and possibly older 4.5.x versions too.

But i’m not really seeing anything in the link that could explain the problem - or anything that i noticed when i did the 5.0.21update a few months back.

What am i missing?

Thank you @rainemak , this explains why the update of my 3rd X10 failed. I didn’t wait patiently but fiddled around and rebooted the phone while update was not ready yet.

I think it is rather a lack of the feature than not functioninh

1 Like

If you implemented individual ringtone for dual sim models, why didn’t you implement individual ringtones for calls in general? As there already is a third party app doing so it shouldn’t be that hard to implement… Thanks for the update anyway! :slight_smile:


No update was found on XA2 Dual SIM :confused: The current version is, checked multiple times for updates since the release, to no avail. It always says “Up to date”. Also removed and re-added the Jolla Account, got the same result.

1 Like

I like this frequent small updates. Keep up with the developmente of core feature of OS


Did you by any chance transfer the licence to this device? Could be the original imei is still linked to your account. It happened to me, I contacted Jolla and it was fixed in 24hrs.

was the Bluetooth issue fixed?(XA2)
an example:

That’s a good tip. But I see the correct IMEI on Jolla | Login as one of the (three) devices.

Happy Jolla Tablet user here :slight_smile:
The update went well and I’m greatful that the device still gets regular updates. Thanks a lot, Jolla!


Did this update break lock screen controls for Android apps? (Xperia 10 III)

In the previous update, I was (usually) able to control e.g. the Audible app when the phone was locked–meaning there was a play/stop button on the lock screen for it.

Never mind. Powering off and back on seems to have fixed it.

for me on 10III, 4.5 bluetooth is the same in and on some boots, it doesnt work unless i do:
rfkill unblock all && systemctl restart bluetooth && sleep 2 && systemctl restart bluebinder
once its working, it stays working until reboot.


BT seems totally broken now, so I totally regret upgrading :confused:

This worked fine before, now it doesn’t and restarting BT doesn’t help at all.

1 Like

Update from .21 to .24 was approx. 50 MB and went well on X, XA2. Thank you for another update!

Did you reboot? What device are you using?

Xperia 10

Unfortunately I have to report that the hotspot (tethering) does assign the same IP address to two clients that are connected do the hotspot at the same time. This is not 0.24 only but since the update to 4.5.0.x generally .

Could this happen if the devices have the same mac address?

I never changed a MAC address and also I wouldn’t know how to do this. The two clients are a Volla phone and another Xperia 10, while the first Xperia 10 from which I tell ist my general internet access for everything in the house, with VPN, and nothing else installed on it.
A Volla and a Xperia 10 should IMHO have different MAC addresses.
Also I checked right now in settings/product information and found different MAC addresses.
Volla begins with 58:9e…
Xperia 10 begins with 38.78…