[release notes] Pallas-Yllästunturi 3.4.0

Does the update server need a reboot? Trying to download the upgrade to 3.4.0.24 but it seems to be stuck at a few percent downloaded of only 140Mb.

I got that error message about a whole bunch of packages. I could still select ‘Install’ and go ahead without removing any of those packages, though. I’m not sure what the warning was all about, because the packages it warned about didn’t really make sense, e.g. opus or libjpg, or in your case gnupg2.

1 Like

That worked! Thank you so much!

I’ve posted a bug report about this issue: Update from 3.4.0.22 to 3.4.0.24 urges user to remove system packages

This version is currently only available as Early Access (=Beta). You can enable this in your Jolla Account at https://account.jolla.com/

2 Likes

bluetooth connectivity improved. my sony :slight_smile: car radio now connects with x10 within 10-20 seconds. before it took minutes, jumping between audio sources etc.

after reconnection sound may stutter but pause , 5 seconds play fixes that.
so for me, great improvement

if only xperia 10 were a better device. camera is dead now (autofocus), screen stopps to work now an then and case is broken too.

1 Like

It seems I didn’t check properly and the issue is with OSM server, which has its own version of zlib. When I try to run it it errors out with the following message:

harbour-osmscout-server: /usr/share/harbour-osmscout-server/lib/libz.so.1: version ZLIB_1.2.9’ not found (required by /usr/lib/libpng16.so.16)`

I only just now noticed that it uses a local libz library for no apparant reason.

Edit: Was managed to fix it by removing the local library and symlinking it to the version in /usr/lib.

This is not a problem but the intended way. We will follow our convention to publish the flashable images at the same time with the roll out of the OTA update to all users. If everything goes well this should happen in a week or so.

7 Likes

Thanks to all the Jolla team. Update to latest RC went smoothly on my X10 and XA2+ :+1:

1 Like

My XA2 update has been installing at about 95% for two hours now. Should I still wait or what?
Update: Never mind, fixed it with
ssu re 3.4.0.22
version --dup

New buttons in email app look ugly to me, and hate that call answer UI change. What’s the point of fixing stuff that isn’t broken? Pulley menu is one of the key features of Sailfish OS UI, and now it’s being replaced by tiny buttons? I don’t think that that was the idea of Sailfish OS swipe UI.

6 Likes

Just adding your own workaround from the Jolla Market comments here :wink:

To fix gPodder manually install python3-sqlite in the terminal with pkcon or zypper after the update.

This is fixed in 3.4.0.24.

1 Like

The Remote Keyboard does not show up in my Android apps since 3.4.0.24. Is there any help?

Since the upgrade, I cannot update the “documents” and “notes” apps. I have tried to delete them and now, I can’t install them.

Now I have tried to use the browser and all I see are black surfaces instead of the webpages.

Please note, that this only true for upgrading SFOS at the GUI.

At the command line, sfos-upgrade takes care about unapplying all Patchmanager-Patches before upgrading, but when upgrading manually at the command line (e.g., per ssu re a.b.c.d && version --dup) one shall unapply all PM-Patches before doing that.
While other safety measures in PM3 should prevent major damage to the SFOS installation when upgrading SFOS manually at the command line with PM-Patches applied (in contrast to PM2), you should avoid trying this.

7 Likes

This post was flagged by the community and is temporarily hidden.

6 Likes

As usual, if you decide to not upgrade immediately, be careful. Do this:

Check : ssu s
ssu will probably return (wrongly) “3.4.0.24”. Then do this:
devel-su => ssu re 3.3.0.16

The email app also lost good ambiance support, especially for plaintext emails that are now displayed with an ugly white background, rather than the usual translucent background of the ambiance, resulting in a bad integration rendering.

I really hope the dev team listens to the user feedback here and rollbacks the changes on the email app at least.

8 Likes

i dont get return wrongly 3.4.0.24

1 Like

Depends on your upgrade checking preferences (manually, always, WLAN only)

Could it be possible to make a document saying which things we have to do in the terminal after installing/upgrading to 3.4 ?
It will be a great help