[release notes] Kvarken 4.1.0

Just tried again and it worked fine. I do have an older license for the XA2

3 Likes

Yes, it works now too.

2 Likes

Right, I am feeling embarrassed now.

Apologies for the great confusion. It should be clear now, after fixing a configuration issue in the shop backend and after some talking.

You are entitled to the discount if you have had a paid Sailfish X licence for any Xperia device previously, or if you have used a Jolla Phone/Tablet (and signed in to your Jolla account).

2 Likes

Bought with discount deducted automatically! Perfect! Thank you!

Did not show up with my account for whatever reason.
Well, Jolla can surely need my additional €20 :money_mouth_face:

I can’t install the android app support on the xperia 10 II , am i the only one ?

1 Like

@sanginteret:
Is it that
a) It is not visible for you in Jolla Store, or
b) The installation is failing?

If case a), have you bought the licence, signed in to your Jolla account from the phone with the same account (that bough the licence) and restarted the phone?

If case b), please explain what happens. Can you install other apps, like Exchange?

1 Like

it’s case b and i can install exchange without issue

1 Like

Is it OK to have the same account for two devices?
I recall someone mentioned that you should set up a second account for your new device, to avoid clashes, but maybe I wrong.
I plan to keep my existing Xperia X w/ Sailfish and get a new license for my new Xperia 10 ii. Should that be feasible with one Jolla account?

Update 2021-05-28:
Contacted Zendesk and received this response:

You can buy several licences on one Jolla account. The last bought licence will be activated on the device which is restarted (or logged in on Jolla account). The licence and the device must be “compatible”, i.e. Xperia X needs an Xperia X licence etc.

So all looking good, will be interesting to go through the flashing experience again on a second device.

1 Like

same here: can’t install android app support for Xperia 10 II from within the store, although:

  • I can install other apps from there.
  • It is offered to me
  • I bought the license

Installation will always fail.

Anyone having trouble with installing Android App Support to Xperia 10 II,
please file a ticket on Jolla Care at Submit a request – Jolla Service and Support.

If possible, consider collecting some logs from your device.

  1. Enable the Developer Mode. See this article.

  2. Launch the Terminal application.

  3. On Terminal, et super-user rights (root rights):

     `devel-su`
    
  4. In Jolla Store, try to install Android App Support

  5. On Terminal, again, collect the journal log to a file:

     `journalctl -ab --no-pager --no-tail > journal.log`
    

Attach journal.log to your ticket, please.

1 Like

i have installed the android support via the terminal.

I use the following command: devel-su zypper install aliendavkin

The i forced the installation because there has a conflict between two package (apkd and apkd8)

It’s now working.

would do, but not possible yet, due to the Xperia 10 II not yet included in the drop down field for devices. :slight_smile:

What, where? Aha, in Zendesk? A moment.
DONE.

4 Likes

The unlimited joy when you can finally switch fully using your Xperia 10 II. Thank you Jolla! Sailfish seems to work fine with only some small inconveniences that I’m sure will be ironed in future releases. :slightly_smiling_face:

6 Likes

@sanginteret:
You may have a mixed bag of software in your device now as apkd belongs to the Android 4.x devices and apkd8 for the Android 8-10 devices.

If you want a clean installation to avoid additional problems, please consider reflashing your phone.

We recommend installing everything via the UI. Please avoid going to the command line.

4 Likes

the correct baseimage for the dual sim variant still is Sailfish_OS-Jolla-4.1.0.24-xqau52-0.0.1.43 with a date of 20210520?
The download did not seem to change for me after buying the license vs the free version I had before.

Yes, it is the correct one.

1 Like

for me, removing apkd by using “pkcon remove apkd” did solve the issue. Everything was installable over the UI after that.

I guess what happened to me was some bad luck with me trying an Android app (I think it’s been here maps) from the store in parallel to the Android support itself.

So one should be fine if one installed the android support first, and only then android apps.

2 Likes

@arisel: thanks, that confirms our current theory. It is most likely so that installing Aptoide and/or Here befre installing Android APp Support brings in ‘apkd’ to the phone unnecessarily. This is turn prevents installing Android App Support.

Deleting apkd at the command line (like you did) or uninstalling Here and Aptoide should help.

Edit/few minutes later:
Yes, uninstalling those apps helps, tried myself.

6 Likes