[release notes] Kvarken 4.1.0

Yes, indeed. But we are working to upgrade the browser engine again.


But please keep the version need >=0.4.1 in patterns-sailfish. Else someone could try to install older version…


Hi @jovirkku. Could someone Location specialist at Jolla comment on GPS stopped working why XA2 Google’s SUPL server seems to work better for acquiring a lock vs /etc/gps.conf default supl.sonyericsson.com location indicator continues flashing forever.

1 Like

Thanks for this release. Update went smoothly on my XA2 Dual-SIM. So far no obvious problems detected. The phone works smoothly and battery life seems normal (similar to before the update). 10 II still waits in the drawer for official release [not EA] and possibly AlienDalvik becoming available.

Yep, same here (Xperia X) It’s annoying, as hell, Right now marking ambiances as favorite makes no sense now, they should at least be shown first.
I hope this one will be fixed in final 4.1, Scrolling trough long list of not used ambiances to get the one you need is ugly.

1 Like

A post was split to a new topic: Google services

Just had this happen again, so the problem isn’t fixed… This is such basic functionality that isn’t working.

1 Like

Nice to see another update, in a quite regular time window as always :slight_smile: But honestly i am missing a bit the highlights of this release. There were mentions about the documents app that should be extended to be able to edit textdocuments. But there is nothing to see from that in the update, or did i misunderstand something? Apparently it has been worked a lot on the Android Layer of the newer devices. For me as a long time Xperia X user, it doesn’t change anything though… Don’t see it as rude, but normally, we saw a whole list of OMP contributions, but just a small mention this time. What happened actually to the Huawei devices for the russian census? I know Corona came in between. Its just that these million devices would boost the Sailfish OS marketshare to neverseen levels. Maybe then we would get the attention of investors and other telephone companies or manufacturers :slight_smile:

1 Like

My wifes phone, an Xperia 10 Dual SIM, is still on SFOS 3.4 AND does not see the update in Settings / Updates (shows “up to date, no update available”)

My questions now are:

  1. Can I update directly from 3.4 to 4.1 by CLI? (I assume, no…)
  2. With what CLI command can I force the phone to update first to SFOS 4.0?
  3. With what CLI command can I afterwards update to SFOS 4.1?

It’s a Sony Xperia 10 Dual SIM, and paid licence.

Its an ea release early adopters. If i remember it correctly, you have to check a box in your Jolla Account. But following your message, i understand that you got the update and your wife not. That would be weared :confused:


OK, thank you! the successfully updated phone is my “experimental phone”. The other ones are in normal mode.

But my wife’s phone doesn`t even see the update to SFOS 4.0 ! It’s still running on 3.4. So I have to update by CLI command.

So I will check out the 4.1 on my ‘experimental phone’ and leave the other ones as they are, but remains the problem to update from 3.4 to 4.0 by CLI.

1 Like

Cheched it just now, very strange! My ‘experimental phone’ is NOT in the early access mode, developer updates are NOT checked in Settings/Developer options! Despite of this, the phone did see the update to 4.1 and updated successful!

updated to 4.1 today, no glaring issues. Any plans to make the offline location data for the americas available?

1 Like

I did now update her phone by cli in devel-su mode with

ssu re
version --dup


ssu dr customer-jolla
pkcon refresh
version --dup

Her phone is in german language, and the file browser should appear as “Dateiverwaltung”, but it did not but as File browser AND it did not display PDF files. Also the white dot on the upper right corner after tapping a PDF file was missing.
So I deinstalled the file browser manually and installed “Dateiverwaltung” new from the Jolla Store. After this it works fine.

It may not be a fix but tracking this here is much appreciated. Thanks!

I believe the newly added ‘Desktop site’ in browser’s menu wasn’t mentioned here?

  • And… Is it just my XA2? Or can we no longer access Android’s settings hitting the back button (Show Licences) ? It immediately closes the window
    I installed a settings shortcut .apk(which is actually better)

  • Not surely related but most probably is…
    Editor could no longer open files (built-in file picker) after the update (error: could not load page)


Use sfos-upgrade from Open Repos.

This has never failed me.


Doesn’t that also affect 4.0? You can use apkd-launcher com.android.settings on the terminal or use the app AlienDalvik-Control from OpenRepos.

Probably related: Alien Dalvik options not working in on Sony Xperia 10 Plus

No it has always worked on 4.0

I can confirm that I experienced this (on Xperia 10ii dual sim following flash of 4.1.0) where my Wifi network password was not retained. There were also other situations where, following flashing the OS, initially logins and credentials weren’t saved. After a reboot however this seems to have fixed the issues.

Examples - Google Account sign in not saved. Audio recorder app appeared not to have saved recordings (In fact recordings were saved but were not shown under Recordings tab until after a reboot.)

Also I was initially unable to complete registration of Whisperfish (Reported under Whisperfish thread) until the phone was rebooted since the registration hung after input of the OTP Signal code.

Hope this is helpful in identifying possible cause.